Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retroarch Hotkey Issue



  • Hey guys I`m hoping someone can help because my brain is so mumbled I may be going a little insane.

    For years I have wanted to build a retro cabinet and a few weeks ago I actually made a start. I have the latest Pi sat inside my cabinet and I`m using an IPAC 2 running in keyboard mode. I have all my controls setup after following a tutorial on here.

    I am now at the stage where I want to implement bezels and this is where my problem lies. I cannot launch retroarch from within a game, it does not matter what key I set as hotkey or menu. As a test to see if the hotkey was working I tested it with other hotkey binds and they all work except the menu toggle, im lost.

    Any help or suggestions at this point would be so muchly appreciated. Ive only been doing this for a few weeks so apologies in advance if this question is stupid, I`ve searched for the answer for days with no luck.

    Many thanks in advance.

    Mike


  • Global Moderator

    @mexman_uk Can you provide more details about your installation, as requested in https://retropie.org.uk/forum/topic/3/read-this-first ?
    If other Hotkey combinations are working, then maybe the menu_toggle key is disabled, but that's not how a standard RetroPie install is configured.
    Can you also post the contents of the .cfg file for your controller from the /opt/retropie/configs/all/retroarch-joypads folder ? That folder is also accessible via file shares at \\retropie\configs\all\retroarch-joypads.



  • Pi Model or other hardware: (3b)
    Power Supply used: (The Recommended One)
    RetroPie Version Used (retropie-4.4-rpi2_rpi3)
    Built From: (The Original Image)
    USB Devices connected: Keyboard Only
    Controller used: IPAC 2 Controller In Keyboard Mode
    Error messages received: N/A
    Emulator: (Not Working In Any)

    The joypads folder is empty, I`m not using a controller I am using a keyboard and an IPAC 2 controller in keyboard mode. IPAC is running latest firmware.

    I have not intentionally disabled the menu toggle, I have accessed RetroArch and changed the Enable Hotkey and that seems to work, I have also specified the Menu Toggle which I`m assuming is to launch RetroArch from within the game?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.