Please do not post a support request without first reading and following the advice in

Retroflag Snes case

  • @fightingbros power button means - poweroff
    So if the reset button works for you I assume the whole script works.

    How did you do to install?

  • @cyperghost yes I mean power off. Screen just goes black. Reset button when pressed shows no input on monitor, script runs then ES restarts.

    I used the code I found of yours on github. I thought Shutdown was supposed to show a script first. Thx for the help

  • @fightingbros Well what do you expect? I could wrote a message like "Shutdown Now ..." but I think it is not needed. So did you install the pure script and set it up with --nespi+ parameter or did you use the modified retroflag installer?

  • @cyperghost I was under the impression that before powering off a script would run on the screen 1st based on YouTube videos I watched. I initially used the nespi script on github. When the power button just shut it off without the script I Googled some help and found your script. I went to command line and entered it.

    Sorry if I'm missing something. Old dude who barely knows anything about code etc

  • @fightingbros So I assume it works ... can you show me the link to the video you mentioned? I'm not sure how you installed it. Does the LED blinks 4 times if you press the power button?

    If yes then you did use the bash install, if not you did use the python installer.

  • @cyperghost ok so now it's doing what I expected. It's running a script on screen before shutting down. Thanks!

  • Hi
    @fightingbros It seems I am having the same issue as poster above shame he did not reply with what he did to make it work.
    I too had no luck with the official shutdown (rasp 3b+) in retropie 4.4
    The reset did nothing, the shutdown didn't give any script running text on shutdown. Whilst it DID shutdown after 10 seconds or so my fan and power light on the pi remained on.

    I installed the @cyperghost script and things are better. Just like the guy above reset works as advertised

    The power of works AND fan / pi power light goes off but shutdown is instant with (my concern is) no time to write anything or run any scripts to shut down safely) and there is no script text. I am worried my safe shutdown is not acting safely. Is there any way to test?

    Sorry I am new to the pi and to coding. I just pressed F4 in retropi and ran the 1 line command to download shown in the CRC github which is linked earlier in the thread for the modified retroflag installer I have done nothing else


  • @bigmike20vt
    That is understandable as a Retroflag case user myself.
    A good few things to test:

    Pressing the reset button in the middle of a game, should exit retroarch and most emulators and return to EmulationStation.

    Make a manual edit to a rom/game in emulationstation metadata, just add a rating or add some games to favourites. (Game Collection Settingsneed to be configured to list favourites.) Then either reset or poweroff, the metadata should be saved.

    If the data isn't saved then maybe the original retroflag script wasn't uninstalled.

    If no script is installed then it wouldn't do anything.

  • Hi
    @Efriim Thanks for your reply. Great idea on the rating / adding something to favourites etc before a shutdown to test, I should have thought of that.
    I know the reset is working, it does exactly as you suggest it should. I will get on that tonight or tomorrow and if it is working will post back to confirm as such and it is just that the script runs super fast (which is great if so)

    Many thanks again.

  • Hi
    just a quick update to this. I never did find out what the issue was however I have just wiped the card and started again, and readded the crc shutdown code........ and it works a treat!.

    Many thanks

  • Sorry to open this up again, but in case it helps anyone, I found a different solution that worked for me (symptoms at bottom of post). It turns out that the power and reset buttons wouldn't function properly because I had accidentally installed the GPi case script instead of the picase/NESPi case script. Because it said on the Github install instructions here it was the Retropie script, I didn't consider there was another install script. The difference between the two is the text "_gpi" after "install/" (see below), which installs moderately different scripts. Even though I tried re-installing the correct one multiple times it seems it did not overwrite the old one. I hope the solution below helps some of you!

    Solution: I ended up having to re-installing it after uninstalling the old ones using the instructions as per this post from derreck503 on July 31st, 2018:

    GPi Case Script Install Command: wget -O - "" | sudo bash

    Picase/NESPi Case Script Install Command: wget -O - "" | sudo bash

    Symptoms: when I had the Safe Shutdown switch off, the power button would turn it off without running the safe-launch script. Likewise, the reset button would reset the console without running it. When I switched it over, the LED either dimmed or got brighter (can't remember). After that, pressing either button had no effect, but I believe that when the console was shut down but still plugged in, it was still able to turn on.

  • Retroflag cases aren't compatible with the RPI4B but I would like to hear of someone who managed to make it work. I'm also interested if someone has integrated an RTC hat to fit in one of these cases.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.