Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

OpenBOR 6xxx OpenBeta Testphase



  • Hello ;) at first this won't be possible without @zanac

    Scriptmodul Install

    I added some scriptmodules for experimental usage here

    With these you are able to install all versions of openbor available on your own device. I added the original openbor scriptmodule, too - if you want to restore the original one. This is the prefered way to do!

    Please use the patch provided here to compile for RPi0/1 devices
    Thx to @SinisterSpatula

    Obtain PAK files

    Go to the official forum CHRONOCRASH and get newest PAK version directly from the several authors.
    Use one of the several gamedatabase like here to obtain some modules.

    After downloading put them to your ROM directory ports/openbor
    You can participate into thread OpenBOR modules we like and add your favourtite modules there.

    Confident in self compiling

    Then read here how to compile your own versions.
    Updated guide on 2019/05/09

    A Workaround to setup JoyPads automatically

    You need a keyboard connected ONE time and configure ONE game
    Then follow instructions here and every other game will be setted up automatically!

    History context in developing (рубеж)

    First version was build Анна (anna)
    Second build with GL4ES support was Борис (boris)
    Third build with advanced options is Василий (wassili)
    Fourth build with PAK CLI input is Галина (galina)
    Fifth build with a small hop from dev-6510 from October to 6510-dev from May 2019 - codname Дмитрий (Dmitri)

    Small History Text (рассказать историю)

    It was @darknior who brought OpenBOR to a wider audience in this forum [~ august 2017] because he has done a small patch that offers Command line Input like OpenBOR Asterix & Obelix.pak and this was so necessary ... because EmulationStation ... our frontend lists files with a suffix as system and just parses the commands...

    Then @BiZzAr721 and @hansolo77 created a list of working mods [mid 2018], this made me aware of OpenBOR and I wrote some scripts to autoconfigurate OpenBOR with different settings and did the call to runcommand which offers LOG support and more opertunites for setup. And now @zanac made newest versions available via GL4ES wrapper with some testing done by various people ... and that's the story of the OpenBOR development [for RetroPie]... (with some missing details for sure)

    As a small teaser - This game is enabled for game playing now ;)
    DOWNLOAD AVAILABLE HERE
    Greetings to @oilusionista for making this mod


    Binary builds

    there some testing builds made for OpenBOR. If this works good it may be used as a full featured OpenBOR engine. Compiled on a Raspberry Pi 3 1.2
    with RetroPie build 4.4 (md5sum: 56988addb60361a2257a61c69d9fceac)

    Install directory is USERHOME (for RetroPie on Rasperry this is /home/pi/openbor_openbeta)

    RetroPie 4.4

    Please use this one liner to install via SSH
    wget "http://raw.githubusercontent.com/crcerror/OpenBOR-63xx-RetroPie-openbeta/master/openbor_openbeta.sh"; bash openbor_openbeta.sh galina; rm openbor_openbeta.sh

    For newest release 01.05.2019
    wget "http://raw.githubusercontent.com/crcerror/OpenBOR-63xx-RetroPie-openbeta/master/openbor_openbeta.sh"; bash openbor_openbeta.sh dmitri; rm openbor_openbeta.sh

    RetroPie 4.3 and lower

    For RetroPie < 4.4 I compiled a binary from galina patch, too. You can download from here if RetroPie asks for missing dependencies. I recommand to first install via bash script mentioned above and then just copy binary to install location.

    If you want to see installers source code then please do so ;) Since Василий I created this installer.

    Thanks @zanac for getting so deep into this code. A small development history can be read here

    Tagline
    @darknior @BiZzAr721 @hansolo77 @zerojay




  • @cyperghost Awesome! This is coming together fast! I will make a point to find time to test.
    There's so much gong on in the retropie scene right now - can't wait till the Raspberry pi 4 comes out......... in 2021 :/



  • @BiZzAr721 Yes we need some testers now. I made just a small hack to the lib location... it is now fixed to OpenBOR binary location in .\liband I made the changes @zanac suggested with compiling flags. Btw I wanted to write a working bash installer with usecases related to version names ;)

    The lib-fix is a way to avoid collisions if we try to use more libGL-files for other Ports like SCUMMVM

    PAK hack is still missing... Maybe added in Галина (galina) but I'm out for buisness next days. So maybe next week but I hope for response of working installations here.



  • Thanks a lot :)
    I think i miss something because i have had your new EXEC file to my OpenBOR directory with your lib directory and i can't launch any game ? Why ?



  • I just ran your install script. It did not fully configure. I do have /home/pi/openbor_openbeta and libGL.so.1 in libs folder. The OpenBOR OPENBETA script was created but this is the contents:

    /home/pi/openbor_beta/OpenBOR
    
    

    The 2nd line is empty

    Is there a way to copy text from terminal (Using Winscp). I highlight what I want to copy, then right click, and everything I have highlighted automatically pasts to command prompt and executes!

    Well anyway, the only thing I see that showed an error is:

                               Link to PAK files
    ---------------------------------------------------------------------------------
    Failed to link to Pak dir
    wassili must be feed with PAKs
    

    .PAK files were in openbor folder as normal

    I will not be near my PC again to tomorrow evening most likely. Sorry.



  • @darknior try the ldd OpenBOR command - maybe missing dependencies. Maybe I missed something, too during cleanup. So that is it, starting my buisness trip.

    @BiZzAr721 Does the binary run anyway? If not then I missed one dependencie

    Thanks for quick response you both.
    One error: I created wrong input to bash file. The path is $HOME/openbor_openbeta/OpenBOR I accedentily wrote $HOME/openbor_beta/OpenBOR - fixed now! I'm sorry.
    But the one liner is working because ports are started by bash scriptname.sh so it is a proper call to a script file.

    Second: About the link to PAK files! There should be created a link to PAK folder I assumed they are stored to /home/pi/RetroPie/roms/ports/openbor/Paks so the script can not find them in your installation and creates no symlink to them. Use SSH and go to openbor_openbeta directory and first delete the empty PAK folder created by OpenBOR here. Then symlink manually with your PAK directory like ln -s "FULLPATH/TO/PAKSFOLDER/" Paks. I want to avoid manually feed ;) But this is also possible :)

    About marking in terminal.... just don't click. Highlight will copy to clipboard automatically.



  • I had my PAKS in /home/pi/RetroPie/roms/ports/openbor - I created Paks folder and moved .PAKS there so I can try the one liner again
    wassili is making you happy haha :)

    Your install script worked - created a proper Symlink to Paks
    Binary loads, but shows No Mods In Paks Folder

    Gotta run - I'm pushing it trying to leave for work - but had to give you some input!



  • @bizzar721 I'm really sorry for confusion. Thank you for feedback I linked to wrong folder. Indeed it just openbor.... It was very late yesterday ;) It is better to delete openbor_openbeta dir and start from scratch

    No Paks error - is fixed
    Linking to folder - is fixed
    Script Path in .sh file - is fixed
    CleanUp for script - ADDED!
    It's working correct now

    @darknior Made a blank install with RetroPie 4.4 this evening. Everything works fine, all dependencies were installed



  • @darknior I've released base source code on my github account ;)
    I will release patch files there....

    Do you think you can patch CLI support in?
    I would suppose to use

      // Test command line argument to launch MOD
       int romArg = 0;
       if(argc == 2) {
          loadsettings();
          memcpy(packfile, argv[1], strlen(argv[1]));
          if(fileExists(packfile)) {
             romArg = 1;
          }
       }
    
       if(!romArg)
    Menu();
    


  • @cyperghost Yes do it, with pleasure :)

    For your OpenBOR i don't use your install script i only copy it to my original OpenBOR directory with the /lib direcory.

    root@retropie:/opt/retropie/ports/openbor# ldd OpenBOR
            linux-vdso.so.1 (0x7ec9e000)
            /usr/lib/arm-linux-gnueabihf/libarmmem.so (0x76f81000)
            libSDL2-2.0.so.0 => /usr/lib/arm-linux-gnueabihf/libSDL2-2.0.so.0 (0x76e79000)
            libSDL2_gfx-1.0.so.0 => /usr/lib/arm-linux-gnueabihf/libSDL2_gfx-1.0.so.0 (0x76e5b000)
            libGL.so.1 => ./lib/libGL.so.1 (0x76d30000)
            libpthread.so.0 => /lib/arm-linux-gnueabihf/libpthread.so.0 (0x76d08000)
            libvorbisidec.so.1 => /usr/lib/libvorbisidec.so.1 (0x76cdf000)
            libogg.so.0 => /usr/lib/arm-linux-gnueabihf/libogg.so.0 (0x76cd0000)
            libvpx.so.4 => not found
            libpng16.so.16 => not found
            libz.so.1 => /lib/arm-linux-gnueabihf/libz.so.1 (0x76ca9000)
            libm.so.6 => /lib/arm-linux-gnueabihf/libm.so.6 (0x76c2e000)
            libc.so.6 => /lib/arm-linux-gnueabihf/libc.so.6 (0x76aec000)
            libasound.so.2 => /usr/lib/arm-linux-gnueabihf/libasound.so.2 (0x76a12000)
            libdl.so.2 => /lib/arm-linux-gnueabihf/libdl.so.2 (0x769ff000)
            libbrcmEGL.so => /opt/vc/lib/libbrcmEGL.so (0x769c6000)
            libbrcmGLESv2.so => /opt/vc/lib/libbrcmGLESv2.so (0x769a1000)
            libbcm_host.so => /opt/vc/lib/libbcm_host.so (0x76979000)
            libvcos.so => /opt/vc/lib/libvcos.so (0x7695f000)
            libvchiq_arm.so => /opt/vc/lib/libvchiq_arm.so (0x76949000)
            libX11.so.6 => /usr/lib/arm-linux-gnueabihf/libX11.so.6 (0x76826000)
            libXext.so.6 => /usr/lib/arm-linux-gnueabihf/libXext.so.6 (0x76807000)
            libXcursor.so.1 => /usr/lib/arm-linux-gnueabihf/libXcursor.so.1 (0x767ed000)
            libXinerama.so.1 => /usr/lib/arm-linux-gnueabihf/libXinerama.so.1 (0x767e2000)
            libXi.so.6 => /usr/lib/arm-linux-gnueabihf/libXi.so.6 (0x767c4000)
            libXrandr.so.2 => /usr/lib/arm-linux-gnueabihf/libXrandr.so.2 (0x767ab000)
            libXss.so.1 => /usr/lib/arm-linux-gnueabihf/libXss.so.1 (0x767a1000)
            libXxf86vm.so.1 => /usr/lib/arm-linux-gnueabihf/libXxf86vm.so.1 (0x76793000)
            librt.so.1 => /lib/arm-linux-gnueabihf/librt.so.1 (0x7677c000)
            /lib/ld-linux-armhf.so.3 (0x54acb000)
            libgcc_s.so.1 => /lib/arm-linux-gnueabihf/libgcc_s.so.1 (0x7674f000)
            libxcb.so.1 => /usr/lib/arm-linux-gnueabihf/libxcb.so.1 (0x76730000)
            libXrender.so.1 => /usr/lib/arm-linux-gnueabihf/libXrender.so.1 (0x7671e000)
            libXfixes.so.3 => /usr/lib/arm-linux-gnueabihf/libXfixes.so.3 (0x76709000)
            libXau.so.6 => /usr/lib/arm-linux-gnueabihf/libXau.so.6 (0x766fe000)
            libXdmcp.so.6 => /usr/lib/arm-linux-gnueabihf/libXdmcp.so.6 (0x766f2000)
    

    I only miss these lib i don't know why ???

            libvpx.so.4 => not found
            libpng16.so.16 => not found
    

    I'm on Retropie 4.4.1



  • @darknior I install 3 packages

    libsdl2-gfx-dev libvorbisidec-dev libvpx-dev

    libvpx is defnitly missing. I think vorbis is not needed to install.
    Then it's just the sdl2-gfx? Sorry can't check at the moment ;)



  • @cyperghost It's not my problem, i read your bash, i already do it.

    root@retropie:/opt/retropie/ports/openbor# apt-get install libsdl2-gfx-dev libvorbisidec-dev libvpx-dev
    Lecture des listes de paquets... Fait
    Construction de l'arbre des dépendances
    Lecture des informations d'état... Fait
    libsdl2-gfx-dev est déjà la plus récente version disponible.
    libvorbisidec-dev est déjà la plus récente version disponible.
    libvpx-dev est déjà la plus récente version disponible.
    0 mis à jour, 0 nouvellement installés, 0 à enlever et 118 non mis à jour.
    

    And other OpenBOR version in the same directory are working fine.



  • @cyperghost Very nice! Your script worked great this time. I see you moved pak directory out of Paks subfolder of /home/pi/RetroPie/roms/ports/openbor, so I moved my .paks back to /home/pi/RetroPie/roms/ports/openbor

    Worked great - game loads full screen right from the start and plays great. Thanks

    I also realized that my .bor folders I made into .pak are no good! If I put just the data folder in Makepak_extractor folder and run makepak.bat I get a working .pak
    makepak.bat content:

    packer.bat bor.pak data
    

    I can rename the bor.pak without a problem, but I cannot specify a data folder location

    packer.bat asterix.pak "F:\OpenBOR FINAL\Makepak__Extractor\ASTERIX OPENBOR [MUGEN PLAYER]\data"
    

    It will extract no different, but the resulting .pak will not work
    1363 Segmentation fault

    The reason I mention this here is I have been trying the 3400 build .paks with the latest and it hasn't been working.
    A correctly made Asterix & Caesar Challange .pak does indeed work with this build!

    @oilusionista If you don't mind, perhaps you can answer this for me.
    Is it even possible to run borpak.exe on a data folder which is in a subfolder? I am trying to batch create paks.

    borpak -d "F:\OpenBOR FINAL\Makepak__Extractor\ASTERIX OPENBOR [MUGEN PLAYER]\data" -b ASTERIX.PAK
    

    Here is a snippet of the batch file I created which gave the incorrectly structured Paks:

    borpak -b -d "F:\openbor\Beats of Rage.bor" Beats_of_Rage.PAK
    borpak -b -d "F:\openbor\Captain Commando and the Avengers.bor" Captain_Commando_and_the_Avengers.PAK
    borpak -b -d "F:\openbor\Castlevania - Pulse of Animosity (Demo).bor" Castlevania_-_Pulse_of_Animosity_(Demo).PAK
    borpak -b -d "F:\openbor\Castlevania LCD Chronicles.bor" Castlevania_LCD_Chronicles.PAK
    borpak -b -d "F:\openbor\Chrono Killer.bor" Chrono_Killer.PAK
    borpak -b -d "F:\openbor\City of Heroes - Episode 1.bor" City_of_Heroes_-_Episode_1.PAK
    borpak -b -d "F:\openbor\Contra - Locked 'N Loaded.bor" Contra_-_Locked_'N_Loaded.PAK
    borpak -b -d "F:\openbor\Crime Buster.bor" Crime_Buster.PAK
    borpak -b -d "F:\openbor\Crisis Evil 1.bor" Crisis_Evil_1.PAK
    borpak -b -d "F:\openbor\Crisis Evil 2.bor" Crisis_Evil_2.PAK
    borpak -b -d "F:\openbor\D & D - Knights & Dragons Final Cut.bor"
    


  • @darknior I reinstalled the blank image today (4.4) and it worked all out of the box.
    There are some missing dependencies that are installed automatically by default

    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
      libwayland-cursor0 libwayland-egl1-mesa
    Use 'sudo apt autoremove' to remove them.
    The following additional packages will be installed:
      libogg-dev libsdl2-gfx-1.0-0 libvorbisidec1
    Suggested packages:
      libsdl2-gfx-doc
    

    So I added libogg-dev libsdl2-gfx-1.0-0 libvorbisidec1, too. But it should work out of the box ;)



  • @darknior I've upladed the tree were @zanac made all the patches for in my GITHUB account - OpenBOR-Raspberry

    I think I'm at least one week out of buisness, I hope you find some time to patch the CLI-support in. I would suggest the version I've modified.

    First check is if one argument if parsed, then it overwrites pakfilename with dedicated string length, then it uses the function OpenBOR provides to check fileexistance and then runs the menu. I think that's enough....



  • @cyperghost I always trying your same compiled file ... i don't have take time to DL the last source code et patch it ...
    I have update all my Retropie to 4.4.2 with Retropie Setup :

    root@retropie:/opt/retropie/ports/openbor# ldd OpenBOR
            linux-vdso.so.1 (0x7ed76000)
            /usr/lib/arm-linux-gnueabihf/libarmmem.so (0x76f07000)
            libSDL2-2.0.so.0 => /usr/lib/arm-linux-gnueabihf/libSDL2-2.0.so.0 (0x76dff000)
            libSDL2_gfx-1.0.so.0 => /usr/lib/arm-linux-gnueabihf/libSDL2_gfx-1.0.so.0 (0x76de1000)
            libGL.so.1 => ./lib/libGL.so.1 (0x76cb6000)
            libpthread.so.0 => /lib/arm-linux-gnueabihf/libpthread.so.0 (0x76c8e000)
            libvorbisidec.so.1 => /usr/lib/libvorbisidec.so.1 (0x76c65000)
            libogg.so.0 => /usr/lib/arm-linux-gnueabihf/libogg.so.0 (0x76c56000)
            libvpx.so.4 => not found
            libpng16.so.16 => not found
            libz.so.1 => /lib/arm-linux-gnueabihf/libz.so.1 (0x76c2f000)
            libm.so.6 => /lib/arm-linux-gnueabihf/libm.so.6 (0x76bb4000)
            libc.so.6 => /lib/arm-linux-gnueabihf/libc.so.6 (0x76a72000)
            libasound.so.2 => /usr/lib/arm-linux-gnueabihf/libasound.so.2 (0x76998000)
            libdl.so.2 => /lib/arm-linux-gnueabihf/libdl.so.2 (0x76985000)
            libbrcmEGL.so => /opt/vc/lib/libbrcmEGL.so (0x7694c000)
            libbrcmGLESv2.so => /opt/vc/lib/libbrcmGLESv2.so (0x76927000)
            libbcm_host.so => /opt/vc/lib/libbcm_host.so (0x768ff000)
            libvcos.so => /opt/vc/lib/libvcos.so (0x768e5000)
            libvchiq_arm.so => /opt/vc/lib/libvchiq_arm.so (0x768cf000)
            libX11.so.6 => /usr/lib/arm-linux-gnueabihf/libX11.so.6 (0x767ac000)
            libXext.so.6 => /usr/lib/arm-linux-gnueabihf/libXext.so.6 (0x7678d000)
            libXcursor.so.1 => /usr/lib/arm-linux-gnueabihf/libXcursor.so.1 (0x76773000)
            libXinerama.so.1 => /usr/lib/arm-linux-gnueabihf/libXinerama.so.1 (0x76768000)
            libXi.so.6 => /usr/lib/arm-linux-gnueabihf/libXi.so.6 (0x7674a000)
            libXrandr.so.2 => /usr/lib/arm-linux-gnueabihf/libXrandr.so.2 (0x76731000)
            libXss.so.1 => /usr/lib/arm-linux-gnueabihf/libXss.so.1 (0x76727000)
            libXxf86vm.so.1 => /usr/lib/arm-linux-gnueabihf/libXxf86vm.so.1 (0x76719000)
            librt.so.1 => /lib/arm-linux-gnueabihf/librt.so.1 (0x76702000)
            /lib/ld-linux-armhf.so.3 (0x54b0a000)
            libgcc_s.so.1 => /lib/arm-linux-gnueabihf/libgcc_s.so.1 (0x766d5000)
            libxcb.so.1 => /usr/lib/arm-linux-gnueabihf/libxcb.so.1 (0x766b6000)
            libXrender.so.1 => /usr/lib/arm-linux-gnueabihf/libXrender.so.1 (0x766a4000)
            libXfixes.so.3 => /usr/lib/arm-linux-gnueabihf/libXfixes.so.3 (0x7668f000)
            libXau.so.6 => /usr/lib/arm-linux-gnueabihf/libXau.so.6 (0x76684000)
            libXdmcp.so.6 => /usr/lib/arm-linux-gnueabihf/libXdmcp.so.6 (0x76678000)
    

    I have always the same problem, i will investigate ...



  • @darknior
    Try to download master branch. Then patch it with patch -p0 -i ./patch/3-Wassili.diff then compile with make BUILD_PANDORA=1
    This should work, too ;)

    PS: I talked about a fresh image ;)



  • Sorry for the dumb question, but is it now possible to launch a game directly from ES using some kind of command-line shortcut? Thanks for all the great work!



  • @spongedan Not a dump question. Галина (galina) offers CLI support for PAKs now. Please use wget "http://raw.githubusercontent.com/crcerror/OpenBOR-63xx-RetroPie-openbeta/master/openbor_openbeta.sh"; bash openbor_openbeta.sh galina; rm openbor_openbeta.sh



  • @cyperghost Awesome! So what's the command-line syntax? Is it "OpenBOR -rom.pak" or something else? Thanks again!


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.