Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[Testing] Kodi 18.0 Leia beta versions now available for RetroPie!



  • Sorry Rasta for not answer earlyer, This days i'm very bussy and i have not to much time, maybe next week i have more time and i can upload the logs, Anyway Thank you for you disposition to help, really. ^^



  • It tells me that I should rather get beta 5. How do I do that?



  • Cool.

    I just bought the DVB-T card for the RPi and my Retropie is currently running tvheadend to offer it out to the network. I haven't yet got around to setting up Kodi to view it "live" on the Pi itself yet but good to know that things are improving all the time.



  • This post is deleted!


  • I get crashes in Kodi 18 whenever I change the regional settings (even if I just go in, change the country, come out). It crashes out of Kodi and the changes are never saved.

    Any idea why that might be (am I missing some internationalisation package for Kodi?).



  • @ledow I don't have this problem with kodi 18 beta 4. Running Raspberry Pi 3b plus..



  • @ledow I cannot reproduce that problem too. Check your kodi log for errors, if you updated from version 17, it can be caused by some incompatible addon. You can try with a clean/default settings, by moving/removing /home/pi/.kodi



  • @Rascas It's a clean install, no previous install ever (never used Kodi on this device/card at all).

    When I change regional settings, it lets me select UK or change the date/time setup to UK but then almost immediately Kodi dies and throws me back to the menu.

    I can change every other option, I can watch TV for hours, do all the normal things, but changing the region just crashes it hard, whether I do it immediately I go into Kodi or if I've been in and out of a thousand menus.

    It did it with zero addons installed, and it does it with the tvHeadEnd HTSP add-on installed.

    I'll try to recover some logs or similar next time I do it, just wondered if it was only me.



  • Well then post your kodi log with debug enabled, and I would also check /var/log/syslog for errors like microSD card/disk errors.



  • Hi,
    i don't know what to do.
    i don't get the netflix addon to run.
    when i try to run it kodi gives me an error message that says to look into the log file.
    looking in the log it seems the problem is that there is no directory for the netflix addon.

    i think the problem is that on installation time the dependency for pycryptodome is not resolved.

    i tried to install the python package pycryptodomex via pip but of course the addon still can not see an equivalent pycryptodome kodi addon/package.

    i run everything on an raspberry pi 3b

    What am i doing wrong?
    how did you get the netflix addon to run on retropie?
    do i need an additional repo?



  • @wursti90 If anybody has trouble getting Netflix working, you have to do 'pip install pycryptodomex' in a terminal, not as root or with sudo or it won't work. Then just install the netflix addon from here
    https://github.com/asciidisco/plugin.video.netflix



  • If anybody has some problem with this Kodi test builds, please post your kodi debug log as explained here
    https://kodi.wiki/view/Log_file
    It will make everything easier and faster for everybody.



  • Found the cause of my problem, and it was a bit of a misdirection, I apologise - apparently a default weather add-on had been enabled.

    Ironically, the UK Met Office weather app crashes if you change the region to UK while it's running........



  • @Rascas It is running now but it won't actually play any video and I don't get any error..



  • @Cederick Make sure you are using the default video settings, which is MMAL enabled, OMXPlayer disabled. If it still does not work after that, post your Kodi debug log.


  • administrators

    @wursti90 Netflix add-on won't play currently due to changes made by Netflix. See issues on https://github.com/asciidisco/plugin.video.netflix/issues



  • @BuZz & @Rascas thank you guys for the support! even though it's not really thread title related :)

    btw. installing pycryptodomex via 'pip install pycryptodomex' didn't do the trick.
    so on my rapsberry pi 3b running retropie 4.4 logged in via ssh i had to explicitly set the user flag. That means after executing 'pip install --user pycryptodomex' i was able to login but now i am waiting for a fix :)

    anyhow thanks!



  • @Rascas Like BuZz said.. There was a new change from netflix and they had to do some changes to the addon.
    @wursti90 They actually fixed it and now it's broken again. Worked until like 30 minutes ago...

    EDIT: Did "sudo apt-get dist-upgrade" and now it dosn't even open anymore. Now trying "pip install --user pycryptodomex".

    I'm getting

    Collecting pycryptodomex
      Using cached https://files.pythonhosted.org/packages/69/e7/5c50af65e3d46a161181089aed939bce185ad61f6cc86779994e9d8280d0/pycryptodomex-3.7.0.tar.gz
    Building wheels for collected packages: pycryptodomex
      Running setup.py bdist_wheel for pycryptodomex ... error
      Complete output from command /usr/bin/python -u -c "import setuptools, tokenize;__file__='/tmp/pip-build-3D6k7q/pycryptodomex/setup.py';f=getattr(tokenize, 'open', open)(__file__);code=f.read().replace('\r\n', '\n');f.close();exec(compile(code, __file__, 'exec'))" bdist_wheel -d /tmp/tmpcQULcVpip-wheel- --python-tag cp27:
      Testing support for x86intrin.h header
      Target does not support x86intrin.h header
      usage: -c [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
         or: -c --help [cmd1 cmd2 ...]
         or: -c --help-commands
         or: -c cmd --help
    
      error: invalid command 'bdist_wheel'
    
      ----------------------------------------
      Failed building wheel for pycryptodomex
      Running setup.py clean for pycryptodomex
    Failed to build pycryptodomex
    Installing collected packages: pycryptodomex
      Running setup.py install for pycryptodomex ... done
    Successfully installed pycryptodomex-3.7.0
    
    

    but I also got it without the "--user" the last time I used it. And it kind of completes it anyways.

    Lastest crashlog: https://pastebin.com/67zwnMjQ



  • @Cederick i don't understand your problem. please be more clear.
    for me installing netflix worked like this:

    1. install the netflix repo from asciidisco
    2. do 'pip install --user pycryptodomex' from any terminal
    3. install the netflix addon
    4. enter account credentials
    5. try to play any episode oder movie and you'll be asked to install libwidevine.
      this is done automatically so you don't have to worry about it. just proceed by accepting and giving green light to everyting :)

    (6.) after that the addon promted me that libwidevine misses 'libnss3.so' and some other libraries. i think doing 'sudo apt-get install libnss3' solved the problem for me.


    Now to your terminal output:
    i asume (and your crashlog shows that) you are using arm architecture ... but the pycryptodomex package seems to rely on a library that is build for x86. i didn't had that problem (i guess). however after trying to build the needed libraries which seem to have failed pip still installs the pycrytodomex package. i don't know but maybe you are fine since as an arm user you don't need 'x86intrin'.

    once again: what is your problem?

    for me doing everything as descriped worked fine. keeping in mind that it didn't worked due to the changes on the netflix site.

    And please i don't know how the others feel but posting crashlogs that have hundreds of entries that are not related to the problem make thinks worse. especially for me who never read any kodi crashlog ever before :)
    i don't care whether you like to watch Hand of blood holding SPANDAU or like to listin to Left Boy. Daher: Bitte brich mein Herz nicht Baby und probiere dein Problem direkt nach dem starten von kodi zu reproduzieren. Also Kodi starten -> Netflix starten -> problem reproduzieren -> crashlog posten ;)

    Schöne Wochenende (have a nice weekend)



  • I'm having the same issue as DeathWalk. It's only in Estuary. It seems the playback menu overlay is blown like a 1000x. Subtitles also don't work (which I guess they do work but are extremely offscreen and extremely oversized). I guess there's some scaling problems there with the menus/overlays, etc.

    I updated from Kodi 17 on RPI3B+. It seems it's the beta 4.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.