Please do not post a support request without first reading and following the advice in

  • Hi, everyone!

    I've just installed RetroPie on a Raspberry Pi 3 Model B.
    First test on video with a USB controller worked fine.
    I've connected via ssh, installed xrpd and then connected via remote desktop using Remmina.
    When I connect to the system via RDP I'm on terminal. If I run emulationstation, I get this error

    lv10 : Error creating SDL window!
    Could not get EGL display
    lv10: Renderer failed to initialize!
    lv10: Window failed to initialize!

    So, via RDP I can work with the terminal (same as ssh), but I'm not able to start emulationstation.
    I tried installing XOrg, but I got the same error (though I'm not sure it is actually running...)

    Any hints?


  • administrators

    @il_mix it doesn't work that way.

  • Uhm... ok. I've read some posts about it and tried to replicate (also one where you suggested to install XOrg... ).
    So, how can I access emulationstation remotely?
    Just to describe the full picture, I've installed and tested all in a rush at work, connecting the RPi to ad HMDI monitor. I don't have a TV/monitor at home at the moment. That's why I want to access via remote desktop. I want to wire everything in a NES case, so I need to preliminary test several things (NES controllers via GPIO, USB/Ethernet custom extension cables, SD from cartridge, ...), and it will be quite useful to test everything via remote desktop.
    Actually, the main thing that can be quite tricky to test without emulationstation are the NES controllers. Is there a command line tool to test them? Like evtest or similar.


  • administrators

    @il_mix there is no way to access emulationstation remotely.

  • Ok, I give up.
    About a controller (connected via GPIO) console testing software? Any hints? Better open a new topic?

  • Global Moderator

    @il_mix said in EmulationStation over RDP error:

    Actually, the main thing that can be quite tricky to test without emulationstation are the NES controllers. Is there a command line tool to test them?

    I have to admit, I was a little confused by the previous request here. With the use case scenario you describe, you're far enough away to require remote desktop software, but close enough to test controllers that are connected to the raspberry pi. I had to discard my original response earlier because I couldn't figure out how to approach it. If you are now saying you just want to test your controller input, have you tried jstest along with the 'Linux Console Tools' test suite included with RetroPie?

  • administrators

    @mediamogul yep jstest should do the trick for testing gpio and it should work over ssh

  • Thanks for the info.
    I knew jstest-gtk. I didn't know it is available via console, too.
    I'm gonna test it with a USB gamepad first, to check if it's what I need (I suppose so). NES/SNES controllers test will take a while, since I need to prepare the interconnection board. Maybe I will do a quick test with jumpers.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.