Please do not post a support request without first reading and following the advice in

F710 buttons changed after update

  • Hi, my Logitech F710 button setup used to look like this:

    input_device = "Logitech Gamepad F710"
    input_driver = "udev"
    input_r_y_plus_axis = "+3"
    input_r_x_minus_axis = "-2"
    input_l_btn = "4"
    input_load_state_btn = "4"
    input_start_btn = "9"
    input_exit_emulator_btn = "9"
    input_r_y_minus_axis = "-3"
    input_down_btn = "h0down"
    input_l_x_plus_axis = "+0"
    input_r_btn = "5"
    input_save_state_btn = "5"
    input_right_btn = "h0right"
    input_state_slot_increase_btn = "h0right"
    input_select_btn = "8"
    input_left_btn = "h0left"
    input_state_slot_decrease_btn = "h0left"
    input_l2_btn = "6"
    input_l3_btn = "11"
    input_l_y_minus_axis = "-1"
    input_up_btn = "h0up"
    input_a_btn = "0"
    input_b_btn = "1"
    input_reset_btn = "1"
    input_enable_hotkey_btn = "10"
    input_l_y_plus_axis = "+1"
    input_r2_btn = "7"
    input_r3_btn = "12"
    input_x_btn = "2"
    input_menu_toggle_btn = "2"
    input_l_x_minus_axis = "-0"
    input_y_btn = "3"
    input_r_x_plus_axis = "+2"

    It has worked for me for ages. However, when I updated to Retropie 4.4, a number of buttons didn't respond anymore. E.g. Select and Start Button.

    When used "jstest" to see which button was being triggered when pushed, I noticed that they now have a different number. E.g. Select is now button 6 instead of 8, and Start is now 7 instead of 9 now.

    Has anyone else experienced this ?

    I also only recently found out that there is also a button configuration file sitting in /home/pi/.emulationstation/es_input.cfg

    Can someone explain to me why there are two ? This is even more confusing to me. Retopie works like a charm, but the button configs give me quite a headache.


  • Global Moderator

    @braham Re-map your gamepad, using the Input Configuration wizard in Emulationstation. Most likely the driver has changed due to a more recent kernel in 4.4 (Raspbian Stretch). The mapping in ~/.emulationstation` is for Emulationstation, the one you referenced is for RetroArch. Once you configure your controller in Emulationstation, both files will be updated automatically.

  • @mitu: perhaps I should have explained everything a bit more. I used to run RP on a Raspberry 2. I upgraded the hardware to a Pi3 B+. It worked out of the box. I wanted to repurpose the Pi3, so I switched it over to a Pi3 A version. This worked, when I also updated the entire system (sudo apt-get update && sudo apt-get dist-upgrade -y && sudo rpi-update). But this is also when I noticed that the kay mappings were off.

    So I did some testing. I took the 4.4.4 image (found elsewhere on the forum), to boot my Pi 3 A. The stock kernel on that image is 4.14.79-v7+. The key mappings are the same as with the latest RP image for the RP3 Plus. And everything works as expected. But when I then update the entire system as above (to kernel 4.14.86-v7+), the mappings change and everything is messed up.

    I can manually (using the config file) change the Select button back to what it was before, and then re-map my Gamepad as you suggested. However, it doesn't fix everything unfortunately. When using mame, controls are rather "slow" all of a sudden. Takes 10 seconds before it accepts a "coin". And also the Exit key combination doesn't work immediately. If at all. When using a GB image, none of the controls work !

    So... for me it's back to the latest official RP image using my Pi3+. RhI guess I should refrain from doing the Raspberry Pi kernel upgrades to keep things from working.

  • Global Moderator

    @braham said in F710 buttons changed after update:

    But when I then update the entire system as above (to kernel 4.14.86-v7+), the mappings change and everything is messed up.

    How did you upgrade to this kernel version ? The latest version in the Raspbian repository is 4.14.79-v7+. You can try re-installing the xpad driver and see if that changes anything.

  • @mitu: I used rpi-update

  • Global Moderator

    @braham rpi-update is only recommended for trying out new (unreleased) firmware/kernel versions. You should not use it to regularly update your kernel and firmware. From the homepage of this tool (

    Even on Raspbian you should only use this with a good reason.

    This gets you the latest bleeding edge kernel/firmware. There is always the possibility of regressions.

    Bug fixes and improvements will eventually make their way into new Raspbian releases and apt-get when they are considered sufficiently well tested.

  • @mitu : I know, it's what I normally use to update all my Pi's. But I guess I should have been more careful with my Retropie.

  • I have now reinstalled the official image on the Pi3B+; did an upgrade (no rpi-update), rebooted. The buttons then didn't work anymore. I then updated Retropie to 4.4.4., rebooted and all is working again. Thanks for your help.

Log in to reply

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.