Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Complete new guy having problems



  • I bought a canakit retropi from amazon recently and followed the supplied instruction and got things running.

    I am an old player and had a few neogeo roms floating around so installed a few and after a few tries got the right files in the right place and got things working - After that success I decided to add the rest of my roms into the PI but then my problems started.

    After I added the files (over a network) to the correct place on the PI SD card (not zip files) I rebooted the PI but when it came back on, there are no games listed at all. Tried a few reboots (just in case) and a few googles but as a complete newcomer to this I dont really have the first clue.

    Can anyone help me get to the bottom of this. I am sure its something simple as I have had things working , but for now i'm stumped



  • @beercritch Start by adding more info about your system - https://retropie.org.uk/forum/topic/3/read-this-first.
    Each system/emulator has a list of known ROM file extensions that it accepts. They are documented in the docs for each system.
    If you copied the ROMs to the right place, but have the wrong extension, they won't show up in the list. Can you give an example of a file/ROM you copied (and where), but doesn't show up in the game list ?



  • thanks for the quick reply and sorry for the missing info .

    Ive got a Rasberry Pi 3 B+
    Canakit 2.5A power supply
    Not sure of my retropie version (how do i find that?)
    The emulator is emulationstation but again I dont know how to find the version
    The SD card was pre-installed and bought online as a kit to assemble.

    The files I added originally were added to the roms\neogeo\ directory. I made a further directory called knights and added into that 13 files vie windows over a local network

    kr_09.rom
    kr_18.rom
    kr_19.rom
    kr_22.rom
    kr_23e.rom
    kr_gfx1.rom
    kr_gfx2.rom
    kr_gfx3.rom
    kr_gfx4.rom
    kr_gfx5.rom
    kr_gfx6.rom
    kr_gfx7.rom
    kr_gfx8.rom

    I then rebooted the PI and this game worked - great.

    I then added more games in the same way, but now when I reboot the PI the main menu shows there is no games installed. (I just have the retropie logo center screen with a black banner above and below and access to the menus and setting screens but no link for neogeo games)

    I tried removing the games I added later in case I made a mistake somewhere just leaving the original game but the PI still boots fine but has no games listed.

    Since I have tried removing all the games and adding just the first game as I did originally but still have no games listed.

    As things stand now if I go to the file manager from the RetroPie configuration menu I can see the files in the location as stated above but the retroPie is not seeing them for some reason - or have I done something wrong along the way?



  • @beercritch NeoGeo and Arcade ROMs must not be unzipped or renamed, they won't work this way. Leave them zipped and copy them into the corresponding folder (arcade, neogeo or fba).

    Not sure of my retropie version (how do i find that?)

    When you open the RetroPie Setup script, the version of RetroPie is shown at the top of the text screen.

    The emulator is emulationstation but again I dont know how to find the version

    Press Start and the Emulationstation menu will appear, with the version at the bottom. However, Emulationstation is not an emulator, is just a front-end to display and browse/start the games you have added to RetroPie. The emulator is shown when you start the ROM, in the Runcommand splash screen (https://retropie.org.uk/docs/Runcommand/).

    The SD card was pre-installed and bought online as a kit to assemble.

    Did it come with RetroPie installed or you installed it yourself ?



  • @mitu "The SD card was pre-installed and bought online"



  • @mitu

    Ohh god I am truly a newb at this - lol

    I was absolutely sure I had unzipped the files and placed them in the Retropie Folder but it turns out I must have put the zip file into the folder and not realised. You are exactly right that the files need to remain as a .zip

    Anyhoo - A very quick learning curve for me there and thanks to you for your very quick response thats got me up and running again



  • @beercritch You didn't answer my question.



  • @mitu

    I bought a kit online with the raspberry Pi, case, power supply, controllers, etc. And an SD card setup with Rasperry PI - It had instructions how to install RetroPie on top of that.

    Too many types of Pie.


  • administrators

    @beercritch interesting. Please can you link me the Amazon item? (please use hxxp so they don't get additional traffic) They should not be including retropie pre-installed. I was under the impression canakit respected our licences.



  • @BuZz I think it is more like a third seller that uses the the canakit set + RetroPie Image for full setup.

    Selling RetroPie install is lame, but what I really dislike with passion are the 16/32/64/128GB full ROMs (or BASIC/SILVER/GOLD/PLATIN images shipped with RetroPie/Recallbox/Lacca ..... whatever you call them)

    That's really a shame and the full installs move the RetroPie project into a bad light.


 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.