Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Aimtrak / Advance Mame 1.4



  • Re: Aimtrak Gun (Mouse Issues) and Mame UPDATED

    Hi all, hope all is well?

    I have tried what was suggested in this thread to get my gun working, but no matter how many times I try, my light gun reads as a joystick, very much like in the screenshots in the previous thread. Any ideas?

    Thank you in advance!



  • Tried everything here too. Nothing I do gets it to recognise Aimtrak as a mouse input

    https://github.com/RetroPie/RetroPie-Setup/wiki/Spinners,-Trackballs,-Lightguns,-and-other-Mouse-Devices#configuring-retroarch-emulators-for-mouse-like-device-use

    Pulling my hair out with this, lol.

    Any other ideas?



  • Is it normal that the gun is recognised on both js1 and also mouse0? Perhaps this is causing a conflict?

    Can I just delete the js1 file?



  • Hi,

    I have two Aimtrak guns and they are also mapped to both js and mouse, but they work nonetheless. So, that shouldn't be the problem, especially since the Docs say,

    Please disregard any devices listed for the legacy interfaces /dev/input/mouse* and /dev/input/js*. Look instead for the /dev/input/event* indexes.

    Instead of just saying that you tried "everything", please provide the information that is asked for in https://retropie.org.uk/forum/topic/3/read-this-first and describe every step you took to setup the gun. Post any output and messages exactly as written (copy & paste or make a photo). The devil often is in the details.

    In addition to that, you may give us the output of this command:

    ls -l /dev/input/by-id/    # The "l" is a small L and not a one!
    

    Cheers
    Clyde



  • @Clyde

    “The devil is in the detail”

    Never has a truer word been spoken. I apologise for the vague methods I tried to get this working. What I meant to say is that I followed that guide step by step... and with your help, I followed the guide again and it works!

    You may be asking yourself “but I didn’t suggest any fixes”. Well, you did. Listing all the devices with that “ls” command, I found that a Bluetooth dongle controlling both a wireless mouse and keyboard was found. It transpires that was causing me an issue. I unplugged the dongle, restarted the pi with a wired keyboard this time, followed the steps in the guide... and voila!

    If you were here, I would kiss you. Seeing as you’re not, I can only extend my thanks and hope that my stupidity can save someone in a similar situation self inflicting grief.

    Note: if after following the guide, you still can’t get the Aimtrak to work, think to yourself, do I need to unplug a wireless dongle?



  • I'm glad that my request helped you fix the gun before the holidays. :)

    In general, testing with the least other hardware connected as possible can be helpful to pinpoint a problem.

    edit: just a typo



  • @Clyde said in Aimtrak / Advance Mame 1.4:

    I'm glad that my request helped you fix the gun before the holidays. :)

    I just realised how strange that may sound out of context. :D


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.