Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

ASUS Tinkerboard: unable to install retroarch and emulationstation.


  • Global Moderator

    @E3L1 Just like on any Debian distro, using apt

    apt -y install libgl1-mesa-dev libxcursor-dev libxi-dev libxinerama-dev libxrandr-dev libxss-dev
    


  • @E3L1 ok , just a thought.
    i have not got the board yet, so i cant help.
    been meaning to but have not had the chance



  • @mitu OK so now there installed but now I have a new problem.... when I try to start EmulationStation all I get back is;

    “Error creating SDL window!
    Could not initialize OpenGL / GLES library
    Renderer failed to initialize!
    Window failed to initialize!”

    So am I missing open GL? Or is some other thing preventing it from starting?


  • administrators

    I've not tested this for some time on the tinker board. It's possible something has happened to break it. I was considering to ditch support for the Image that comes with the tinkerboard and instead look at using Armbian as a base as it looks like it's better support. I cannot offer any advice until I have looked at this.



  • @BuZz on that note ive tried using armbian but it seams that only tinkeros is actually bootable on the tinkerboard.... any ideas why?


  • administrators

    @E3L1 No - I've yet to try Armbian on the Tinker board.



  • @BuZz so ive been looking around, do I need to disable the desktop interface for emulationstation to work?



  • so got armbian to boot, the problem was that I put a paperclip through the run pinouts for tinker os, armbian dous NOT boot with them shorted.... will now try armbian install



  • Well I’ve managed to get everything installed and running though for some reason there is this strange audio thing happening, literally 50% of the time when starting games the audio is missing but like super predictable like start game no audio, restart same game audio, restart again no audio.... any ideas?



  • @E3L1 , try this:
    In terminal type:
    sudo nano /usr/share/alsa/alsa.conf
    Then Change
    defaults.pcm.card to 1
    To
    defaults.pcm.card to 0
    Save, exit, and reboot.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.