Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

RetroPie on Odroid C2 not working



  • Hello everyone!

    I am unable to get Retropie 4.4.4 working on my Odroid C2.
    The information I found is outdated and the links are wrong and I am too bad to make it work :D

    (eg. the instruction page links to an odroid C1 image for Ubuntu 14.04lts)
    https://github.com/retropie/retropie-setup/wiki/Odroid-C1-C2

    I did:

    sudo apt-get update && sudo apt-get upgrade
    sudo apt-get install -y git
    git clone --depth=1 https://github.com/RetroPie/RetroPie-Setup.git
    cd RetroPie-Setup
    sudo ./retropie_setup.sh
    

    on
    ubuntu-18.04-3.16-minimal-odroid-c2-20180626.img
    and
    ubuntu64-16.04.3-minimal-odroid-c2-20171005.img
    and later also on
    ubuntu-18.04-3.16-mate-odroid-c2-20180620.img

    It always works until I see the setup screen like this:
    alt text

    At first I just hit "Basic install" which took about 2 hours and ended in multiple errors like:

    Could not sucessfully build sdl2 - SDL (Simple DirectMedia Layer) v2.x (/root/RetroPie-Setup/tmp/build/sdl2/libsdl2-dev_2.0.8+1mali_arm64.deb not found)
    
    Could not install package(s): libxkbcommon-dev libusb-1.0-0-dev libavcodec-dev libavformat-dev libavdevice-dev
    
    Could not install package(s): libboost-system-dev libboost-filesystem-dev libboost-date-time-dev libfreeimage-dev libfreetype6-dev libcurl4-openssl-dev cmake libsm-dev libvlc-dev libvlccore-dev vlc
    
    Could not install package(s):  mc
    
    Could not sucessfully build lr-mame2000 - ARcarde emu - MAME 0,37b5 port for libretro  (/root/RetroPie-Setup/tmp/build/lr-mame2000/mame2000_libretro.so not found)
    
    Could not install package(s):  libpng-dev
    
    Could not sucessfully build lr-picodrive - Sega 8/16 bit emu - pocodrive arm optimised libretro core (/root/RetroPie-Setup/tmp/build/lr-picodrive/picodrive_libretro.so not found)
    
    Could not install package(s):  rsync ntfs-3g exfat-fuse pmount lockfile-progs
    

    I am installing via SSH and have NOT created a new user.
    I am installing as root user and have added the user 'root' to the group 'input' and 'video'.

    I also tried to restart after adding the user 'root' to the group 'input' and 'video' and run the install script again (because the installation said that the changes only takes affect after a reboot)

    Then I tried to install ES from 'Manage packages'->'core'->'811 emulationstation'->'Install from source' and install the emulationstation only, but it also drops me some of the above errors:

    Could not install package(s):  devscripts debhelper dh-autoreconf libasound2-dev libudev-dev libibus-1.0-dev libdbzs-1-dev fcitx-libs-dev mali-bfbdev
    
    Could not successfully build emulationstation - EmulationStation - Frontend used by RetroPie for launching emulators (/root/RetroPie-Setup/tmp/build/emulationstation/emulationstation not found)
    

    I also dont know what "Option 5: Install EmulationStation" does mean.

    @BuZz said he sucessully build it for Odroid C2 on Ubuntu 18.04... Sadly I dont know how :D

    Currently I am on ubuntu-18.04-3.16-mate-odroid-c2-20180620.img in hope that there were some packages included that could be helpfull.

    One of the logs can be found here:
    https://pastebin.com/Y5fTfexk

    If anyone needs more information, has questions or hints please let me know :)


  • Global Moderator

    The errors come from this:

    Unpacking mali-fbdev (20180710-r6p1-10) ...
    dpkg: error processing archive /tmp/apt-dpkg-install-kRF6OI/38-mali-fbdev_20180710-r6p1-10_arm64.deb (--unpack):
     trying to overwrite '/usr/lib/aarch64-linux-gnu/libEGL.so.1', which is also in package libegl1:arm64 1.0.0-2ubuntu2.2
    

    This is a distro packaging error, that should be fixed outside RetroPie.

    I see you're using a 64bit distro, which I don't think is tested (or even working) with some of the emulators included in RetroPie. You should use a 32bit distro and also add a dedicated user - root is not supported.



  • Thanks for your help and these important hints.

    On the Odroid C2 Wiki there is none of this mentioned.

    I also didn't know that adding a new user is needed, but after reading your post I saw that in the Ubuntu tutorial there is mentioned that you need x86.

    So for the issues:
    I don't find any x86 Ubuntu images for the Odroid 2. Maybe someone can help me out?
    In none of the sites I read there was a special x86 version mentioned.. just the HK images.

    Adding a new user and not installing as root is critical and a must?
    I didn't find a hint or a tutorial showing that.

    So can I just do this?

    adduser retropie
    passwd MYPASSWORD
    su - retropie
    

    and then start the setup script again ?

    for the distro packaging problem:
    What can I do to make it working or will it be automatically be fixed it I use an X86 Ubuntu (if there is one somewhere)?

    I just wonder how @BuZz has installed it and got it running :D

    Thanks a lot for your help so far!


  • Global Moderator

    @Phil333 said in RetroPie on Odroid C2 not working:

    I don't find any x86 Ubuntu images for the Odroid 2. Maybe someone can help me out?

    There is no such thing - x86 means 32 bit Intel/AMD cpu, the C2 has an ARM cpu.

    Adding a new user and not installing as root is critical and a must?
    I didn't find a hint or a tutorial showing that.

    The installation assumes you're already using the HK image and running as the odroid user.



  • @mitu Yeah :)
    So in my knowledge the first image I tried Ubuntu 18.04 and the last 18.04 Ubuntu mate image should be 32bit right?
    Because the 16.04 Ubuntu image has also the 64bit mentioned in the name.
    OS can be found here

    So the image ubuntu-18.04-3.16-minimal-odroid-c2-20180626.img should be OK right?
    If not then I have no idea how to find the right 32bit Ubuntu for Odroid C2.

    On my installation I connected via SSH and logged in as 'root' with the root password.
    Of the installation is automatically done as user Odroid then it's all fine :)

    But I think I read the hint at the setup script, that the user 'root' must be a member of the group input and video... which should say, that installation was done as root.

    So what do you think is the best for me to try and do? :)


  • Global Moderator

    Unfortunately I think RetroPie may not be easy for you to install on the C2. You may give Lakka, since it has a ready-to-go image available.



  • Yeah... you might be right I am afraid.

    But it must be possible as @BuZz has already got it running on Ubuntu 18.04
    And also this looks like something had been running in the past.

    The problem with lakka is, that kodi is not convinient to use as with retropie.
    Recalbox is easy to use, but it has an outdated kodi 16 (jarvis) included and multiple things are just workarounds so that kodi is not fully usable (no PVRs do work for example) and the overall developement is a bit slow.
    Batocera on the other hand is great in every implementation - very fast and up to date, but it has no netplay implemented...
    And I would love to play with my buddys :)

    So I "just" want to use ES with netplay and kodi that supports PVR to stream from my VU+ box to the Odroid C2 and every retro gaming project has its own issues with Odroid C2 (and retropie is right now the hardest, because it cant even run properly... or better: I cant get it running :D )

    I know with my Raspberry Pi 3B/3B+ everything runs easyly but also the resulutiuon and performance is not as good.
    I hope someone can help me out of this very very bad situation :D:D


  • Global Moderator

    @Phil333 said in RetroPie on Odroid C2 not working:

    But it must be possible as @BuZz has already got it running on Ubuntu 18.04

    No quite, that message is about installing RetroPie on a PC (amd64) running Ubuntu, not about Odroid C2 running Ubuntu. It might have been running in the past on another Ubuntu release (16.04 maybe?).

    You might try an Armbian Ubuntu image - but I don't know if they use an aarch64 (64bit) system or not.



  • As far as I understand, RetroPie is the only retro gaming software (lakka, recalbox, batocera) that has no ready to use image for Odroid C2 and is also the only one that is not able to run on Odroid C2 even if you try to do it manually.

    So its the only gaming software not working on Odroid C2 (to make it short and simple)

    I also tried Armbian Ubuntu, but its also not working (also aarch64).
    All the information you find is outdated and doesnt work.
    The Tutorial simply doesnt work.

    Pretty sad, because RetroPie is a great project :(



  • I was going to suggest a link I found, but that appears to be the guide you have tried just a different link

    Found this though on the an odroid support site that looks like its a distro of RetroPie 4.4.2

    http://odroidarena.com/various-os-flavors-available/

    This is the main site with various distros for all the odroid versions, but this one seems to be the one specifically for the Odroid C2

    I don't have one to try it on, but it might help you

    http://odroidarena.com/downloads/

    The direct link for the IMG file is also here. Be aware it is a 5GB image file, so you'll need at least an 8GB SD card to get started

    http://odroidarena.com/pub/xu4-4.4.2-v1.5.x/XU4-ORA-Base-RP-Pub-v1.5.2.img

    Assuming you intend to write the IMG to an 8GB SD card, this bit of nifty software looks the best. I use OSMC that uses its own installer but then had to build RetroPie using RetroSMC so didn't need to burn an IMG file of RetroPie, plus I use an Raspberry PI3 for my KODI/RetroPie set-up

    https://www.balena.io/etcher/



  • @steptoe: This is an xu4 image.
    I gave it anyway a shot (in case it was just mistakenly named wrong).

    The Odroid C2 doesnt boot and no heartbeat led blinking -> image not for C2.

    If you have additional ideas or findings let me know and I'll try it :)

    Thanks for the help so far!



  • So glad i hit upon this thread.
    I had a similiar use case as that of OP's. Didn't find Rp3 performant enough, so i have odroid c2 running librelec. But now i want to run retroarch with kodi on another microSd on C2. I did similiar permuations with the images but just like as OP's they all failed.
    If anyone got it working on c2, it would be greatly appreciated if they can contribute in updating the wiki or let know even if they were able to do so, so that investing time might be worthwhile. The "retropie-4-x-on-odroid-c2" link is helpfull but can't fully grasp if some steps are obsolete or still required.

    @Phil333 did you pursue this further or dropped it for now?

    thanks for this thread tough!


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.