Please do not post a support request without first reading and following the advice in

lr-mupen64plus-next: experimental scriptmodule for testing

  • @hhromic so was testing out Mario tennis, game is playable using the old lr-mupen64plus but game goes to a black screen and freezes with lr-mupen64plus-next. Had to ssh in and reboot.

    Edit: found a game that lr-mupen64plus-next is better at running: Nascar 99. Lr-mupen64plus just goes to a black screen and fails to launch the game. Standalone mupen64plus+gliden64 will load the game but the title screen is black and the game froze on on me about 5 secs into a race.

  • Hello,
    I've noticed that after 15 minutes or so the emulator starts glitching and then it crashes.
    Anyone else has this problem?

  • @saccublenda very likely due to the fact that it's using a older version of gliden64 for video. Older versions of gliden64 have issues on raspberry pis when framebuffer emulation is enabled. Try turning framebuffer emulation off. Though some effects may not render properly.

  • @quicksilver I tried disabling the framebuffer emulation, but the problem remains. Does this bug also occur in older versions of the standalone mupen64plus that used the same version of gliden64 that is in lr-mupen64plus-next?

  • @saccublenda it has been an issue with gliden64 on the pi for a while now and was only just recently resolved (inadvertently I might add). The issue only occurred when frame buffer emulation was enabled and only in standalone mupen64plus. The bug didn't occur in lr-mupen64plus.

  • @quicksilver Ok, I will try to replicate the crash in lr-mupen64plus.

  • Any Update or news from this emulator?
    Its been a while since this post lacks any new feature or announcements

  • @Heartless I had some interactions with the developers on GitHub about the 15 minutes crash. It turned out to be related to texture cache size which was too big (15000) by default.
    m4xw and hhromic prepared a new build with an extra core option that allows the user to set it to 1500, 4000 or 8000, and this fixed the bug for me. The new build can be installed by re-installing lr-mupen64plus-next form source through the RetroPie scriptmodule.

  • @hooperre I tried to build it for RPI3 last night and still has some build issues.
    So for now is not yet ready on the RPI unfortunately. I hope to be debugging the build soon but I'm currently busy with other things at the moment :(

  • @hhromic Yea I tried updating as well but it looks like Im still on a build from about a month ago.

  • @quicksilver The same goes for me. Yesterday I was able to build it and today it can't be updated anymore and aborts with several bugs.

  • @quicksilver @xadox good news! last night we managed to make it work with the upstream dev (m4xw) :)
    We will be testing a few more things before patching it on the repository for good.

    @xadox are you sure you could build the mupen64plus "next" core? It hasn't been able to build for some time now, how did you compile it yesterday?

  • @hhromic said in lr-mupen64plus-next: experimental scriptmodule for testing:

    @xadox are you sure you could build the mupen64plus "next" core? It hasn't been able to build for some time now, how did you compile it yesterday?

    Yes. Since I was able to set it up at runcommand as default emulator.
    Also, I get the folder lr-mupen64plus-next with in it under libretrocores.

    I build it just as you described:

    sudo ./ lr-mupen64plus-next clean
    sudo ./ lr-mupen64plus-next

  • @xadox just to confirm, you are building on an RPI device right?
    Also can you check in scriptmodules/libretrocores/ what it says on the gitPullOrClone line? I've been also updating the scriptmodule recently.

    Anyway, the build fix is now upstream and it should work for everyone.

    Just make sure you also update the scriptmodule. I recommend you to delete it and re-apply the instructions on the original post to make sure you are using the latest version.

    This is now building the new updated GLideN64 plugin, so any feedback on how games are working for you, including your setup (RPI model, settings, GPU memory) are highly appreciated by the upstream developer to continue improving this core.

    Be warned that some games take a bit of time to boot, so be patient!

    An option we are very interested on getting feedback about is the Max Texture Cache Size. It is defaulted to 1500 on RPI but we think it can be raised to 4000 without major issues. If you can test that setting with different games and provide input it would be awesome.

    Thanks everyone!

  • Update
    We found that games only boot once, if you try to boot them again it will crash.
    This is due to a new shader cache. To make games boot again, you have to clear the cache in $HOME/RetroPie/BIOS/Mupen64plus/shaders. We will investigate more.

    EDIT: This can be circumvented for now setting the EnableShadersStorage option to False.
    EDIT2: A commit was pushed now to disable this option entirely on the RPI, so you should be fine now.

  • Update

    The FBemulation option is now also made available to RPI devices, with it being default to Off.
    M4xw suggested me to play with it to see how it goes, and to play with:

    EnableLODEmulation = Off
    NoiseEmulation = Off

    There is also a new FXAA option that we can play with on the RPI and see how it goes.

    Lastly, m4xw also suggest to make sure you are experimenting with video threaded enabled in RetroArch, that potentially can give better performance as well.

    Happy testing guys!

  • @hhromic I was just about to report that FBE appeared to be off even though it was set to true. If I update it should fix this problem? (I updated about an hour ago)

  • Looks like some games refuse to boot if framebuffer emulation is enabled. SW rogue squadron and battle for naboo for example.

    Ocarina of Time has severe graphical depth issues if framebuffer emulation is enabled.

    Also performance is much better than I expected, being able to have the advantages of up to date gliden64 and tweaking per game settings using retroarch is amazing.

    Edit: I tested OOT with standalone Mupen64plus/gliden64 and it has the same graphical depth issues. If framebuffer emulation is turned off it looks ok. Must be a function the pi is incapable of.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.