Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

RetroFlag safe shutdown config problem



  • Setting up my nespicase+ for safe shutdown. It requires dropping into the terminal to execute a command. The command contains the "pipe" symbol. It's on my keyboard but will not appear on screen. Without it, I'm screwed. Is there some Linux trick to make the "pipe" symbol appear? I've tried reconfiguring the keyboard, but no luck. Can't understand why such a simple thing should be such a pain in the butt. Pipe works fine in Windows.


  • Global Moderator

    @MikeC Change you keyboard layout to US using raspi-config. The default Raspbian image has an UK layout.



  • @MikeC
    sudo dpkg-reconfigure locales #it is a long list be sure to check "en_US.UTF-8" use TAB key for cursor placement. ISO-8859-1 may be problematic too.

    or

    use key combo "ctrl+shift+u" and type in unicode "7c" and press "enter"

    and

    Goodluck. This is the script I used for my case reset button exits emulator and power switch saves EmulationStation Metadata.



  • Also the pipe symbol means that the command with file in argument is being piped to the next command. So if you wget a file it is saved in your current directory, then you can just run the next command on that file.



  • Thanks folks for your great advice and quick response. Making the keyboard change in raspi-config worked like a charm. By the way, I highly recommend this nespicase+ case. Thanks again!!!


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.