Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

DualShock4 disconnecting using native bluetooth



  • Hello guys, I recently bought a Raspberry 3 B+ and installed Retropie on top of Raspbian Stretch. I'm having problems playing with a dualshock4 in wireless mode with the board's built-in bluetooth module. The controller disconnects after a while in playing crash team racing with lr-pcsx-rearmed. The game sends a lot of vibration signals (i.e. the controller vibrates a lot in this game), so I guess what's happeing is that the bluetooth module is not being able to handle all the TX and RX signals and eventually gets overwhelmed and loses connection with the controller. I've already read that the built-in bluetooth on the Pi is not that great so I guess my problem has no fix at all, but I thought to share this here if someone knows something I've been missing. I attached a system log of while I was playing and the controller lost connection which shows bluetooth errors in the end. The controller was charged, it didn't disconnect because of drained battery. This also doesn't seem to happen in any other game. Any ideias?

    Pi Model or other hardware: 3 B+
    Power Supply used: Foundation's Official 5.1V - 2.5A PSU
    RetroPie Version Used: 4.4.9
    Built From: Manually installed on top of Raspbian GNU/Linux 9.8 (stretch)
    USB Devices connected: None
    Controller used: Wireless Controller (DS4)
    Guide used: https://github.com/RetroPie/RetroPie-Setup/wiki/PS4-Controller#regular-bluetooth-pairing
    Emulator: lr-pcsx-rearmed
    Attachment of log file: https://pastebin.com/dy4XkbMr
    How to replicate the problem: Play Crash Team Racing for a while with DS4 via bluetooth with vibration enabled.


  • Global Moderator

    @ivooc Try to disable the Wifi (only) during gameplay and see if you get better results (sudo rfkill block wifi).



  • @mitu Ok, just tried that. Controller disconnected on 3rd lap in Cortex Castle time trial. I executed the command through SSH while the board was connected via wifi (duh), but then I was unable to connect again and checked in Retropie wifi settings and there was no info of any connection, so I guess the command worked. But it apparently didn't help with the problem...



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.