Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

retroarch crashing when connecting any new controller


  • Global Moderator

    @KrtschMaster said in retroarch crashing when connecting any new controller:

    RetroPie Version: Merge a161774a 0311a953 (only thing close to version i could find)

    The RetroPie version is shown at the top of the screen when you open the setup script (you seem to have a recent version).

    Retroarch Git version: 9750719

    If you open the RGUI, you'll see the RetroArch version at the bottom of the menu

    Verbose logging is not possible as I can't launch the runcommand menu.

    Did you disable the Runcommand menu ? It's enabled by default - https://retropie.org.uk/docs/Runcommand/#runcommand-launch-menu ?

    Is the problem only with PS1 games or also with other games ?



  • Thanks.
    So retroarch version is 1.7.6
    retropie version is 4.4.9
    the dialog is turned on and when i use the xbox controllers with ps controllers not plugged in, it starts fine. But with plugged in PS controllers it does not even get to the launch screen.
    The problem is with every emulator that uses retroarch. I cant even launch the menu entry "Retroarch" from within emulationstation.


  • Global Moderator

    @KrtschMaster Update your RetroPie-Setup script, there have been some improvements w.r.t. Runcommand and gamepads in the last 2 weeks, so this might fix the Runcommand not appearing.
    Can you get a listing of your gamepads with cat /proc/bus/input/devices and show them in a code block here in the topic ?



  • i'm currently backing up the working sd card. this takes a while. then i'll poste the inputs and try the update. if my memory is correct, there was an error when i wanted to update the setupscript last time. but this could have been some weeks ago. I'll try again.
    I come back here when everything is done, give me some hours. ^^
    Thanks so far.



  • Well now, I did the update (basic packages/update all) the runcommand launch screen is now visible and I selected launch with verbose. The error message is still the same. -> https://pastebin.com/Z1mjF0Zf

    Here is the proc/bus/input/devices output: https://pastebin.com/bSEnBtW9
    I will now try to set everything up with a fresh image.



  • I have now installed retropie from scratch. It is not updated in any way, just the image from retropie.org.
    I have set up one ps4 via bluetooth and 2 ps1 controllers via usb adapter. Right now it works fine. I suspect the xbox receiver to interfere with the other controllers. when i had the ps3 controller setup and on and turned on an xbox controller, it took the nex available index (LED on the xbox logo.)
    I will do some testing and report back. but i think i will stick with the fresh image and go on from here.


  • Global Moderator

    @KrtschMaster I'd suggest to update to latest version before installing any drivers and use the sixaxis driver instead of the ps3controller driver. Also, you don't need to install xboxdrv, it's not an actual Xbox driver - but an userspace driver simulating an Xbox controller. For Xbox wired controllers, the driver used is xpad, which I suggest re-installing after you update everything (OS + RetroPie packages and script).

    I think your problem comes from the xboxdrv, which interferes with normal controller operations. Your RetroArch log is still not set to verbose, to check what controllers it detects.



  • After the fresh install yesterday I setup one ps4 bt controller and two PS1 wird controllers. No changes done to the xbox stuff.
    Tested with PS1 game and everything worked great (emulator started up)
    Then i did all Updates, nothing works.
    I will try updating all packages one by one and see which one breaks Thema Controller Setup.


  • Global Moderator

    @KrtschMaster The updates to OS (Linux kernel) will change the drivers - the Sony drivers for PS3/4 controllers will change their mappings with the kernel update. That's why I recommended to do any updates before mapping your controllers.



  • Hello.
    I have now used another sd card with a fresh new image. Did all updates as soon as I could, before configuring any inputs. It took about 3 hours and finished with some warnings on emulationstation. But nothing wild.
    I have then put a psx rom onto the pi and configured one ps1 controller via usb adapter and one ps4 controller via bluetooth.
    Everithing seems to work fine right now. I am going to add the n64 controllers and some more cores. But for now: Thank you very much @mitu for your support.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.