Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Steam Controller | How to configure left pad as buttons?



  • Hi all,

    I was able to add my Steam Controller to my Retropie and set it up as Xbox 360 pad. However, it uses the left pad as touch pad instead of a digital d-pad. Which makes it completely useless as a gamepad and even the navigation in Emulationstation is horrible. Is there any way to configure it, so it will be more like a XBOX 360 pad without that touch input?

    Pi Model or other hardware: 3 B+
    Power Supply used: 5V 3A
    RetroPie Version Used 4.4



  • @NoXPhasma
    I'm not familiar with the device or xpad.
    What do you mean by touch input?
    And are you using xpad or xboxdrv?

    There are some solid configurations here
    https://github.com/RetroPie/RetroPie-Setup/wiki/Xbox-360-Controller#xboxdrv-driver

    From this source, if it is glitchy; changing this selection in /boot/cmdline.txt dwc_otg.speed=1 may help

    Or are you using this standalone steamcontroller driver
    where you have something like this
    sc-desktop.py stop
    steamcontroller-desktop mouse and keyboard function stop.

    Also Hi.



  • @NoXPhasma
    From here

    /etc/udev/rules.d/99-steam-controller.rules

    #find mouse set false.
    mouse = False
    

    I found the steamcontroller has a touchpad, this much makes sense now.



  • @NoXPhasma Ive been following this since i saw it because i really want to find a use for this controller since it feels so nice...aside from my singular postal 2 binge when i bought it!

    So yours actually registers the left trackpad completely??? All four directions?
    Mine on tapping the left trackpad (not even clicking it in which im now assuming is your inquiry) registers up as hat0left and down as hat0right, but also does the same for the actual left and right resulting in "already taken"... Would rather click TBH, but just getting it configured would be a start.

    Its worth noting that i tried both with and without the steam controller driver as it worked without it...sort of! It also works perfectly as if its in keyboard/mouse mode outside of ES despite whats set which might explain part of it.

    I think after looking into it today the 4.18 kernel driver overrides whatever is set in the script: gamingonlinux
    I even noticed that when you switch profiles it is supposed to launch a script on the next boot in etc/rc.local but doesnt write anything. I made sure that script (cant remember the exact location, but it had 360.py in it) started on next boot which i confirmed that it did, but no change. Ill try whats suggested in that link later tonight and see what happens.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.