Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Deleted & replaced folders in opt/retropie, now won't boot



  • Currently I access my RetroPie through WinSCP using Root. Long story short... I deleted all the folders in opt/retropie. I replaced them with the same folders i had backed up from a week ago. I know I shouldnt have done it, I really only needed to mess with the configs folder, but for some dumb reason i deleted them all then replaced. Emulation Station will not boot now, during the first black screen it shows that emulationstation.sh has "Permission Denied". It will not boot if I type :emulationstation".

    The line reads as this:
    /opt/retropie/supplementary/emulationstation/emulationstation.sh: Permission Denied

    The supplementary folder wne as oof the folders that was deleted. I can still connect through WinSCP and have tried putting those folders back and I still get this message. Please tell me there is a way to fix this without having to start from scratch.



  • It's okay you can do that. Now that you replaced the folder logged in as your user the current owner and permissions need to be changed from that user to root and the permission to write is needed for the configs and the permission to execute needs to be granted for the emulators executables.

    1. Right-Click on the folder /opt/retropie/ using winscp and select properties(F9).
      Set the user and group to root in the dropdown.
      fill out the checkboxes like this
           R   W   X
    Owner [X] [X] [X]
    Group [X] [ ] [X]
    Others[X] [ ] [X]
    [=] Add X to directories
    [X] Recursively
    
    1. Next Right-Click on the folder /opt/retropie/configs.
      Set the user to pi(UID:1000) and group to pi(GID:1000) or your user name(UID:100?).
      And the checkboxes should look like this.
           R   W   X
    Owner [X] [X] [X]
    Group [X] [ ] [ ]
    Others[X] [ ] [ ]
    [X] Add X to directories
    [X] Recursively
    

    These should be the effective permissions while not completely accurate. Performing a complete update in RetroPie-Setup should restore the remaining non-executable files to ro/rw.


    If you have permission denied while uploading the folders or changing permissions. You need to make two changes to your login session.
    Select the session name and then click "Edit"
    Click the drop down File Protocol and change it to "SCP"
    and then click "Advanced"

    Environment
    |- ...
    |- ....
    |-SCP /Shell
    

    +{Change the Shell from "Default" to "sudo su -" using the drop down menu.}
    Shell: "sudo su -"

    Save and login.



  • This post is deleted!


  • Thanks for taking the time to write this. Worked like a charm and saved me many hours... THANK YOU!!



  • @OwenWilsonsNose
    Yay! You're welcome. Have a good day.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.