Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

How to configure controller for pcsx-rearmed (pi3) ?


  • Global Moderator

    @Duxa said in How to configure controller for pcsx-rearmed (pi3) ?:

    Looks like they are already set to standard? Unless Im looking in wrong place? Quick Menu -> Options -> Pad 1 Type

    Yes, you're right - I was looking at the previous log (where it was set to default).

    also forgot to mention to your earlier post about being bad rom... possible... but the other emulator runs it?

    Yes, that's puzzling.

    I don't have the PI system at hand now - so I could compare the output. The only differences that I can think of:

    • I have lr-pcsx_rearmed installed from binary, so maybe a source update broke something due to a recent commit ? Unlikely, since it didn't work also before the update.
    • I run the game from the internal SD card (and not from the USB). I don't think that makes a difference, but you could try just for kicks to run it from the sd card.
    • the BIOS - also highly unlikely since SCPH1001.bin should be widely compatible.


  • Oh it could be the secure data layer for example you have these files
    winnie.cue
    winnie01.bin
    winnie02.bin

    The cue file needs to contain the correct and case sensitive name of each track.

    I haven't ever resolved one of these. Most conversions for example pbp, will lose track02..trackXX and lose audio with it. Other conversions .bin to .iso result in broken audio.

    Sometimes it is a security layer or a buffer and non important.



  • @mitu

    Ok I think I found the issue..... "enhanced resolution" seems to have been the culprit, probably has to do with trying to do weird stuff with FMV. turning off the following two settings the game now plays!

    Quick Menu -> Options -> Enhanced Resolution (slow) - disabled
    Quick Menu -> Options -> Enhanced Resolution speed hack - disabled

    Both of these were enabled by default.

    Thanks for helping me figure this out....

    now I have one more issue.. two actually, not sure if I should start new threads for them...

    one:

    Trying to save current config under Configuration File config gives Failed saving config to "/opt/retropie/configs/psx/retroarch.cfg"

    I checked the permissions and user pi/pi has them and its RWX

    issue two:

    The USB I have the roms on... once in a while (maybe one out of 5 reboots) the USB is not mounted before ES tries to start. so it boots without showing/loading the stuff on USB. Restarting ES fixes it right up (because things are now mounted). I tried adding sleep to start of /opt/retropie/configs/all/autostart.sh but didnt seem to help. Any ideas?



  • @Duxa
    I didn't think of that.

    You could try raspi-config >> boot options >> disable network wait on boot.
    This could speed up boot time and get the mountservice to run earlier.

    interoperability with combining usb3.0 and 2.0 devices
    https://www.raspberrypi.org/documentation/hardware/raspberrypi/usb/README.md#knownissue
    it is hard to read, I'm not sure I understand it.


  • Global Moderator

    @Duxa said in How to configure controller for pcsx-rearmed (pi3) ?:

    one:
    Trying to save current config under Configuration File config gives Failed saving config to "/opt/retropie/configs/psx/retroarch.cfg"

    Don't use that, it will produce a large and unnecessary config file. Instead use the 'Save Game Options' from the Options menu to have these options saved per game.

    I checked the permissions and user pi/pi has them and its RWX

    issue two:
    The USB I have the roms on... once in a while (maybe one out of 5 reboots) the USB is not mounted before ES tries to start. so it boots without showing/loading the stuff on USB. Restarting ES fixes it right up (because things are now mounted). I tried adding sleep to start of /opt/retropie/configs/all/autostart.sh but didnt seem to help. Any ideas?

    How are you mounting the USB stick ? Are you using the default RetroPie method (auto-mount) or you added the USB stick to /etc/fstab ?
    Either way, I think your can modify the system boot order and have the usbmount or the fstab mounts be dependencies for the multiuser target. I remember I answered someone in the forums which had a similar problem (splashscreen was on usb-stick, but it wasn't mounted on time to be read), but for the life of me I can't find the post right now.
    I'll get back on this.



  • @Efriim said in How to configure controller for pcsx-rearmed (pi3) ?:

    @Duxa
    I didn't think of that.

    You could try raspi-config >> boot options >> disable network wait on boot.
    This could speed up boot time and get the mountservice to run earlier.

    Some devices show inoperability when combining usb3.0 and low speed 2.0 devices
    https://www.raspberrypi.org/documentation/hardware/raspberrypi/usb/README.md#knownissues

    I believe that setting is off by default? Ill have to double check. Maybe I can edit something to add a wait loop somewhere to wait until usb is mounted and then like 5 seconds before even attempting to launch ES?



  • @mitu said in How to configure controller for pcsx-rearmed (pi3) ?:

    @Duxa said in How to configure controller for pcsx-rearmed (pi3) ?:

    one:
    Trying to save current config under Configuration File config gives Failed saving config to "/opt/retropie/configs/psx/retroarch.cfg"

    Don't use that, it will produce a large and unnecessary config file. Instead use the 'Save Game Options' from the Options menu to have these options saved per game.

    I checked the permissions and user pi/pi has them and its RWX

    issue two:
    The USB I have the roms on... once in a while (maybe one out of 5 reboots) the USB is not mounted before ES tries to start. so it boots without showing/loading the stuff on USB. Restarting ES fixes it right up (because things are now mounted). I tried adding sleep to start of /opt/retropie/configs/all/autostart.sh but didnt seem to help. Any ideas?

    How are you mounting the USB stick ? Are you using the default RetroPie method (auto-mount) or you added the USB stick to /etc/fstab ?
    Either way, I think your can modify the system boot order and have the usbmount or the fstab mounts be dependencies for the multiuser target. I remember I answered someone in the forums which had a similar problem (splashscreen was on usb-stick, but it wasn't mounted on time to be read), but for the life of me I can't find the post right now.
    I'll get back on this.

    Yeah I ended up doing individual settings for those two games, but I noticed that after updating retroarch it added an annoying frame count in bottom left, and only way to get rid of it is to turn it off and save the overall config, otherwise ill have to turn it off and create config for every single game. I ended up manually editing the config file to turn it off via SSH. But doesnt seem right that I cant save the file from within retroarch? This may cause other issues? So I should probably get that fixed?

    For mounting I am actually using both. I have two 64GB sticks, PSX and Sega CD games dont fit on one of them, so Im using both. And auto-mount method only supports one. So I am using that on one of them, and then using fstab for second one.

    I dont mind if boot time is longer, even if its like an extra 15 to 30 seconds, as long as it can reliably mount both of them, so yeah some sort of dependency config would be great for my use. I wish auto mount method supported multiple USBs, like having folder "retropie-mount0" on one then "retropie-mount1" on another... up to at least 4 total (0-3) for the 4 USB ports on a pi. I could get a 128GB single stick, but I already have these laying around so kind of a workaround not a solution.



  • @Efriim

    @Duxa

    I don't know how to force bios, other than by suggesting to the lr-core by removing the other bios options, and I haven't tested this, or known any priorities other than it prefers scph101.bin

    The search order for BIOS files is fixed: https://github.com/hhromic/pcsx_rearmed/blob/588bf7918460109815d5cc505ada4334a4c5a791/frontend/libretro.c#L1934-L1939

    	const char *bios[] = {
    		"SCPH101", "scph101",
    		"SCPH5501", "scph5501",
    		"SCPH7001", "scph7001",
    		"SCPH1001", "scph1001"
    	};
    

    @Duxa

    Quick Menu -> Options -> Enhanced Resolution (slow) - disabled

    Quick Menu -> Options -> Enhanced Resolution speed hack - disabled

    Both of these were enabled by default.

    Are you 100% sure these are enabled by default? As far as as I know that is not true.

    From the source code: https://github.com/libretro/pcsx_rearmed/blob/588bf7918460109815d5cc505ada4334a4c5a791/frontend/libretro.c#L495-L497
    It can be seen that these options are defaulted to disabled, and as far as I remember they are disabled on fresh install of the core.


  • Global Moderator

    @Duxa I would advise to use the manual mount method, it's more flexible (i.e. edit /etc/fstab and add the mount manually). I've found the old topic (see here) with the similar problem.
    You can modify the autologin service to start after any local filesystems have been brought online (i.e. mounted). The systemd unit file is at

    /etc/systemd/system/autologin@.service
    

    so just add a After=local-fs.target in the Unit's dependencies sections.



  • @hhromic said in How to configure controller for pcsx-rearmed (pi3) ?:

    @Efriim

    @Duxa

    I don't know how to force bios, other than by suggesting to the lr-core by removing the other bios options, and I haven't tested this, or known any priorities other than it prefers scph101.bin

    The search order for BIOS files is fixed: https://github.com/hhromic/pcsx_rearmed/blob/588bf7918460109815d5cc505ada4334a4c5a791/frontend/libretro.c#L1934-L1939

    	const char *bios[] = {
    		"SCPH101", "scph101",
    		"SCPH5501", "scph5501",
    		"SCPH7001", "scph7001",
    		"SCPH1001", "scph1001"
    	};
    

    @Duxa

    Quick Menu -> Options -> Enhanced Resolution (slow) - disabled

    Quick Menu -> Options -> Enhanced Resolution speed hack - disabled

    Both of these were enabled by default.

    Are you 100% sure these are enabled by default? As far as as I know that is not true.

    From the source code: https://github.com/libretro/pcsx_rearmed/blob/588bf7918460109815d5cc505ada4334a4c5a791/frontend/libretro.c#L495-L497
    It can be seen that these options are defaulted to disabled, and as far as I remember they are disabled on fresh install of the core.

    Fairly sure, I certainly didnt set them, maybe some other setting set these? Although if I select to Load Defaults, it still sets these to Enabled. Which is a good thing for 99% of other games, because it does make them look better. Its just these two games need a custom config added or something to future builds.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.