Please do not post a support request without first reading and following the advice in

lr-mame2003-plus Joystick not working after updating

  • Have a Raspberry Pi 3 B+ running RetroPie4.4 using a Dragonrise USB Controller and a Zippy Joystick.

    Before updating lr-mame2003-plus the Joystick was responding perfectly fine (and working fine with all other emulators)

    After updating lr-mame2003-plus (from Source) the Joystick no longer responds.
    (Version is 1.7.3 - MAME 2003-Plus 927c557)
    The Joystick is still working fine in all other emulators including lr-mame2003.

    Have tried re-configuring it in RGUI remapping both Game and Core and saving the remap, but it still does not respond. Have searched extensively and tried just about everything to config the Joystick but with no luck.

    I can change a game's emulator from lr-mame2003-plus to lr-mame2003 and the Joystick works fine. But prefer to use lr-mame2003-plus for some games and use the 4 Way restrictor feature in 2003-plus.

    Any ideas ?


  • goto your options menu and change

    Control mapping to digital it comes with analog_and_digital by default as mame2003 handles analog controllers 2003 doesnt. I was me that update the analog support for 2003+ since your comming from an older version I would recommend you delete the contents of your mame2003-plus/cfg/ this is ust controller setting mame creates. With the recent update to mame2003 I would recommend you do this as well as the structures have changed a little(I never done these updates)

  • Thank you so much ! Control Mapping to 'Digital' the Joystick now works again !

    I feel a bit silly now that it was something so simple :)

    Appreciate it !

  • no problems easy when you know there is a lot of options in to be fair

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.