Please do not post a support request without first reading and following the advice in

[Solved] Somehow my B button now resets and X button opens Retroarch menu without a hotkey. I then updated and made things worse.

  • Alright i haven't messed around with my pi in months nor updated anything. Things were going good until i decided to play it. When i first turn it on i'm greeted with the configuring gamepad menu, no problem. I then start a snes game once the game starts i press the B button it resets the game , and the X button opens Retroarch without holding the hot key. I reset the controller config file at least 3 times thinking i hit the wrong button though still doing the same thing after ever attempt. Was still able to exit the game pressing start and the hotkey.

    I then think maybe it's just really out of date and my Pi was a couple months out of date. Now when i start the controller config i get to the part when it asks for the right analog left it says already taken. And i then have to hit random buttons because it appears to locked up frozen for abit. Same thing happens with right analog right input also hotkey. Tried this numerous times and don't get it haha.

    I'm lost at why this happened before i even updated. Try not to mess around with the Pi anymore i'll be here asking you guys to please fix my mistakes. Few weeks ago when i played my Pi it was smooth.

    Would be very grateful if someone could please tell me what i'm doing wrong. Hopefully what i posted made any sense. Thanks for the time.

    Pi 3 model B +
    Power Supply used: official pi 2.5v
    RetroPie Version Used: 4.4
    Built From: Pre made SD Image on RetroPie website
    USB Devices connected: wifi, keyboard
    Controller used: Logitech F310 gamepad

  • Well i'm dumb. Had the controller on directinput instead of xinput. Update had nothing to do with anything. Sorry about that.

  • Any time you solve an issue yourself it might help to give a step by step in order for others to hopefully fix there reset button issue as well. Such as myself. The topic is the same as my issue, but no solutions typed out. Nice.

  • @NewAgeRipper Never mind. I just realized this is for a wired controller.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.