Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

(Solved) Lots of massive issues after updating to retropie 4.4.11



  • So i have several issues. 8 days ago I updated to 4.4.11 basic install. Now if i hit f4 or in es menu choose exit it reboots emulationstation and says loading system config at the bottom of the es splashscreen and loads all the configs. Press f4 again after that it works. Sometimes when i try to load a game same thing.

    Even though time and date are correct and wifi is working, i can no longer update retropie setup script. It tells me:
    Update failed:
    Fatal: unable to access
    https://github.com/RetroPie/RetroPie-Setup.git/‘ :
    Gnutls_handshake() failed: Error in the pull function

    When i try to configure a controller (mayflash dolphinbar) in emulationstation the left analog up/down axis one no longer works and cant be configured. And either i have no clue where configs for the controllers save now or it isnt saving the configs even though all permissions in opt all the way to the controllers config and the controllers config isnt changing.

    In retroarch none of the hotkeys on my keyboard or controller work. All have the keyboards keys mapped. But i cant exit by any means or enter the menui also have to turn off frame_count the configs. When i setup my controller it shows as gamepad 1 but doesn't work at all



  • Tried to update retroarch from binary and get tons of errors. Including some hotkey fix. Strange thing with the retroarch part is the hotkeys had worked in retroarch, (only tested on keyboard) and it worked until i rebooted the pi. The other problems were still a problem.


  • Global Moderator

    The ES and controller detection in the input configuration could be caused by the SDL update - which has not been reverted. But you seem to have some problems getting the updated script to allow you to downgrade, and that's not related to the update (i.e. the git errors) but it looks like a network/firewall problem.

    You can manually revert to the previous version by manually downloading and installing the SDL packages

    wget https://files.retropie.org.uk/binaries/stretch/rpi3/libsdl2-2.0-0_2.0.8+1rpi_armhf.deb
    wget https://files.retropie.org.uk/binaries/stretch/rpi3/libsdl2-dev_2.0.8+1rpi_armhf.deb
    
    dpkg -i libsdl2-2.0-0_2.0.8+1rpi_armhf.deb libsdl2-dev_2.0.8+1rpi_armhf.deb
    

    and then reboot and check again if get the same problems using or configuring the controllers.



  • @mitu i reset my router so i didnt get error running update script. Then I ran those commands you gave me and it didnt fix anything in controller setup in emulationstation or having any kind of working controllers/keyboard in retroarch.



  • This post is deleted!


  • @mitu so i can exit in retroarch. it takes like 5 minutes to respond after you press buttons. not sure how to fix that



  • Maybe it cant exit. Tried again and nothing. It must have exited due to something else.


  • Global Moderator

    Is your controller wireless (Bluetooth) or wired ? Do you have installed any driver (ps3/sixaxis/xboxdrv/etc.) from the RetroPie-Setup ?

    The frame counter is an indication the RA config file was saved using 'Save Configuration' - you can try resetting it to the default provided by RetroPie, by copying retroarcfg.cfg.rp-dist over retroarch.cfg in /opt/retropie/configs/all (you could make a backup of your existing configuration file).


  • administrators

    @mitu SDL update was reverted a few mins after my post in other thread. (It should be anyway. It's in commit history).



  • @BuZz @mitu i just updated everything tested all was good. Then hooked up wiimote and it is screwed up. The whole problem is my wii classic controller pro’s axis -1 is stuck. All of this issue cause by something stupid. When i found out it was happening only with my wiimote on i tested it on my wii and immediately the pointer hand shot straight up. Time to replace the analog.



  • And i am back in business. What a wasted day of backing up everything. Glad i didnt wipe the card without updating first which allowed me to find the issue. Otherwise tomorrow would be a wasted day too.



  • @BuZz i do have one issue that might have been from my previous update. (Not the update i did 2 days ago) When i quit emulationstation by any method, the first time it restarts emulationstation and says loading config file. Then it shows it loading all of the system configs on the es splashscreen. Next time it works fine. Not a huge deal, just an inconvenience.


  • Global Moderator

    @BuZz said in (Solved) Lots of massive issues after updating to retropie 4.4.11:

    SDL update was reverted a few mins after my post in other thread

    I know, but @edmaul69 was having problems updating the script from git, so the new version wouldn't have been pulled - it was just a workaround for the network problems.



  • @edmaul69
    For ES restarting check some of these files for a trace of the init
    /opt/retropie/configs/all/autostart.sh
    /opt/retropie/configs/all/autostop.sh
    /home/$USER/.bashrc

    And try resetting the boot behavior
    retropie setup script>>Configuration / tools>>autostart
    raspi-config>>boot options

    Set to Auto-login Command line Interface

    With the wiiremote, the analog is stuck, has it got any liquid spilled on it? Try taking the batteries out and resetting it. Make sure that the analog is neutral when putting batteries in/resync.



  • @Efriim thanks for the info. Actually the issue on the analog was a bad solder pad. I just jumpered a wire to the 5v/gnd (didn’t test to find out which it was) on the other axis



  • @Efriim so the issue was in the autostart.sh. I had the emulationstation line with the —-no-splash in it to disable the splashscreen . Somehow a line with just

     emulationstation auto 
    

    Got created underneath it. Now it works fine. Thank you.



  • @edmaul69
    Is that the place to put --no-splash? I had added it directly to the configuration file but it wouldn't merge with any update.


  • Global Moderator

    @Efriim that parameter is not persisted nor read from the configuration file, it only works from the command line.



  • I plugged in my pi. It was closing on netplay everytime.

    in emulationstation on the 'retropie list' there is an item 'RetroArch Netplay' There is an option for hostname set to "retropie" by default. If you have a different hostname for your pi. Change this so they are matching, that worked for me.

    ooppss wrong thread.



  • Not to mention that usb rom setup no longer shows up on the setup



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.