Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

USB stick w/Emulator+Roms automatically used?



  • I had a question concerning whether or not the USB drive I copied all the info to from the SD Card is automatically used when plugged in over the SD Card itself?
    I ask this mainly b/c I intentionally disabled the USB feature under configuration. Does that change reset by chance on reboot, or remain off? Is that required to be on for the USB drive to be the default?
    I'm inclined to believe the USB drive is used instead of the SD Card, but would like verification. Also, is there a way to verify this under File Manager. I don't know a great deal of Linux command-line, but plan on learning.



  • @DarkkMatter If I have you correct, you have a usb drive you are loading the roms from? If you have a setup as described here, then there isn't a proper "yes" or "no" answer to your question. It is "automatically" used in the sense that it is automatically mounted and takes the place of the folder you specified (most likely the home/pi/RetroPie folder). So if you boot the system without that usb drive then the system will try to mount that folder to a device that isn't there, which would be roughly equivalent to deleting the folder. You will get the "No systems found" error if you boot without the usb drive. This will happen even if the files and folders still exist on the sd card, the system just will not no where to look for them.

    As far as verifying, are you wanting to verify that it is loading roms from the usb drive? If you have edited fstab to mount the retropie folder, and your system boots and you can play games then you did it right.

    On boot you should see a line in red that says [Failed] to start usb rom service, then below that will be "Checking file system on [xxxx-xxxx]".

    If you are loading your roms from a usb drive, you can still delete the roms from the sd card to save room, scraped images and videos are still saved on the sd card and can take up a lot of room. Remove the usb drive then Comment out the lines you changed in fstab and reboot the pi, then you can ssh into the pi and delete the roms on the sd card, replace the lines in fstab, plug the usb drive back in and reboot. The system will then be loading the roms from the usb, and you will know for sure because the roms will no longer be present on the sd card.



  • Some more info:
    When I hit F4 to reach terminal, I type df and the /dev/root shows the sd card properly, and /dev/sda1 shows the USB mounted as /media/usb0.
    What I did to copy the entire directory structure was this: cp -r -v ~/RetroPie/ /media/usb/retropie-mount
    When I load File Manager I can't figure out how to view the USB drive at all.
    I plugged the USB drive into my Windows machine and see the following directory structure: retropie-mount-->Retropie-->Bios, retropiemenu, roms, splashscreens folders.
    The roms and bios files were all copied over to their respectful folders correctly.

    I started up the Pi system with the USB out of it, and all emulators + games are still there and work fine.
    I have not edited fstab to mount the retropie folder.
    On boot with USB drive in I do see failed to start service, but then a few lines below I see Starting usbmount@dev-sda1 service...
    So it appears it at first fails, but then a few lines below starts it?

    So am I right to assume with the USB stick plugged in that it is running off of that, even though File Manager only wants to show me my sd card info?

    Edit: Is my next step this: "Configure fstab to automatically mount USB drive" from the link you provided above?


  • Global Moderator

    @DarkkMatter If the auto-mounting of the USB is working, you don't need the manual mounting via /etc/fstab. So far from what you've described, the auto-mount seems to be working.
    If you want to check, put the USB on your PC, copy a new ROM, plug it in the PI, start it and see if the ROM shows up in Emulationstation.



  • @DarkkMatter said in USB stick w/Emulator+Roms automatically used?:

    When I load File Manager I can't figure out how to view the USB drive at all.

    I am not sure how the directory structure differs using the auto-mounting method but you access the usb drive when you access the /Retropie folder, the usb drive won't show up as a separate drive or anything like that. When you access the RertroPie folder via command line, file manager, or WinCP you will see the contents of the usb drive.

    Follow mitu's advice (being sure that usb rom service is still disabled) only worry about doing a manual mount if that fails.



  • Well I did what Mitu said and copied a few roms over, which did not show up on the game/emulator list. So I assume its not reading off of the USB drive, but the sd card.
    Also, I tried enabling USB service, shutdown, then started up again and it could not find any game systems.
    Removed USB drive, restarted and systems are all there again with roms.

    So I guess I have to manually mount this USB drive?


  • Global Moderator

    @DarkkMatter said in USB stick w/Emulator+Roms automatically used?:

    So I guess I have to manually mount this USB drive?

    Before attempting to manual method, can you exit Emulationstation and then type mount, posting the output here in the topic ?



  • @mitu
    Sorry noob question, but how would I PrintScreen to capture the output to post here. I got it hooked up to a separate TV.
    Is there certain line in question? I'll just type it out one I think you are looking for:
    /dev/sda1 on /media/usb0 type vfat (rw, no suid, nodev, noatime, nodiratime, sync, uid=1000, gid=1000, fmask=0022, dmast=0022, codepage=437, iocharset=ascii, shortname=mixed, errors=remount-ro)

    I dont see anything else mentioning the USB drive besides that.


  • Global Moderator

    @DarkkMatter said in USB stick w/Emulator+Roms automatically used?:

    @mitu
    Sorry noob question, but how would I PrintScreen to capture the output to post here. I got it hooked up to a separate TV.

    Usually through SSH.

    Is there certain line in question? I'll just type it out one I think you are looking for:
    /dev/sda1 on /media/usb0 type vfat (rw, no suid, nodev, noatime, nodiratime, sync, uid=1000, gid=1000, fmask=0022, dmast=0022, codepage=437, iocharset=ascii, shortname=mixed, errors=remount-ro)

    So the drive is mounted ok - the usbmount service is working. Do you have another line that mounts the /media/usb0/retropie-mount to /home/pi/RetroPie ?



  • @mitu
    Thx about SSH.
    No, that line is not present.


  • Global Moderator

    @DarkkMatter Then give the manual method a try. What USB disk/stick is it ?



  • @mitu
    Ok, going to give manual a try and then type mount again to see if that line appears.
    It's Corsair 512GB with Fat32 file system. Came preformatted w/FAT 32. System labels it as usb0.
    So: UUID=E44B-FC4E /home/pi/RetroPie vfat nofail,user,uid=pi,gid=pi 0 2
    ...would be correct obviously replacing my UUID instead of the example?

    Update: I typed in the above in fstab file, saved changes, reopened and confirmed changes were saved, exited. Then full shutdown, started up again and those roms are not present yet, so I went to terminal typed mount and I did not see that line you mentioned before. I did use my USB drives UUID.

    Update2: Checked fstab file and made typo...put uid-pi instead of uid=pi.... Going to shutdown and restart. Still no luck.

    Update3: I typed in the UUID=E44B-FC4E /home/pi/RetroPie vfat rw,exec,uid=pi,gid=pi,umask=022 0 2 Substituting my UUID, and when it booted up I got a Time(timeout error for the USB disk), Depend(dependency error for File System Check, for /home/pi/Retropie, for Local File Systems, and it would not load further.



  • Well I think I've gone and broke the file system now. As it says its in emergency mode and to hit enter, and I'm not able to do anything beyond that.
    "Cannot access console, the root account is locked."
    Looks like I gotta format the card and reload the image =(

    Another update: Through some forum searching and lucky I had a Linux laptop available, I figured out how to undo the fstab modification and I'm able to load emulation station again fine.

    I'll await any further input before I mess with it again.



  • @DarkkMatter said in USB stick w/Emulator+Roms automatically used?:

    So: UUID=E44B-FC4E /home/pi/RetroPie vfat nofail,user,uid=pi,gid=pi 0 2
    ...would be correct obviously replacing my UUID instead of the example?

    Yes, replace with your uuid, also make sure that that EVERY space is a tab space not a space-bar space; that part hung me up.

    Also look at the directory structure on the usb drive, if it still has the auto-mount structure that is different than the manual mount. Make sure your roms are backed up, then make sure the directory structure on your usb drive looks like /home/pi/RetroPie (if it is still the same as when you tried the auto mount then the first folder will still be RetroPie-mount, which will cause problems)



  • @GoldManSex778
    When I typed in fstab I did use tab instead of spaces, but I found one thing to be strange: When I typed in UUID=E44B-FC4E /home/pi/RetroPie vfat nofail,user,uid=pi,gid=pi 0 2 Using my UUID of course, the 0 near the end was tabbed farther out rather than close as on the page with instructions.
    Earlier when I also tried this: In the case you want to allow execution of file with fat32 file system (E.g : OpenBOR), use

    UUID=E44B-FC4E /home/pi/RetroPie vfat rw,exec,uid=pi,gid=pi,umask=022 0 2 The 0 was properly spaced as in the instructions. Not sure if that means anything, but thought it strange and worth mentioning. I also thought to try this method b/c the filesystem is FAT 32, but got the errors listed above in previous posts.

    At this point in time I have altered the fstab file with the: UUID=E44B-FC4E /home/pi/RetroPie vfat nofail,user,uid=pi,gid=pi 0 2 Line using my UUID instead of the examples.
    When I plug the USB into my Windows machine the first and only folder shown is: retropie-mount, clicking that only 1 folder is shown: Retropie, and clicking that: BIOS, retropiemenu, roms, splashscreen folders.

    I'm sorry I do not understand the difference between auto-mount structure and manual mount structure. I do have a full backup image for my sd card on an external drive.
    How can I do what you asked here: "then make sure the directory structure on your usb drive looks like /home/pi/RetroPie " as the first folder is retropie-mount there are issues?

    Do I just rename retropie-mount to "pi"? Or create a new main folder called "home" and place the renamed retropie-mount(which is now "pi") into the home folder to create the correct structure?

    Thx, again for your guys help on this. Sounds like we are getting closer to solving the issue...I think.



  • @DarkkMatter said in USB stick w/Emulator+Roms automatically used?:

    Do I just rename retropie-mount to "pi"? Or create a new main folder called "home" and place the renamed retropie-mount(which is now "pi") into the home folder to create the correct structure?

    Yes, you posted earlier: retropie-mount-->Retropie-->Bios, retropiemenu, roms, splashscreens folders, change it to home-->pi-->RetroPie-->roms.... Everything else being equal, I am willing to bet that will fix the problem. If you look at the first step in the manual mount method it is to copy that file structure.

    About the two lines the author gives as options, the second appears to set permissions, i am not exactly sure so don't quote me. That must be needed for launching some applications, either one should work. I used the first and have had no problems launching anything (all systems, including ports). About the weird spacing, that is probably normal, those tabs do funny things sometimes. So you are editing this in Nano or file manager? that's pretty hardcore. You can edit those lines in WinCP from a windows computer.

    Thx, again for your guys help on this. Sounds like we are getting closer to solving the issue...I think.

    No prob, it took all of us several tries to get it right; except for mitu, that guy is a legend.



  • @GoldManSex778
    I did try that and still ran into issues so said hell with it...erased everything off of USB drive and started from scratch at instructions for manually mounting. Since I had copied everything over using a previous copy method and that might have been causing issues.
    Right now I'm copying the correct directory structure over, so hopefully everything will work properly now once I do the rest of the steps lol. If anything I've learned some things about Linux from the experience.

    Final Update: Success! Thank you all for helping!

    For anyone ever going through this, one of two things I think was the issue: NOT following the instructions to the letter manually mounting, or my UUID was wrong. I had the last char wrong, but could have sworn it was something different before(either new copy changed UUID, or was my error). Resolution on a laptop helps reading the characters much more clearly than on the TV screen where its almost a guessing game.
    I used WinSCP to confirm that its working, and booting up was much faster!


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.