Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

GPIO Disabled



  • Im setting up my third Retropicade kit. Other two worked great with arcade style GPIO joystick. This one was tricker to set-up, I used a 3B+ and the others a 3B. I had to download the software from this site, use Etcher and install (others worked well with the included pre-imaged software). Most of the tutorials explain this well. I can use the B+ with a usb controller and/or the keyboard. It runs ROMS and seems OK except, It won't read any input from the GPIO. Its like I missed something in the software download/installation. I have not done any internet updates to the B+. I have dial up internet and there is no way. I downloaded the software off site (faster internet!) as that would have been impossible from here as well. Ideas that don't require any downloads? Thanks.....


  • Global Moderator

    @naughtjosh How did you connect the controller to the GPIOs ? Did you install any of the additional drivers needed for such setup - https://retropie.org.uk/docs/GPIO-Modules - ? Simply connecting a few wires to the GPIO pins is not enough.

    Ideas that don't require any downloads?

    Set-up your PI on a location where you have internet, just in case you'll need a driver to be downloaded or use your phone as a WiFi access point.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.