Please do not post a support request without first reading and following the advice in

JSCAL Controller calibration won't work

  • I'm using gamecube controllers with an usb gamecube adapter and got everything working with
    Now I have one Gamecube adapter that has a little drift down on the analog stick. Which causes charakters always move backwards in some games and I can't run forwards, because even though I push the stick up to maximum it isn't recognized as maxium and the charakter in some games (like ocarina of time on n64 emulator) is walking slowly instead of running.
    So I tried to calibrate the controller with jstest like described here:, but after calibrating the controller with the tool it didn't change anything.
    So I tried around little and inverted the axes to find out if retropie is even using the changed configuration at all and I found out that it is indeed using the changed configuration in the retropie emulator configuration (the one that pops up when you start a game and press the A button to change the emulator settings. Could only confirm it there because you can't use analog sticks in any other retropie menu). But in the game itself the inverted axes I configured were ignored. Seems like the emulators won't use those configurations. I tried it with the snes9x and mupen64 emulators and it didn't work for both emulators.
    Has somebody got this controller calibration working with jstest and jscal and knows what I'm doing wrong? Or is there some other way to calibrate a controller for retropie?

  • Global Moderator

    Take a look at this recent topic - If the emulator is using the new evdev api to read/access the gamepad, then jscal doesn't have any effect.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.