Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[Solved] DOSbox not loading conf file



  • I'm having problems getting dosbox to run a custom conf file on the retropie. I run the file from emulationstation but dosbox just quits. I read somewhere on this forum that it was a permissions problem, but I played around with permissions with no success. Does anyone know what might be wrong?

    I also tried to run dosbox from the command line with the -conf flag, but dosbox seems to ignore my configuration file completely. I tried the same on my mac and it works fine.



  • @Nodfyr please supply info requested here: https://retropie.org.uk/forum/topic/3/read-this-first

    Also post the contents of your .conf file, specifically the part under [autoexec]



  • Through trial and error, I figured out how to solve the problem.

    Assuming it was a permissions problem, I first reset all the permissions to the ones all files had at the beginning. As expected, my conf file did not run.

    I then copied the default dosbox configuration file from ~/.dosbox/dosbox-SVN.conf and edited that with my custom setup.

    Now everything works fine, though I never did figure out which permissions were broken.

    Thanks anyway!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.