Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Fallout 1 to work on msdos



  • cant get it to work ,
    i have the AUTOEXEC file like that -
    b44134eb-3365-4faf-9c92-6ae678747f40-image.png
    but still just quit.
    any luck someone else?



  • @shavecat Just to be clear, did you try following this guide:
    https://retropie.org.uk/forum/topic/10192/fallout



  • @Brigane
    Now i will try
    thanks !



  • @shavecat
    The CD isn't required for playing as long as you copy the MASTER.DAT(323MB) and CRITTER.DAT(149MB) to the fallout directory.
    Original US version MASTER.DAT(318MB) and CRITTER.DAT(150MB)

    The fallout.cfg needs some paths, in DOS namesake. This will do:

    [sound]
    music_path1=data\sound\music\
    music_path2=data\sound\music\
    [system]
    critter_dat=.\critter.dat
    critter_patches=.\data
    master_dat=.\master.dat
    master_patches=.\data
    

    There are some settings in there like the cache, cycle_speed_factor and hashing, I haven't tried these for performance.

    These are the patches, you should download all of them. 1.1 is required for 1.2; and 1.2 for 1.35
    Fallout 1.1 patch (official)
    Fallout 1.2 patch (unofficial)
    Fallout 1.35 patch (unofficial)



  • You'll also need DOS4GW in the same directory. If it doesn't come with it, there is an alternate DOS32A that can be downloaded and renamed in its place, it offers no performance gain.

    The dosbox.conf

    [sdl]
    output    = surface
    
    [dosbox]
    memsize   = 64 # needs at least 32mb memory up to 64mb is good.
    
    [render]
    frameskip = 1 # It is good use of 1 frameskip, it will be essential to employ this in order to balance the audio with the high cycle rate.
    
    [cpu]
    core      = dynamic
    cputype   = 386 # I'm fairly certain to use 386
    cycles    = fixed 44350 # This was practically the highest value I could get.
    #cycles=max # Max is a good option too. Or reduce the cycles by about 12000
    cycleup   = 1650
    cycledown = 1650
    
    [mixer]
    rate      = 22050 
    blocksize = 2048
    prebuffer = 270 
    
    [dos]
    ems = emm386
    

    The fallout.cfg

    #I'm looking for debug variables that might help
    [preferences]
    combat_speed=50
    item_highlight=0
    target_highlight=0 #turned the highlight off, it is probably no consequence
    
    [sound]
    music_path1=data\sound\music\
    music_path2=data\sound\music\
    cache_size=448 # Sound cache size, I guess is for DirectX sound only. Non applicable.
    [system]
    art_cache_size=8 # I reduced this because I ran out of memory.
    color_cycling=1 # This effects the target highlighting randomly enough
    cycle_speed_factor=1
    critter_dat=.\critter.dat
    critter_patches=.\data
    master_dat=.\master.dat
    master_patches=.\data
    
    
    

    in case you dont have these drivers for 386 they are needed in the fallout directory.
    hmidet.386
    hmidrv.386
    This is the free 32 bit extender, it can replace \DOS4GW.EXE.
    DOS/32A
    And here is a Fallout 1.2 DOS executable patched with DOS32A, eliminating the need of DOS4GW. Usable with any patch level 1.1 or 1.35.
    FALLOUT.EXE

    I'll update with more as I'm going to try to get this working good too.
    I ran out of memory so reduced the art cache in fallout.cfg, I think I was running 32mb dos.



  • @Efriim
    OMG
    thanks a lot !!! <3
    so i tried , it just give me the loading screen ... and quit :\



  • @shavecat
    Have you set the
    memsize = 32 in the roms/pc/fallout.conf

    art_cache_size=8, in the roms/pc/FALLOUT1/INTRPLAY/FALLOUT/fallout.cfg?

    I think they have to be under their class identifier
    [dosbox] and [system]



  • @Efriim
    So i added to the system in the fallout.cfg
    ed0287ed-6730-446f-bd21-929110532d57-image.png

    still loading screen then exit


  • Global Moderator

    @shavecat Remove the exit at the end of the autoexec section so you can see the actual error.
    And please, try to use text when posting instead of images - it makes it impossible to copy/paste configurations. If you're using Putty, it's enough to select the lines you want copied and they're automatically copied to the clipboard.



  • @mitu
    Thanks , i dont really see the error problem (with the AUTOTEXE) .
    but i loaded it direct with the Fallout.exe file.
    and will try not images no more.
    thanks again.



  • @shavecat
    memsize=32 does go in the dosbox.conf, sorry to confuse them. They look similar, I don't type very well.



  • It is really slow too so don't be too disappointed. It is a great game though, you should play it on your computer.



  • @Efriim
    U right was 64 , now i change it to 32.
    Im still getting like a white screen after loading then quit.

    Shame that is so slow if u saying :\



  • @shavecat
    64 would work, I can't say what isn't working. Usually if it closes after loading. Is it going back to dos? Are you seeing a fallout splashscreen?

    Are you using the Fallout.exe with DOS32A patched, or the regular one from patch 1.2 or 1.1 with DOS4GW? Either would work, but I patched the other one with dos32a myself, so maybe it is just weird.



  • @Efriim
    Fallout 1.1 patch (official)
    i am seeing the splashscreen loading screen for fallout its even chagne everytime i start it again.
    then after loading white screen and exit back to dos (emulator).
    /maybe another patch ?



  • @shavecat
    Nah that patch will work.
    Are you using lr-dosbox?



  • @Efriim
    lr-dosbox no.
    Trying it with that now.. now its really really slow the loading fallout screen looks stuck...and quit :\



  • @shavecat
    Yeah lr-dosbox loads configuration a little differently, like the cycles will be at default 1000, and I don't ever use it to understand it.

    Well heres my autoexec from Fallout.conf, it's nothing special, and it obviously isn't finalized.

    [autoexec]
    # Lines in this section will be run at startup.
    # You can put your MOUNT lines here.
    @echo off
    mount c "/home/pi/RetroPie/roms/pc"
    #mount c "/home/pi/RetroPie/memorycard/dos"
    #set PATH=%PATH%;C:\bin;C:\setedit\bin;C:\bin\HXRT\BIN
    c:
    cd Fallout
    


  • @Efriim

    HOLY MOLY !!!!!
    ITS WORKING !!!!!!! with the dosbox .
    THANKS A LOT !!
    looks good and good speed too.
    thank you !!
    Just load the FALLOUT.EXE .


  • Global Moderator

    @shavecat said in Fallout 1 to work on msdos:

    Just load the FALLOUT.EXE .

    What did you try before - and it was not working ?


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.