Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

PS3 Controller RP3+ issue



  • I recently updated my retropie script and once I did my PS3 controllers stopped working. It still said the drivers were installed. I went and tried to remove the driver and reinstall. Once I did and followed the exact instructions that worked before, it didnt recognize the bluetooth. The USB wire is functioning and I tried this on both PS3 controllers. Any suggestions to what could be causing this? Again, the controllers worked fine prior to updating the retropie software. thanks.


  • Global Moderator

    @common763 There is an issue with the latest Raspbian Linux kernel - see more details and a workaround here.
    I moved your topic in the Help & Support category, it doesn't belong in Projects...



  • ok thanks. stupid question but I have my old setup backed up. could I just delete everything and replace with that or will it cause issues because I already installed the new version?


  • Global Moderator

    @common763 If your backup is the whole sdcard image, yes, restoring should work. You can still update RetroPie, just don't update the OS and packages from Raspbian (there's a prompt when you upgrade RetroPie).



  • @mitu One last question...If I type the below command in the CUI then I should be able to use the controllers? This is on the thread you suggested.

    sudo ./downgrade_firmware.sh downgrade



  • @common763
    Provided you downloaded the script and given it executable permissions.
    git clone https://gist.github.com/psyke83/cb3ca50561480809c246f42727cb7cf2
    cd cb3ca50561480809c246f42727cb7cf2
    sudo chmod +x downgrade_firmware.sh

    The downgrade part will do two important things, it will block the future updates and it will begin downgrading to the date at April 1st.

    After the downgrade is complete you can call the script immediately again to unblock the future updates, as long as you don't plan on updating everything again soon.
    sudo ./downgrade_firmware.sh unblock

    There is also, for lack of my personal understanding and terminology; the future update which will fix the bluetooth connection modules, however it could introduce faults on a experimental or untested level.
    sudo rpi-update



  • @Efriim ok thank you. I am thinking since I have a wired joystick this can wait until a fix comes, but I may just try it anyway. thanks for the help. I mean technically would I have to add the unblock portion of it if I have script that is stopping the wi fi connection? Someone else on this forum a while back gave me script to do this because it was interfering with the bluetooth connection so there is really nothing that would update anyways.



  • @common763 The part of the RetroPie-Setup update script that updates kernel modules, is per-user request so no automatic updates. You'll only have to avoid the main update in the RetroPie-Setup script that requests if you want to update the underlying OS.

    If that was confusing, the downgrade script places holds on the package upgrade system, this in particular will disallow it from fetching kernel updates until the hold is removed.



  • @Efriim thanks.



  • @common763
    You're welcome, it's no problem. As long as you dont Update all and then update underlying packages it is a good idea to run the unblock part of the script so you don't forget or lose it was all I was trying to say.

    Is that Shane Mcmahon?



  • @Efriim said in PS3 Controller RP3+ issue:

    git clone https://gist.github.com/psyke83/cb3ca50561480809c246f42727cb7cf2

    I typed the first line into the CUI and it asked me for a username and password for github. Does that make sense? I dont have a password. Bobby the Brain Heenan. I used him for a fantasy football icon years ago and i guess it is still hanging around.



  • @common763
    Yes this makes sense, most of the time it will ask for a password if it is typed wrong. If you have enabled SSH you could log in to the pi and paste the command. Windows 10 has SSH built-in



  • It's not Shane it's someone else.

    I'm about to format my drive to install Windows 64-bit, am I forgetting anything before it all goes?



  • @Efriim I dont think so. It was asking for my pi generic password then? ok. I will try it tonight again. In all honesty why even update if everything is working properly? I wish I hadnt in this scenario. It looks like the names of the emulators changed too. The FBAlpha one now has FBNeo or something like that associated with it which makes me think it is NeoGeo but that is the one I needed to run some Street Fighter games. The icon in my profile is Bobby the Brain Heenan. Thanks for your help.



  • @common763
    It would have asked for the github password of your associated github account if that address was 1 letter off. On the CLI if you press arrow up you can go through the command lines recent shell commands, to look back and edit what typos you can find.

    The updates are usually good and this one in particular doesn't have anything to do with RetroPie mostly because it is the Raspbian distribution that have progressed and allowed this broken module into passing. Almost all of the emulator update packages can be done individually, and are unconnected with the updating of the underlying Raspbian OS. Though I understand, it can be disappointing to find the extra effort in updating becomes the more effort required to undo something.



  • @Efriim ok. I just ran it properly. I dont think it rolled anything back though. I entered the first line and it went to the second one without any other info scrolling down. When I rebooted the controllers still dont work. SO it did something but dont think it brought me back to the state I was prior to update.



  • @common763

    sudo ./downgrade_firmware.sh downgrade
    If it is working it will display most everything that it is doing, and it will be a long list and you should be able to tell.

    If it was run without sudo then it probably will not do very much.

    Alternatively you could use sudo rpi-update which will bring the latest kernel and with the working bluetooth, But I don't want to say so and then have something go wrong, I used it and it seemed fine, but I am using a different kernel now.



  • @Efriim I typed in sudo chmod +x downgrade_firmware.sh instead so will type in the command you suggested...What is the first command for then? If you are irritated with me by now disregard but would be cool to understand.



  • @common763
    This command allows the script to be executed by changing its permissions with chmod:
    sudo chmod +x downgrade_firmware.sh

    The following are two ways to tell tell the script which of its functions you want to use.
    sudo ./downgrade_firmware.sh downgrade
    sudo ./downgrade_firmware.sh unblock
    'downgrade' is the downgrade process and this sets up the kernel package holds after it is complete.
    'unblock' is the function that will remove the kernel package holds, allowing kernel updates to happen again.

    You can read the script here, it was contributed by the user psyke83
    https://gist.github.com/psyke83/cb3ca50561480809c246f42727cb7cf2



  • thanks.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.