Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

[x86] Cannot install PCSX2



  • When I try to install the experimental package PCSX2 through the RetroPie menu I'm getting an error: E: Unable to locate package pcsx2 retropie

    This is on an x86 Ubuntu install.


  • Global Moderator

    @Panja which Ubuntu version ?



  • @mitu
    I tagged: Ubuntu 18.04



  • @Panja I ran into this with a Lubuntu 19.04 install, but it was not correctable and since youre on ubuntu server could be in the same boat. EDIT: To clarify if you look at the logs im pretty sure its looking for a package that is not in the default repo and it fails to install. The package pcsx2 is in normal ubuntu kde neon and kubuntu repos, but not server nor lubuntu for some really odd reason. Server i get, but lubuntu had me scratching my head...

    You can try adding this repo and see what happens since you're on 18.04:
    Official PCSX2 PPA
    19.04 is NO GO using this PPA.

    Then run the installer from the setup script. If it works and you want to get extra fancy with v1.5+ add this repo afterwords:
    Official Unstable PPA
    then install pcsx2-unstable from the command line. It will remove the normal pcsx2, but runcommand still calls it anyhow and it works great!



  • @Parabolaralus
    It's nice to see you remembered I'm on 18.04 server!
    And indeed, after checking the logs, it's a package not found error.

    I must agree with you, it's fairly strange for Lubuntu.
    For Ubuntu server is understandable.
    After some thinking, that was what @mitu was asking as well I guess.

    When I have some more time I'll give the PPA a try and report back, here in my thread.
    Probably will be after the weekend though but I'll let you know!

    Thanks for your time and help again!



  • @Panja I saw your other thread as well about Dolphin and i hate to say it, but if that doesnt perform well pcsx2 will probably be worse.

    Have you considered setting up a test OS on a flash drive with a full desktop just regular ubuntu to see if theres any performance change? And if you find there is the key is to find out what caused it.

    Dolphin works out of the box for me and everything runs perfectly except F-Zero GX which my cpu is the bottleneck. Same with pcsx2 except there are far, far more games where my old cpu shows...

    I have a phenom ii x6 overclocked to 4.2ghz on air and it just isnt enough...its paired with a gtx 690 not in SLI though the gpu is rarely ever stressed....

    Games i can play full speed so far are some of my favorites: Vice city, Sky Odyssey and Way of the Samarai though none of these are particularly taxing.

    As mentioned dolphin runs pretty much full speed on every game ive tried so far which is quite a list. Your cpu is significantly newer so it should keep up with my crusty ancient dinosaur if not do better.


  • administrators

    You need to enable the "universe" Ubuntu repo. It might be in /etc/apt/sources.list but commented out



  • @Parabolaralus
    Dolphin is indeed not running well on my system imho.
    My CPU is a pretty recent one but couldn't it be a problem with the (integrated) GPU?
    The GPU is not a really powerful one. When running Dolphin I have checked my CPU usage with top and it's hitting 100 to max 140%.
    As my CPU is a dual core with 4 threads my max would be 400% so 100-140% is peanuts...
    Even with F-Zero GX I rarely see my CPU hit over the 140%.

    In some games the FPS is ok but I do see (micro) stutters, it's just not butter smooth.
    I could try a flash drive with (L)Ubuntu desktop but I doubt it'll run better.
    For instance Dreamcast (with standalone) Redream runs flawlessly, 60 fps on all games (standard internal DC res). Really no stutter at all.

    I'll just give PCSX2 a try later on. Maybe it'll work just fine on my system, I hope!

    @BuZz
    Universe is enabled (uncommented), I've checked the sources.list



  • @Panja I think dolphin is single threaded for the most part because the emulated CPU only had one core. 100% on one thread would mean you hit a bottleneck! 140% might be hacked dual threading which i also think it supports.

    I still think this should be doable with what you have though. Im going to go with my previous recommendation to try dolphin and pcsx2 on a regular ubuntu install. I honestly dont know if you can install pcsx2 in lubuntu 18.04 but 19.04 is very troublesome as mentioned earlier.

    I setup a test on my laptop and F-Zero GX ran well...really surprisingly angrily well actually...and the specs for my laptop most notably GPU is weaker then what you have. screenshot for reference with F-Zero GX in the background:fzero.png

    The cpu i have in this laptop doesnt run 100% as well as it should either because its one of the few socketted mobile processors which i swapped from a dead clients laptop, but because of my use of heavy virtualization even though each core is slower i needed as many as possible. For "work" of course!

    I really think your NUC should be fine...

    EDIT: pcsx2 runs piss poor on my laptop. I capped off at 100% emotion engine (cpu) and 4% speed so like 1fps at the Sky Odyssey intro which is not taxing at all...Also it seems to install pcsx2 1.5 now instead of 1.4 without the additional ppa!



  • @Parabolaralus
    Thanks for testing and all your help!
    You convinced me, I’ll try a regular Ubuntu install!
    Though I have to find something to run it off without wiping my current install.

    Did you install Dolphin standalone or through RetroPie?



  • @Panja Through retropie built from source and set to launch dolphin-gui which is why you saw its normal icon to the left. It wouldnt be very useful to you if i installed standalone dolphin now would it???

    Im actually a little upset about how well dolphin ran on this thing...its not that smooth on my desktop, but also the exact opposite scenario for pcsx2 lol

    Perhaps you have a flash drive, sd card, spare hard drive etc laying around? Look around! or worst case partition your boot drive...

    You can even try it booting from ubuntu live "test ubuntu without installing".



  • @Parabolaralus

    Ok cool. I do have a spare SD card somewhere. Should have! Going to give it a go after the weekend. I’m really curious now. 😃

    On my current install I’m running dolphin-gui as well. I was planning to run the non-gui version but as it ran shit on my install I did not switch yet.

    Again I really do appreciate the help.
    Will report back once I have an update.


  • administrators

    @Panja it should be available then - please post it and a log of trying to install. No difference between server edition and desktop apart from installed packages and enabled repos etc.



  • @BuZz

    rps_2019-06-24_083214.log

    Log started at: Mon Jun 24 08:32:14 CEST 2019
    
    RetroPie-Setup version: 4.4.14 (89cabe0)
    System: Linux rgs-01 4.18.0-22-generic #23~18.04.1-Ubuntu SMP Thu Jun 6 08:37:25 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux
    
    = = = = = = = = = = = = = = = = = = = = =
    Installing dependencies for 'pcsx2' : PS2 emulator PCSX2
    = = = = = = = = = = = = = = = = = = = = =
    
    
    = = = = = = = = = = = = = = = = = = = = =
    Installing 'pcsx2' : PS2 emulator PCSX2
    = = = = = = = = = = = = = = = = = = = = =
    
    Hit:1 http://ppa.launchpad.net/ubuntu-x-swat/updates/ubuntu bionic InRelease
    Hit:2 http://archive.ubuntu.com/ubuntu bionic InRelease
    Get:3 http://archive.ubuntu.com/ubuntu bionic-updates InRelease [88.7 kB]
    Get:4 http://archive.ubuntu.com/ubuntu bionic-backports InRelease [74.6 kB]
    Get:5 http://archive.ubuntu.com/ubuntu bionic-security InRelease [88.7 kB]
    Fetched 252 kB in 0s (537 kB/s)
    Reading package lists...
    Reading package lists...
    Building dependency tree...
    Reading state information...
    E: Unable to locate package pcsx2
    Unable to install binary for pcsx2
    
    Log ended at: Mon Jun 24 08:32:16 CEST 2019
    Total running time: 0 hours, 0 mins, 2 secs
    

    /etc/apt/sources.list:

    # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
    # newer versions of the distribution.
    deb http://archive.ubuntu.com/ubuntu bionic main restricted
    # deb-src http://archive.ubuntu.com/ubuntu bionic main restricted
    
    ## Major bug fix updates produced after the final release of the
    ## distribution.
    deb http://archive.ubuntu.com/ubuntu bionic-updates main restricted
    # deb-src http://archive.ubuntu.com/ubuntu bionic-updates main restricted
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team. Also, please note that software in universe WILL NOT receive any
    ## review or updates from the Ubuntu security team.
    deb http://archive.ubuntu.com/ubuntu bionic universe
    # deb-src http://archive.ubuntu.com/ubuntu bionic universe
    deb http://archive.ubuntu.com/ubuntu bionic-updates universe
    # deb-src http://archive.ubuntu.com/ubuntu bionic-updates universe
    
    ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
    ## team, and may not be under a free licence. Please satisfy yourself as to
    ## your rights to use the software. Also, please note that software in
    ## multiverse WILL NOT receive any review or updates from the Ubuntu
    ## security team.
    deb http://archive.ubuntu.com/ubuntu bionic multiverse
    # deb-src http://archive.ubuntu.com/ubuntu bionic multiverse
    deb http://archive.ubuntu.com/ubuntu bionic-updates multiverse
    # deb-src http://archive.ubuntu.com/ubuntu bionic-updates multiverse
    
    ## N.B. software from this repository may not have been tested as
    ## extensively as that contained in the main release, although it includes
    ## newer versions of some applications which may provide useful features.
    ## Also, please note that software in backports WILL NOT receive any review
    ## or updates from the Ubuntu security team.
    deb http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
    # deb-src http://archive.ubuntu.com/ubuntu bionic-backports main restricted universe multiverse
    
    ## Uncomment the following two lines to add software from Canonical's
    ## 'partner' repository.
    ## This software is not part of Ubuntu, but is offered by Canonical and the
    ## respective vendors as a service to Ubuntu users.
    # deb http://archive.canonical.com/ubuntu bionic partner
    # deb-src http://archive.canonical.com/ubuntu bionic partner
    
    deb http://archive.ubuntu.com/ubuntu bionic-security main restricted
    # deb-src http://archive.ubuntu.com/ubuntu bionic-security main restricted
    deb http://archive.ubuntu.com/ubuntu bionic-security universe
    # deb-src http://archive.ubuntu.com/ubuntu bionic-security universe
    deb http://archive.ubuntu.com/ubuntu bionic-security multiverse
    # deb-src http://archive.ubuntu.com/ubuntu bionic-security multiverse
    


  • @BuZz
    Just tried a fresh install of Lubuntu 19.04 and I've got the same problems.



  • @Parabolaralus
    I did a fresh install with Lubuntu 19.04 and build RetroPie from scratch with Dolphin.
    It does run better. Though some games don't run butter smooth as well.
    To be honest GameCube was an extra for me. If it doesn't run well I just remove the system from my setup. No problem.

    Adding the PCSX2 ppa to my 18.04 install did not work.
    Well adding the PPA did work of course but I cannot install PCSX2 through the RetroPie menu afterwards.


  • Global Moderator

    @Panja You're running a x64 arch (x86_64), pcsx2 is only available on i386 (32bit) - https://packages.ubuntu.com/bionic/pcsx2.



  • @mitu
    That is correct, I'm running 64-bit Ubuntu (server).
    Reading the github page (https://github.com/PCSX2/pcsx2/) it says:
    OS: Windows Vista SP2 or newer or GNU/Linux (32-bit or 64-bit)

    So I thought it would be possible and didn't think about noting my 64-bit build.



  • @Panja I was not able to figure out why pcsx2 cannot be installed on lubuntu 19.04, but it does work fine with kubuntu and ubuntu 19.04 64-bit.


  • Global Moderator

    @Panja You can still install it, you just need to add the i386 repositories - see https://github.com/PCSX2/pcsx2/wiki/Installing-on-Linux. Scroll down to the Ubuntu installation instructions.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.