Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

lr-cannonball (outrun engine)



  • Hi, I haven't found any topics talking about this. There is a repository for libretro cannonball (Outrun engine) located here: https://github.com/libretro/cannonball and it looks like it's supposed to work on Raspberry pi. When I look at the current scriptmodules available for Pi zero, I only see the original core (https://github.com/djyt/cannonball). I've been trying to get that to run (the original core), it compiles, but just can't seem to get it run. Are there any plans to look at the libretro version and see if it can be included officially in Retropie (as a scriptmodule)? And if possible, to get it compiling properly or have a binary available for pi zero/one? It compiles successfully for me, but when I run it, I get the dreaded 'illegal instruction' on the zero. I saw there was this Diff: https://github.com/djyt/cannonball/compare/master...Avnerus:master in one of the forks of the original, but that didn't seem to make any change for me, still 'illegal instruction'. Maybe it's something to do with "Double Buffering" I heard maybe the zero does not support that? I also get the same 'illegal instruction' when trying out the libretro version on the zero. I've checked the Cflags and tried both armv6 and arm1176jzf-s



  • I got the non-libretro version working for pi zero (Retroflag Gpi case) and wrote up a guide in case it helps anyone interested in Cannonball on Pi zero: https://sinisterspatula.github.io/SuperRetropieGuides/cannonball and also, if it helps retropie dev's in adding a pi zero specific version, my modified repository that worked for zero is located here: https://github.com/SinisterSpatula/cannonball



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.