Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

PowerBlock at powerstrip with switch powers on unintendedly



  • I have observed that the PowerBlock powers sporadically on a Raspberry Pi if the powerstrip is switched on, where the power supply (official Raspberry power supply for 3B variant) for the PowerBlock is connected to.

    This is a continuation of the thread PowerBlock stopped working ("t-t-t-t-t..." noise) .

    The hardware- and software setup is described under https://sslsites.de/superpie.3kelvin.de/index.html. The powerstrip is actually a PowerCube. Two other external harddisks are connected, too.


  • Global Moderator

    Can you post the schematics of your project? Could it be that there is some sort of feedback loop back to the switch pins?



  • It cannot be more classical than that. It is the same as shown here: .

    In my setup it looks like this:
    The red-black cable-pair connects the PowerBlock switch pins to a toggle switch (original SNES switch).
    The green-white cable pair connects the PowerBlock LED pins to a LED (original SNES LED).

    Another red-black cable pair connects pins from the Pi-header to a reset switch (original SNES switch) according to: .


  • Global Moderator

    Sorry for this delayed reply.

    I guess it has to do with a transient voltage that originates from the power strip. Does this also happen, if the external hard disks are not connected to the strip? I have not heard of that behaviour so far, I am see that I am guessing at the moment.



  • @petrockblog said in PowerBlock at powerstrip with switch powers on unintendedly:

    Does this also happen, if the external hard disks are not connected to the strip?

    Thanks for your reply.

    Ah, I forgot to mention that there is another Raspberry Pi 3B+ attached to the powerstrip in a Pi-Desktop housing, again with the original Raspberry power supply for the 3B+ variant.

    I will watch the behaviour without having other devices attached to the powerstrip.

    As the spurious power-on takes place only sporadically, it will take some time before I can report observation results.



  • Too bad, the second PowerBlock is dead. No reaction anymore. Raspberry still works, PowerBlock is gone.

    My assumption is that the official Raspberry power supply kills the PowerBlock. Either by hardware failure or by a software bug in the Atmel Controller.

    Let me know if I can help in investigating the failure. Anything to measure? Anything to try in software? Need some log-files?

    After all, the PowerBlock would have been the ideal solution for a retro SNES.


  • Global Moderator

    @superpie3k I am using the official Raspberry power supply for years now for testing. So far, I did not observe such issue.

    Nevertheless, with the release of the Raspberry 4 two completely new power switch gadgets will be released soon. These new model are designed in different ways and they should not have this issue anymore in your case.

    I would be happy to have you as beta tester.



  • @petrockblog Well, right now it is only my assumption that the power supply in combination with the powerstrip and other power supplies causes the problem. If you are interested in further investigations, I can send back the problematic PowerBlocks, or I could do a few simple measurements.

    Being a beta tester would be fine, I am used to work with hardware/software in development status. However, it depends on the timeframe as I have have an eye on an alternative solution. But if we talk about one, two, three months, I would be glad in acting as beta tester.



  • Any news regarding the new power switch gadgets here?


  • Global Moderator

    In the meantime, we have released the PowerBlockling, which is a minimal power switch solution with less features than the PowerBlock. The PowerBlockling does makes use of the standby mode of the Raspberry Pi and, therefore, does not add an additional USB socket for the power supply. Instead it uses the original Raspberry USB socket.

    @superpie3k Please send me an email with your shipping address. I would send you one PowerBlockling for testing.

    A completely new model of the PowerBlock is also in preparation. It has a USB-C connector and a completely redesigned power switch circuitry that allows up to 6 A while having a voltage drop of only about 6 mV. We expect to release it in one to two months.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.