Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retropie "es" exit back to menu on game launch ?!



  • Hi guys, I have a raspberry pi using retropie and everything is great, until I decided to update my retropie when I got a problem when launching any rom. when I launched a rom it just takes me back to menu. I'm not sure what exactly the problem.


  • Global Moderator

    Please add more info about your system - https://retropie.org.uk/forum/topic/3/read-this-first.
    Please also add the Emulationstation log file (from /home/pi/.emulationstation/es_log.txt) and Runcommand log (/dev/shm/runcommand.log) to pastebin.com so we can take a look.



  • @mitu I have a raspberry pi 3B+, I was on 4.4.4 version of retropie and I have updated it to 4.5.1 version.
    Here is the : es_log.txt

    lvl2: 	EmulationStation - v2.8.4rp, built Jun 26 2019 - 05:27:34
    lvl2: 	Parsing XML file "/opt/retropie/supplementary/emulationstation/resources/mamenames.xml"...
    lvl2: 	Parsing XML file "/opt/retropie/supplementary/emulationstation/resources/mamebioses.xml"...
    lvl2: 	Parsing XML file "/opt/retropie/supplementary/emulationstation/resources/mamedevices.xml"...
    lvl2: 	Creating surface...
    lvl2: 	Created window successfully.
    lvl2: 	Added known joystick Sony Interactive Entertainment Controller (instance ID: 0, device index: 0)
    lvl2: 	Checking available OpenGL extensions...
    lvl2: 	 ARB_texture_non_power_of_two: MISSING
    lvl2: 	Loading system config file /etc/emulationstation/es_systems.cfg...
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/theme.xml"
        could not find file "" 
    lvl1: 	System "amstradcpc" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/arcade/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/arcade/../theme.xml")
        could not find file "" 
    lvl1: 	System "arcade" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/atari2600/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/atari2600/../theme.xml")
        could not find file "" 
    lvl1: 	System "atari2600" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/theme.xml"
        could not find file "" 
    lvl1: 	System "atari5200" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/atari7800/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/atari7800/../theme.xml")
        could not find file "" 
    lvl1: 	System "atari7800" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/theme.xml"
        could not find file "" 
    lvl1: 	System "atari800" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/atarilynx/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/atarilynx/../theme.xml")
        could not find file "" 
    lvl1: 	System "atarilynx" has no games! Ignoring it.
    lvl1: 	Error - folder with path "/home/pi/RetroPie/roms/coleco" is not a directory!
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/theme.xml"
        could not find file "" 
    lvl1: 	System "coleco" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/theme.xml"
        could not find file "" 
    lvl1: 	System "fba" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/fds/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/fds/../theme.xml")
        could not find file "" 
    lvl1: 	System "fds" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/gamegear/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/gamegear/../theme.xml")
        could not find file "" 
    lvl1: 	System "gamegear" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/gb/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/gb/../theme.xml")
        could not find file "" 
    lvl1: 	System "gb" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/gba/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/gba/../theme.xml")
        could not find file "" 
    lvl1: 	System "gba" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/gbc/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/gbc/../theme.xml")
        could not find file "" 
    lvl1: 	System "gbc" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/mame/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/mame/../theme.xml")
        could not find file "" 
    lvl1: 	System "mame-libretro" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/mame/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/mame/../theme.xml")
        could not find file "" 
    lvl1: 	System "mame-mame4all" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/mastersystem/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/mastersystem/../theme.xml")
        could not find file "" 
    lvl1: 	System "mastersystem" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/megadrive/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/megadrive/../theme.xml")
        could not find file "" 
    lvl1: 	System "megadrive" has no games! Ignoring it.
    lvl1: 	Error - folder with path "/home/pi/RetroPie/roms/msx" is not a directory!
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/msx/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/msx/../theme.xml")
        could not find file "" 
    lvl1: 	System "msx" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/n64/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/n64/../theme.xml")
        could not find file "" 
    lvl1: 	System "n64" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/neogeo/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/neogeo/../theme.xml")
        could not find file "" 
    lvl1: 	System "neogeo" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/nes/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/nes/../theme.xml")
        could not find file "" 
    lvl1: 	System "nes" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/theme.xml"
        could not find file "" 
    lvl1: 	System "ngp" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/ngpc/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/ngpc/../theme.xml")
        could not find file "" 
    lvl1: 	System "ngpc" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/pcengine/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/pcengine/../theme.xml")
        could not find file "" 
    lvl1: 	System "pcengine" has no games! Ignoring it.
    lvl2: 	Parsing XML file "/home/pi/RetroPie/roms/psx/gamelist.xml"...
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/psx/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/psx/../theme.xml")
        could not find file "" 
    lvl2: 	Parsing XML file "/home/pi/.emulationstation/gamelists/retropie/gamelist.xml"...
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/retropie/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/retropie/../theme.xml")
        could not find file "" 
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/sega32x/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/sega32x/../theme.xml")
        could not find file "" 
    lvl1: 	System "sega32x" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/segacd/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/segacd/../theme.xml")
        could not find file "" 
    lvl1: 	System "segacd" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/sg-1000/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/sg-1000/../theme.xml")
        could not find file "" 
    lvl1: 	System "sg-1000" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/snes/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/snes/../theme.xml")
        could not find file "" 
    lvl1: 	System "snes" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/theme.xml"
        could not find file "" 
    lvl1: 	System "vectrex" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/theme.xml"
        could not find file "" 
    lvl1: 	System "zxspectrum" has no games! Ignoring it.
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/auto-allgames/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/auto-allgames/../theme.xml")
        could not find file "" 
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/auto-favorites/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/auto-favorites/../theme.xml")
        could not find file "" 
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/auto-lastplayed/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/auto-lastplayed/../theme.xml")
        could not find file "" 
    lvl1: 	  Warning from theme "/etc/emulationstation/themes/playstation/custom-collections/theme.xml"
      (from included file "/etc/emulationstation/themes/playstation/custom-collections/../theme.xml")
        could not find file "" 
    lvl1: 	 requested mismatched theme type for [video.md_rating] - expected "rating", got "text"
    lvl1: 	 requested mismatched theme type for [detailed.md_rating] - expected "rating", got "text"
    


  • @mitu said in Retropie "es" exit back to menu on game launch ?!:

    /dev/shm/runcommand.log

    @mitu
    the runcommand:

    
    pi@retropie:~ $ cat /dev/shm/runcommand.log
    Parameters:
    Executing: /opt/retropie/emulators/retroarch/bin/retroarch -L /opt/retropie/libretrocores/lr-pcsx-rearmed/pcsx_rearmed_libretro.so --config /opt/retropie/configs/psx/retroarch.cfg "/home/pi/RetroPie/roms/psx/CTR - Crash Team Racing.iso" --appendconfig /dev/shm/retroarch.cfg
    Memcard 2: disabled
    Starting PCSX-ReARMed
    Running PCSX Version 1.9 (May 28 2019).
    psxMap: warning: wanted to map @80000000, got 0x6f4af000
    Init new dynarec
    testing if we can run recompiled code..
    test passed.
    warning: RAM is not directly mapped, performance will suffer
    Mapped (RAM/scrp/ROM/LUTs/TC):
    77000000/1f800000/1fc00000/08000000/70134000
    found BIOS file: SCPH1001.BIN
    RGB565 supported, using it
    plugin: plugins/builtin_gpu
    plugin: plugins/builtin_spu
    plugin: plugins/builtin_pad
    plugin: plugins/builtin_pad
    Plugins loaded.
    Loaded CD Image: /home/pi/RetroPie/roms/psx/CTR - Crash Team Racing.iso.
    selected sound output driver: libretro
    
    

  • Global Moderator

    I don't see any errors in the files you posted - can you try enabling Verbose logging from the Runcommand launch menu and get the /dev/shm/runcommand.log again ? Please post it on pastebin.com, not in the forum.
    Does it happen for all emulators or just for PS1 games ?



  • @mitu sure, it also happens for all emulators.
    My guessing is when I updated my retropie it creates a local es_systems.cfg that overrides the one from /etc/emulationstation. but not sure where can I find the local one.

    link text --->RUNCOMMAND LOG


  • Global Moderator

    My guessing is when I updated my retropie it creates a local es_systems.cfg that overrides the one from /etc/emulationstation. but not sure where can I find the local one.

    I don't think so, there's no such provision in the installer. If there's a local es_systems.cfg , then you can find it in /home/pi/.emulationstation.

    link text --->RUNCOMMAND LOG

    It's the same log as before - there's no 'Verbose' logging here and - sadly - no conclusive error info.



  • @O-M-A-A So this happens with EVERY rom? Regardless of emulator?
    Does any emulator work as before?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.