Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Sounds problems with Certain Emulators



  • So up until recently, I had Retropie/Emulationstation running perfectly -- but for some reason, I am no longer getting audio when I run several emulators. Some emulators are working fine (MAME, Megadrive, C64, all Game Boy systems), but several are not producing sound (NES, SNES, Atari 2600 and 7800). I'm using the default emulators for each system.

    Not sure whether I inadvertently tweaked a setting that caused a problem, but all of these emulators produced sound in the past.

    I'm currently using an external speaker (via the 3.55 mm plug), but I'm experiencing the same exact problem when I attempt to use the speakers on my HDMI television.

    I spent several hours last night tweaking the usual settings in boot/config.txt (hdmi groups and modes, hdmi_force_hotplug, etc.)

    This issue has me perplexed -- as mentioned, everything was working fine a while back, and I can't imagine what caused this problem.

    Any assistance/suggestions would be appreciated.

    Jim



  • I've noticed audio problems with Retropie as well. I recently switched to a fresh install of 3.8.1. I haven't really thoroughly tested it but the emulator in question is PSX. I seem to be having a hard time with it mainly. For some reason only certain games load. But I was testing a game and when I exited to test another game there was no sound. I exited again and tried another game and still no sound. So I rebooted and audio was working again.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.