Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Controller Configuration Question



  • I have both the RetroFlag SNES controller and the RetroFlag Genesis controller. I primarily use the SNES controller but when I play Genesis games, I want the feel of the original controller. I have already configured everything for 6 buttons on the Genesis controller.

    Here is the problem I am running into:

    I am (and want to continue) using both controllers in Direct Input mode. Both controllers register as "RetroFlag Wired Controller". When I map inputs with the SNES controller and then swap to the Genesis controller, the buttons end up being

    Y A X
    C B Z
    

    rather than

    X Y Z
    A B C
    

    I can solve this by remapping before I launch a Genesis game, but that's tedious and I was thinking I ought to be able to solve it with some kind of an override config file for just the Genesis/Megadrive. I am using lr-picodrive. This doesn't appear to be something that I can do with a core remap file. I have already tried this. I have also tried editing the retroarch.cfg file in the megadrive directory to manually specify the input mappings there but that doesn't seem to have any effect.

    Any help would be greatly appreciated.

    Obligatory information:
    Raspberry Pi 3B
    RetroPie 4.5.1
    Built from official image.
    lr-picodrive


  • Global Moderator

    It's unfortunate that RF has chosen the same name for all controllers, instead of adding a designation to each model. That makes the auto-configuration in RetroArch unable to apply different settings.
    However, there is a solution using the retroarch.cfg for the MD/GEN system - point the gamepad auto-configuration folder to another location (joypad_autoconfig_dir) , where you have the MD controller configuration file with a different input configuration.
    By default, all gamepad auto-configuration files are written to /opt/retropie/configs/all/retroarch/autoconfig - you should have a .cfg file for your controller there. Unfortunately, due to the name collision, it's the same file for both controllers.
    So my advice would be

    1. configure the MD controller as you'd like in ES, this will write the auto-config file in the aforementioned folder. Make sure it works as you like in games.
    2. save the controller config file in (from the default locaton) to /opt/retropie/configs/megadrive/joypad/ (create the folder).
    3. modify /opt/retropie/configs/megadrive/retroarch.cfg and add
    joypad_autoconfig_dir = "/opt/retropie/configs/megadrive/joypad"
    

    After that, re-configure the SNES style controller - which will overwrite your controller config file in the default location - and test again with other systems and with the MD/Gen system if everything works fine.



  • @mitu Thank you. This is exactly what I was looking for.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.