Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Atari 5200 Not Working - "Atari800/OS Emulation Halted"



  • So I got everything set up. I got my ROM library in \\retropie\roms\atari5200. I got all 5 BIOSes in \\retropie\bios. And it just boots into the same error screen every time (pictured below). I switched out all 5 BIOSes from at least 3 different sources. I tried a different ROM library. I mixed and matched everything. I updated the core packages and the OS. I even created that weird config file that the wiki said to make. Nothing. As far as I know, I've followed every instruction to a T, multiple times, in multiple different ways, and I've still gotten the same result every time. What gives?

    Pi Model or other hardware: Raspberry Pi 3 Model B+
    Power Supply used: Official 5V 2.5A Power Supply
    RetroPie Version Used: v4.5.1
    Built From: Pre made SD Image on RetroPie website (retropie-4.5.1-rpi2_rpi3.img)
    USB Devices connected: 2 Retro-bit Sega Saturn Control Pads, 1 Raspberry Pi Official USB Keyboard
    Error messages received:
    alt text
    Guide used: https://github.com/retropie/retropie-setup/wiki/Atari-800-and-5200
    Emulator: lr-atari800
    Attachment of config files: https://pastebin.com/5VY5JmsR
    How to replicate the problem: Just launch any Atari 5200 game.



  • I remember when this happened to me. The part missing from the documentation and most other instructions is that you need to tell the emulator that the specific game you are trying to run is a 5200 game and not an 800 game. You have to go into the menu inside the emulator and set it to 5200 mode the first time you launch a 5200 game. Once you set it, exit it and restart. It's annoying and you have to do it for each game, but it works.

    EDIT: if I recall correctly, I basically had to put the rom file name in the '5200 rom' option. Exiting the game will save the config for that game, thus it keeps the ROM pointer. It's been a year or so since I did this, so my memory is a bit blurry.



  • @Thorr69 I went to Quick Menu > Options and set the system type to 5200, but that didn't work. Turned on autodetect 5200 cartridge type just because that will hopefully save me some time when I do get this mess working, turned on save config on exit, even created a game options file. Nothing. Still just boots to the same error screen. Thank you for trying to help though!



  • @ciano Take a look at the setting for 5200_ROM. That's where the 5200 BIOS file name goes, I think. If you have that filled in and the others empty, it might be the trick. I will fire up my system later today an look at exactly how I did it.



  • Ok, so I hadn't fired up 5200 since before updated to RPi 4.3. I get similar trouble to what you are experienceing. However, I can hit F1 on my keyboard and go to System Settings and change the System Type to 5200. The other thing to make sure of is that you go into the Directories and make sure your 5200 bios location is set. With those two things, my games fire up. HOWEVER, it doesn't seem to hold onto my settings when I exit (either by the F9 option or by using the hotkeys to exit).



  • @Thorr69 I'm not sure what you mean by "the setting for 5200_ROM", but I already set the Atari System to 5200 in the Options menu, and in the Directory menu, System/BIOS is set to /home/pi/RetroPie/BIOS. I have no idea how to change it, pressing A just opens up a screen that says "> / (dir)" and then none of the buttons do anything, except B to go back a menu. I even tried the keyboard, no dice.



  • @ciano Is your BIOS showing up as an available selection? The emulator allows you to assign 3 BIOS files. You need to assign at least one of them.
    F1 menu -> Emulator Configuration -> System ROM Settings -> 5200 BIOS ROM locations -> Original

    That should let you assign your bios file to the default. When you open this, it should start in the directory you set as the BIOS directory. If your 5200.rom file is there, you should see it right away and select it.



  • @ciano your issue is that machine model is srt as Atari 800 rather than 5200. Dig in retroarch menus. Load Atari 5200 core manually, load content (5200 game rom), open Retroarch menu, go to Quick Menu, then Options. You'll see Atari System likely set as 400/800. Change it to 5200 and go back to main menu an load content again. If you quit RetroArch it should save you default system as 5200.
    This is all assuming you have good 5200 bios and pathh to that file entered correctly in Atari.cfg.



  • @Thorr69 I don't see an Emulator Configuration option in the RetroArch menu. I did go to Main Menu > Settings > Directory and check that my BIOS folder was set to home\pi\RetroPie\BIOS, but in that folder nothing showed up except its subfolders. Not even the BIOSes for other systems showed up.

    @adriansos666 When I opened RetroArch from the RetroPie menu on the home screen, the Load Core option said "No items." Below that it just displayed a controller tester, "Start Remote RetroPad", and that's it. I know I have cores on my machine because I can run like 17 other consoles from the home menu already, so I don't know what's up with that. But anyway, I had already done the rest of what you said, per my post above:

    I went to Quick Menu > Options and set the system type to 5200, but that didn't work.

    I have no way of knowing if my BIOSes are good, but per my original post:

    I switched out all 5 BIOSes from at least 3 different sources.

    So how does one enter a path to a BIOS in Atari.cfg? I appreciate all the help you guys, I can provide pictures and video of whatever if need be, just ask.



  • @ciano said in Atari 5200 Not Working - "Atari800/OS Emulation Halted":

    @Thorr69 I don't see an Emulator Configuration option in the RetroArch menu. I did go to Main Menu > Settings > Directory and check that my BIOS folder was set to home\pi\RetroPie\BIOS, but in that folder nothing showed up except its subfolders. Not even the BIOSes for other systems showed up.

    My direction was for the emulator itself, not retroarch. When you are sitting at this screen:
    https://user-images.githubusercontent.com/4813834/38234246-958b4196-371d-11e8-80b2-32b7f3625eb7.png
    Hit F1 to get to the emulator's menu. The screen should then be full of menu options. Emulator Configuration is about halfway down.



  • @Thorr69 Sitting at that screen and pressing F1 just takes me to the Retroarch Quick Menu.
    https://ibb.co/Mf1C9zz



  • @ciano said in Atari 5200 Not Working - "Atari800/OS Emulation Halted":

    @Thorr69 Sitting at that screen and pressing F1 just takes me to the Retroarch Quick Menu.

    You can see the actual menu behind the Retroarch overlay there. I would normally give you the keyboard shortcut to get directly to that menu, but the one we need is the only one that doesn't have a keyboard shortcut.

    Essentially what you are trying to accomplish is the set the variable 5200_ROM. In the atari800.cfg file on line 47 is 5200_ROM. You can edit that file and set it to /home/pi/RetroPie/BIOS/5200.rom by making that line look like this:

    ROM_5200=/home/pi/RetroPie/BIOS/5200.rom

    Once that is set, then when you go to the system menu with Alt+Y (keyboard Y, not button Y), you set the system to 5200 on the first menu item. When you select 5200, the line below should change and it should say:

    OS VERSION: Original(Auto)

    If it does that then you know it found the 5200 bios. From here all you have to do is exit the menu and it should start up your game normally.



  • I had the same issue where it was set to Atari 800 and not 5200, then after it kept crashing for every ROM I tried I downloaded some more roms from another source - turned out my original romset was a dud source and none of them were compatible with this core, I googled for a new source and this corrected the problem for me - so try using a differently sourced rom to confirm if this helps you. my broken romset was for Atari 800, but they failed to boot for me, so all my new roms are inside zip files as .a52



  • @Thorr69 In my Atari800.cfg file it's on line 16, line 47 said "ENABLE_SLOW_XEX_LOADING=0". But I changed the line to what you said, and then IT BOOTED RIGHT INTO A GAME! YES!!! I even went to the system menu with alt+y and verified that the system was already set to Atari 5200, and the OS was already set to Original (Auto). Thank you so much!

    alt text

    @LiveFreeDead I already had .a52 ROMs, but like I said in the OP, I had tried everything from every source I could find.



  • @ciano said in Atari 5200 Not Working - "Atari800/OS Emulation Halted":

    @Thorr69 Thank you so much!

    Happy to help. =)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.