Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Atomic Pi freezes when do basic install (solved)



  • Hi guys, I'm trying to install Retropie on an Atomic Pi, but it freezes when trying to perform basic install.

    I tried on ubuntu 18.04 and lubuntu 19.04, no success.
    Is there anything diferent from the wiki to do on atomic pi?


  • Global Moderator

    AFAIK, the Atomic PI is a regular x86 computer - so the instructions for Ubuntu (or derivates) should apply. You're already doing that, so there's nothing wrong in your set-up.
    What exactly does freeze mean ? Is the computer unresponsive completely or just the installation stops/hangs ? Are you able to access the computer via network/ssh when the freeze occurs ?



  • hi thanks for taking the time to help me out!
    I followed the regular install, as I've done several times on other PCs, but it completely freezes when compiling the basic install modules. I can't move the mouse, use keyboard, or get a response from the computer. Today I left it for more than 3 hours and the screen remained frozen on the same line as the terminal.



  • Hi, I identified and solved the problem, the installation did not have a swap partition, so it was crashing. I did the installation with a 2048MB swap partition and everything go well!


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.