Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

No music in PS1 - ImgBurn rips CUE and BIN, retropie wants cue and bin!



  • I started writing this post, and then thought I'd try a fix myself and it worked! So I thought I'd finish the post for posterity in case somebody else hits the same snag.

    ImgBurn named all my CUE and BIN files I ripped from my old PS1 collection in ALLCAPS. Including the BIN and CUE extension. Retropie wants them to be lowercase. For completeness, I'm also updating the reference to the BIN file that exists within the CUE file to lowercase.

    So for those who are remotely administering their Pi from a Windows machine via network shares, here's a powershell script to automate the process of lowercaseifying your BIN and CUE file extensions. Open up a Powershell console and CD into your Roms folder (so my Pi is named "mir", so you execute "cd \mir\roms\psx")

    Then run the following rename script (or don't, and just do it manually, that's fine too).

    Get-ChildItem | 
      foreach-object { 
        Rename-Item $_ "$([IO.Path]::GetFileNameWithoutExtension($_.Name))$([IO.Path]::GetExtension($_.Name).ToLower())"
      }
    
    Get-ChildItem *.cue | 
      foreach-object {
         (Get-Content $_) -replace 'FILE "(.*)\.BIN"', 'FILE "$1.bin"' | 
            Set-Content -Path $_.Name 
      }
    

    You'll have to reboot your pi after doing this.



  • @Pxtl huh, I can't edit the post. Small bug in the instructions - I think something got confused by double-backslash. It's a network share, therefore it's

    cd \\mypicomputername\roms\psx
    

    before executing the script.


  • Global Moderator

    EmulationStation accepts also CUE files (uppercase), in fact any extension supported is accepted in both lower or upper cases variants (but no mixed cases). As long as the .bin name is correctly stored within the within the file (i.e. it's the same as the actual filename), it should work.
    Thanks for the script, I'm sure it will be handy in the future for other users.



  • @mitu I have no idea if it's some bizarre edge-case specific to my system, but that's what was broken on my machine and what fixed it - seriously, everything was allcaps CUE and BIN - both the CUE file and the BIN file and the reference to the BIN file embedded within the CUE. All in capitals. I confirmed before renaming that the BIN filename 100% matched the value stored within the FILE "..." BINARY reference in the CUE file.

    And I had no music in any of those games.

    Changing all the file-extensions to lowercase (including the FILE "..." BINARY reference within the cue file) fixed it.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.