Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Installed Kodi, No Kodi (solved)



  • so i installed Kodi to give it a try from experimental on my desktop pc running Xubuntu 18.04LTS and Retropie.
    After that i m not able to find Kodi anywhere, say its installed though. not in ports, not a seperate tab nothing
    anyone ?


  • Global Moderator

    In the $HOME/RetroPie-Setup/logs you should have a log file from the time of the installation, archived - can you post the contents of that log file to pastebin.com ?
    If you're unsure which one is the right one, remove them all and then re-install again from the experimental section, you should get a new file.
    Did you restart Emulationstation after installing Kodi ?



  • @mitu yeah i restarted it couple of times until i wanted to try out kodi i noticed it was missing and could not find it anywhere in emulation station,. only thing i could find was in retropie setup that it should have been installed , (installed), but that was all. i ll try again later today



  • @mitu Log started at: do 24 okt 2019 12:18:42 CEST

    RetroPie-Setup version: 4.5.1 (ee294fb0)
    System: Ubuntu 18.04.3 LTS - Linux singingcoyote13-iMedia-S2984 4.15.0-66-generic #75-Ubuntu SMP Tue Oct 1 05:24:09 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

    = = = = = = = = = = = = = = = = = = = = =
    Installing dependencies for 'kodi' : Kodi - Open source home theatre software
    = = = = = = = = = = = = = = = = = = = = =

    Geraakt:1 http://nl.archive.ubuntu.com/ubuntu bionic InRelease
    Geraakt:2 http://nl.archive.ubuntu.com/ubuntu bionic-updates InRelease
    Geraakt:3 http://nl.archive.ubuntu.com/ubuntu bionic-backports InRelease
    Ophalen:4 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
    Ophalen:5 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu bionic InRelease [15,4 kB]
    Ophalen:6 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu bionic/main amd64 Packages [32,8 kB]
    Ophalen:7 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu bionic/main i386 Packages [32,6 kB]
    Ophalen:8 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu bionic/main Translation-en [10,9 kB]
    180 kB opgehaald in 3s (63,5 kB/s)
    Pakketlijsten worden ingelezen...

    = = = = = = = = = = = = = = = = = = = = =
    Installing 'kodi' : Kodi - Open source home theatre software
    = = = = = = = = = = = = = = = = = = = = =

    Geraakt:1 http://nl.archive.ubuntu.com/ubuntu bionic InRelease
    Geraakt:2 http://nl.archive.ubuntu.com/ubuntu bionic-updates InRelease
    Geraakt:3 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu bionic InRelease
    Geraakt:4 http://nl.archive.ubuntu.com/ubuntu bionic-backports InRelease
    Ophalen:5 http://security.ubuntu.com/ubuntu bionic-security InRelease [88,7 kB]
    88,7 kB opgehaald in 3s (35,4 kB/s)
    Pakketlijsten worden ingelezen...
    Pakketlijsten worden ingelezen...
    Boom van vereisten wordt opgebouwd...
    De statusinformatie wordt gelezen...
    De volgende pakketten zijn automatisch geïnstalleerd en zijn niet langer nodig:
    fonts-roboto-hinted fonts-wine gstreamer1.0-plugins-base:i386 icoutils
    kodi-bin kodi-visualization-spectrum libasn1-8-heimdal:i386 libasound2:i386
    libasound2-plugins:i386 libasyncns0:i386 libatomic1:i386
    libavahi-client3:i386 libavahi-common-data:i386 libavahi-common3:i386
    libbsd0:i386 libcairo2:i386 libcap2:i386 libcapi20-3 libcapi20-3:i386
    libcdparanoia0:i386 libclamav7 libcups2:i386 libdbus-1-3:i386
    libdrm-amdgpu1:i386 libdrm-intel1:i386 libdrm-nouveau2:i386
    libdrm-radeon1:i386 libdrm2:i386 libedit2:i386 libelf1:i386 libexif12:i386
    libexpat1:i386 libffi6:i386 libflac8:i386 libfontconfig1:i386
    libfreetype6:i386 libgd3:i386 libgl1:i386 libgl1-mesa-dri:i386
    libgl1-mesa-glx:i386 libglapi-mesa:i386 libglib2.0-0:i386 libglu1-mesa:i386
    libglvnd0:i386 libglx-mesa0:i386 libglx0:i386 libgmp10:i386 libgnutls30:i386
    libgphoto2-6:i386 libgphoto2-port12:i386 libgsm1:i386 libgssapi-krb5-2:i386
    libgssapi3-heimdal:i386 libgstreamer-plugins-base1.0-0:i386
    libgstreamer1.0-0:i386 libhcrypto4-heimdal:i386 libheimbase1-heimdal:i386
    libheimntlm0-heimdal:i386 libhogweed4:i386 libhx509-5-heimdal:i386
    libicu60:i386 libidn2-0:i386 libieee1284-3:i386 libjack-jackd2-0:i386
    libjbig0:i386 libjpeg-turbo8:i386 libjpeg8:i386 libjs-iscroll
    libk5crypto3:i386 libkeyutils1:i386 libkrb5-26-heimdal:i386 libkrb5-3:i386
    libkrb5support0:i386 liblcms2-2:i386 libllvm8:i386 libltdl7:i386
    libmpg123-0:i386 libnettle6:i386 libodbc1:i386 libogg0:i386 libopenal1:i386
    libopus0:i386 liborc-0.4-0:i386 libosmesa6 libosmesa6:i386 libp11-kit0:i386
    libpcap0.8:i386 libpciaccess0:i386 libpixman-1-0:i386 libpng16-16:i386
    libpulse0:i386 libroken18-heimdal:i386 libsamplerate0:i386 libsane1:i386
    libsdl2-image-2.0-0 libsensors4:i386 libsndfile1:i386 libsndio6.1:i386
    libspeexdsp1:i386 libsqlite3-0:i386 libssl1.1:i386 libstdc++6:i386
    libtasn1-6:i386 libtheora0:i386 libtiff5:i386 libunistring2:i386
    libusb-1.0-0:i386 libv4l-0:i386 libv4lconvert0:i386 libvisual-0.4-0:i386
    libvorbis0a:i386 libvorbisenc2:i386 libwebp6:i386 libwind0-heimdal:i386
    libwine libwrap0:i386 libwxgtk3.0-gtk3-0v5 libx11-6:i386 libx11-xcb1:i386
    libxau6:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386 libxcb-glx0:i386
    libxcb-present0:i386 libxcb-render0:i386 libxcb-shm0:i386 libxcb-sync1:i386
    libxcb1:i386 libxcomposite1:i386 libxcursor1:i386 libxdamage1:i386
    libxdmcp6:i386 libxext6:i386 libxfixes3:i386 libxi6:i386 libxinerama1:i386
    libxml2:i386 libxpm4:i386 libxrandr2:i386 libxrender1:i386
    libxshmfence1:i386 libxslt1.1:i386 libxxf86vm1:i386 ocl-icd-libopencl1:i386
    python-wxgtk3.0 python-wxversion supertux-data
    Gebruik 'sudo apt autoremove' om ze te verwijderen.
    De volgende extra pakketten zullen geïnstalleerd worden:
    kodi-x11 libfstrcmp0 libshairplay0 libssh-4 python-cryptodome
    python-simplejson
    Voorgestelde pakketten:
    kodi-pvr-mythtv kodi-pvr-vdr-vnsi kodi-pvr-tvheadend-hts kodi-pvr-dvbviewer
    kodi-pvr-iptvsimple kodi-audioencoder-vorbis kodi-audioencoder-flac
    kodi-audioencoder-lame python-cryptodome-dbg python-cryptodome-doc
    De volgende pakketten zullen VERWIJDERD worden:
    kodi-data kodi-repository-kodi
    De volgende NIEUWE pakketten zullen geïnstalleerd worden:
    kodi kodi-inputstream-adaptive kodi-inputstream-rtmp
    kodi-peripheral-joystick kodi-vfs-libarchive kodi-vfs-nfs kodi-vfs-sftp
    kodi-x11 libfstrcmp0 libshairplay0 libssh-4 python-cryptodome
    python-simplejson
    0 opgewaardeerd, 13 nieuw geïnstalleerd, 2 te verwijderen en 4 niet opgewaardeerd.
    Er moeten 38,9 MB aan archieven opgehaald worden.
    Na deze bewerking zal er 69,3 MB extra schijfruimte gebruikt worden.
    Ophalen:1 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu bionic/main amd64 kodi-x11 amd64 2:18.4+git20190831.2224-final-0bionic [13,1 MB]
    Ophalen:2 http://nl.archive.ubuntu.com/ubuntu bionic/universe amd64 libfstrcmp0 amd64 0.7.D001-1.1build1 [8016 B]
    Ophalen:3 http://nl.archive.ubuntu.com/ubuntu bionic/main amd64 python-simplejson amd64 3.13.2-1 [61,2 kB]
    Ophalen:4 http://nl.archive.ubuntu.com/ubuntu bionic-updates/main amd64 libssh-4 amd64 0.8.0~20170825.94fa1e38-1ubuntu0.2 [169 kB]
    Ophalen:5 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu bionic/main amd64 python-cryptodome amd64 3.5.1-2~bionic [4796 kB]
    Ophalen:6 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu bionic/main amd64 libshairplay0 amd64 0.9.0.2~bionic [100 kB]
    Ophalen:7 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu bionic/main amd64 kodi all 2:18.4+git20190831.2224-final-0bionic [19,7 MB]
    Ophalen:8 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu bionic/main amd64 kodi-inputstream-adaptive amd64 2.4.2-1~bionic [602 kB]
    Ophalen:9 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu bionic/main amd64 kodi-inputstream-rtmp amd64 2.0.6-1~bionic [12,9 kB]
    Ophalen:10 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu bionic/main amd64 kodi-peripheral-joystick amd64 1.4.8-1~bionic [200 kB]
    Ophalen:11 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu bionic/main amd64 kodi-vfs-libarchive amd64 1.0.5-1~bionic [67,4 kB]
    Ophalen:12 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu bionic/main amd64 kodi-vfs-nfs amd64 1.0.1-2~bionic [36,0 kB]
    Ophalen:13 http://ppa.launchpad.net/team-xbmc/ppa/ubuntu bionic/main amd64 kodi-vfs-sftp amd64 1.0.0-2~bionic [30,1 kB]
    38,9 MB opgehaald in 9s (4272 kB/s)
    (Database wordt ingelezen ...
    (Database wordt ingelezen ... 5%
    (Database wordt ingelezen ... 10%
    (Database wordt ingelezen ... 15%
    (Database wordt ingelezen ... 20%
    (Database wordt ingelezen ... 25%
    (Database wordt ingelezen ... 30%
    (Database wordt ingelezen ... 35%
    (Database wordt ingelezen ... 40%
    (Database wordt ingelezen ... 45%
    (Database wordt ingelezen ... 50%
    (Database wordt ingelezen ... 55%
    (Database wordt ingelezen ... 60%
    (Database wordt ingelezen ... 65%
    (Database wordt ingelezen ... 70%
    (Database wordt ingelezen ... 75%
    (Database wordt ingelezen ... 80%
    (Database wordt ingelezen ... 85%
    (Database wordt ingelezen ... 90%
    (Database wordt ingelezen ... 95%
    (Database wordt ingelezen ... 100%
    (Database wordt ingelezen ... 267501 bestanden en mappen momenteel geïnstalleerd.)
    kodi-data (2:17.6+dfsg1-1ubuntu1) wordt verwijderd ...
    kodi-repository-kodi (2:17.6+dfsg1-1ubuntu1) wordt verwijderd ...
    Voorheen niet geselecteerd pakket libfstrcmp0 wordt geselecteerd.
    (Database wordt ingelezen ...
    (Database wordt ingelezen ... 5%
    (Database wordt ingelezen ... 10%
    (Database wordt ingelezen ... 15%
    (Database wordt ingelezen ... 20%
    (Database wordt ingelezen ... 25%
    (Database wordt ingelezen ... 30%
    (Database wordt ingelezen ... 35%
    (Database wordt ingelezen ... 40%
    (Database wordt ingelezen ... 45%
    (Database wordt ingelezen ... 50%
    (Database wordt ingelezen ... 55%
    (Database wordt ingelezen ... 60%
    (Database wordt ingelezen ... 65%
    (Database wordt ingelezen ... 70%
    (Database wordt ingelezen ... 75%
    (Database wordt ingelezen ... 80%
    (Database wordt ingelezen ... 85%
    (Database wordt ingelezen ... 90%
    (Database wordt ingelezen ... 95%
    (Database wordt ingelezen ... 100%
    (Database wordt ingelezen ... 264679 bestanden en mappen momenteel geïnstalleerd.)
    Uitpakken van .../00-libfstrcmp0_0.7.D001-1.1build1_amd64.deb wordt voorbereid...
    Bezig met uitpakken van libfstrcmp0 (0.7.D001-1.1build1) ...
    Voorheen niet geselecteerd pakket kodi-x11 wordt geselecteerd.
    Uitpakken van .../01-kodi-x11_2%3a18.4+git20190831.2224-final-0bionic_amd64.deb wordt voorbereid...
    Bezig met uitpakken van kodi-x11 (2:18.4+git20190831.2224-final-0bionic) ...
    dpkg: fout bij verwerken van archief /tmp/apt-dpkg-install-KhyIlO/01-kodi-x11_2%3a18.4+git20190831.2224-final-0bionic_amd64.deb (--unpack):
    poging tot overschrijven van '/usr/lib/x86_64-linux-gnu/kodi/kodi-xrandr', wat ook in pakket kodi-bin:amd64 2:17.6+dfsg1-1ubuntu1 zit
    dpkg-deb: fout: plakken subproces werd afgebroken door signaal (Gebroken pijp)
    Voorheen niet geselecteerd pakket python-cryptodome wordt geselecteerd.
    Uitpakken van .../02-python-cryptodome_3.5.1-2~bionic_amd64.deb wordt voorbereid...
    Bezig met uitpakken van python-cryptodome (3.5.1-2~bionic) ...
    Voorheen niet geselecteerd pakket python-simplejson wordt geselecteerd.
    Uitpakken van .../03-python-simplejson_3.13.2-1_amd64.deb wordt voorbereid...
    Bezig met uitpakken van python-simplejson (3.13.2-1) ...
    Voorheen niet geselecteerd pakket libshairplay0:amd64 wordt geselecteerd.
    Uitpakken van .../04-libshairplay0_0.9.0.2~bionic_amd64.deb wordt voorbereid...
    Bezig met uitpakken van libshairplay0:amd64 (0.9.0.2~bionic) ...
    Voorheen niet geselecteerd pakket kodi wordt geselecteerd.
    Uitpakken van .../05-kodi_2%3a18.4+git20190831.2224-final-0bionic_all.deb wordt voorbereid...
    Bezig met uitpakken van kodi (2:18.4+git20190831.2224-final-0bionic) ...
    Voorheen niet geselecteerd pakket libssh-4:amd64 wordt geselecteerd.
    Uitpakken van .../06-libssh-4_0.8.0~20170825.94fa1e38-1ubuntu0.2_amd64.deb wordt voorbereid...
    Bezig met uitpakken van libssh-4:amd64 (0.8.0~20170825.94fa1e38-1ubuntu0.2) ...
    Voorheen niet geselecteerd pakket kodi-inputstream-adaptive wordt geselecteerd.
    Uitpakken van .../07-kodi-inputstream-adaptive_2.4.2-1~bionic_amd64.deb wordt voorbereid...
    Bezig met uitpakken van kodi-inputstream-adaptive (2.4.2-1~bionic) ...
    Voorheen niet geselecteerd pakket kodi-inputstream-rtmp wordt geselecteerd.
    Uitpakken van .../08-kodi-inputstream-rtmp_2.0.6-1~bionic_amd64.deb wordt voorbereid...
    Bezig met uitpakken van kodi-inputstream-rtmp (2.0.6-1~bionic) ...
    Voorheen niet geselecteerd pakket kodi-peripheral-joystick wordt geselecteerd.
    Uitpakken van .../09-kodi-peripheral-joystick_1.4.8-1~bionic_amd64.deb wordt voorbereid...
    Bezig met uitpakken van kodi-peripheral-joystick (1.4.8-1~bionic) ...
    Voorheen niet geselecteerd pakket kodi-vfs-libarchive wordt geselecteerd.
    Uitpakken van .../10-kodi-vfs-libarchive_1.0.5-1~bionic_amd64.deb wordt voorbereid...
    Bezig met uitpakken van kodi-vfs-libarchive (1.0.5-1~bionic) ...
    Voorheen niet geselecteerd pakket kodi-vfs-nfs wordt geselecteerd.
    Uitpakken van .../11-kodi-vfs-nfs_1.0.1-2~bionic_amd64.deb wordt voorbereid...
    Bezig met uitpakken van kodi-vfs-nfs (1.0.1-2~bionic) ...
    Voorheen niet geselecteerd pakket kodi-vfs-sftp wordt geselecteerd.
    Uitpakken van .../12-kodi-vfs-sftp_1.0.0-2~bionic_amd64.deb wordt voorbereid...
    Bezig met uitpakken van kodi-vfs-sftp (1.0.0-2~bionic) ...
    Fouten gevonden tijdens verwerken van:
    /tmp/apt-dpkg-install-KhyIlO/01-kodi-x11_2%3a18.4+git20190831.2224-final-0bionic_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    Unable to install binary for kodi

    Log ended at: do 24 okt 2019 12:20:09 CEST
    Total running time: 0 hours, 1 mins, 27 secs

    This is the LOG file i got afterward*****
    It also says unable to install kodi from binary


  • Global Moderator

    I think you alreay have Kodi (or other related package) installed from the Ubuntu repos (version 17) and the new package (18.4) cannot replace it, at least that's what I get from the

    Bezig met uitpakken van kodi-x11 (2:18.4+git20190831.2224-final-0bionic) ...
    dpkg: fout bij verwerken van archief /tmp/apt-dpkg-install-KhyIlO/01-kodi-x11_2%3a18.4+git20190831.2224-final-0bionic_amd64.deb (--unpack):
    poging tot overschrijven van '/usr/lib/x86_64-linux-gnu/kodi/kodi-xrandr', wat ook in pakket kodi-bin:amd64 2:17.6+dfsg1-1ubuntu1 zit
    dpkg-deb: fout: plakken subproces werd afgebroken door signaal (Gebroken pijp)
    Voorheen niet geselecteerd pakket python-cryptodome wordt geselecteerd.
    

    Try removing any Kodi packages you have installed and re-try the installation from the RetroPie setup.



  • @mitu thanks dude, that was it.
    i had removed everything with kodi- before it in
    synaptic package manager and then reinstalled kodi
    from binary in retropie and restarted retropie/es
    and now kodi shows up and runs within ports!
    thanks you



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.