Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

sda2 is not an SD card. Don't know how to expand



  • raspi-config expand file system only works on sd card. It just gives the error sda2 is not an SD card. Don't know how to expand

    Anybody know how to expand on hard disk?



  • Please provide us with more information, see https://retropie.org.uk/forum/topic/3/read-this-first

    In addition to that, please describe step by step what you tried to do, what you did expect to happen, and what did or didn't happen instead. Post any console commands and their complete output in code blocks.


  • administrators

    did you flash the retropie image to a hard drive instead of the sd card? are you trying to boot from the harddrive?



  • Yes thx herb I am. Booting from an OLDEN 1TB hardrive that was top of the line a long time ago. I tried easus. waste of time. I tried mini partition tool. Nop. Only thing that worked? gParted. FTW!
    fdisk -l shows

    Device Boot Start End Sectors Size Id Type
    /dev/sda1 * 8192 124927 116736 57M e W95 FAT16 (LBA)
    /dev/sda2 124928 1953523711 1953398784 931.5G 83 Linux

    Moral of the story just use gPared. Everythig else is a waste of time.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.