Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Gamepad Registration Issue



  • Hi All. I cannot get any response from my PowerPlay PS2/3 Gamepad. It is registered in devices and estest, however when I run estest, it doesnt respond to any buttons/movements. Any ideas or good guides to help? I have installed only the generic xbox driver in RetroPie and disabled it



  • @macraem said in Gamepad Registration Issue:

    however when I run estest
    I mean evtest


  • Global Moderator

    If it's not responding to evtest, then the OS (Linux) doesn't see it as a gamepad, so there's nothing that RetroPie can do about it. Did you try it on a (Windows) PC to see if it works ?



  • Thanks @mitu the controller does register and is usable on a PC but nothing on the pi. I tried a The64 Joystick on the pi - and it worked straightaway, so it does seem the controller isnt compatible



  • @macraem That seems a little strange, because every controller that correctly registers as a "human interface device" (HID) should work out of the box in Linux/Retropie. Drivers should only be necessary for special functions that aren't part of the usb standard for HIDs.

    If you want to dig a little deeper, look at the output of these commands:

    dmesg
    

    right after connecting the device, or

    tail -f /var/log/syslog
    

    before pluggin in the device, then plug it in and watch for upcoming messages. Stop this command with Ctrl + C.



  • Hey @Clyde thanks for your comments. I tried the tail command, and after plugging in my controller I get 'Device was not an MTP Device'. Any further ideas?


  • administrators

    Does the pad have any different power on modes?

    Can you post the dmesg output after plugging it in. Use a pastebin site for the output and post a link.

    Also output of lsusb -v may help.



  • @BuZz There are no different power modes, although the cable is a split USB / PS2/3 interface (so you could plug straight into a PS2/3 console if you wish. I have attached the dmesg output here - I hope this helps?



  • @macraem According to dmesg, you controller registers as a Shanwan PS3/PC gamepad. Retropie has a special driver for Shanwan PS3 clones. This video tells you how to set it up:

    I'll have to say, though, that I have no experience with this. I just searched the web a little bit. So (and on principle) you should backup your system before following the steps of some YouTube video.



  • Thanks @Clyde althought I have followed this video. After installing the Shanwan drivers, the video says the USB connection should work, and he goes on to discuss Bluetooth. However my controller is USB only and isnt recognised in EmulationStation or evtest even after a reboot. Unless there is some other input blocking my controller, Im almost resigned to giving up on it and purchasing another.



  • Did anything change in the dmesg and/or tail output?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.