Please do not post a support request without first reading and following the advice in

Audio capable HDMI monitor breaks proper audio playback and impacts emulation speed.

  • Hello,

    I've installed RetroPie on a UDOO Bolt V8, which is powered by an AMD Ryzen 1000 SoC.

    I've tested RetroPie connected to my old HDMI monitor, which is not audio capable.
    Everything was working file, with excellent audio quality, using an old school analog jack.

    When I connect the system to my TV which has an audio capable HDMI input, the emulation is not able anymore to playback properly, emitting distorted and broken sound. It does not matter if I configure KDE for emiting sound on the HDMI monitor (which is audio capable) or using the analog jack audio output: the behavior is the same. Also, the overall emulation speed is impacted, as if the emulator is now considering the HDMI input in the event loop, even though I've configured KDE for emiting sound on the analog audio jack.

    I'm definitely not an expert on the matter, but I've tried suggestions from the documentation, as much as I could, since most of them are applicable to Raspberry Pi (Raspbian) but not directly applicable to a regular PC running Debian.

    I found the snippet below, which is for Raspberry Pi.
    My question is: What would be the "equivalent" of the snippet below for a PC running Debian 10, please?

    Any suggestion? Is there a troubleshooting path for Debian 10?

    If you have a standard RPi and want to send audio over the HDMI connector then it should just work. In some instances though, you will need to manually modify the raspberry pi boot config file (sudo nano/boot/config.txt) and ADD the following lines to those already there:

    # forces HDMI mode
    # Setting hdmi_force_hotplug to 1 pretends that the HDMI hotplug signal is asserted, so it appears that a HDMI display is attached. In other words, HDMI output mode will be used, even if no HDMI monitor is detected.
    # Pretends all audio formats are supported by display, allowing passthrough of DTS/AC even when not reported as supported.
    # May not be needed for all HDMI devices

    For your information:

    $ uname -a
    Linux mercury 5.3.0-0.bpo.2-amd64 #1 SMP Debian 5.3.9-2~bpo10+1 (2019-11-13) x86_64 GNU/Linux​

    I've installed RetroPie using the shell script here:

    Please let me know if you need some more diagnostics or information.

    Thanks a lot,

  • Global Moderator

    @frgomes said in Audio capable HDMI monitor breaks proper audio playback and impacts emulation speed.:

    My question is: What would be the "equivalent" of the snippet below for a PC running Debian 10, please?

    There is no direct equivalent, since those configurations are specific to the Raspbian boot loader (which alters the audio parameters for the loaded kernel modules).

    Do you have sound working at all (besides emulators) ? Are you using PulseAudio for sound ?

  • Hello @mitu

    Yes, audio and video are working perfectly with Firefox and VLC, for example.
    I can direct sound to speakers connected to an analog jack or to HDMI, which allows sound to be heard from my TV. Everything works just perfectly.

    Yes, KDE uses PulseAudio.
    I've already tried the idiot's procedure for resetting PulseAudio: remove ~/.config/pulse and restart. I've also tried another HDMI output from my UDOO Bolt, which required some reconfiguration but, honestly, not complicated... both Firefox and VLC are working fine.

    I've reinstalled everything from scratch (according to the shell script pointed in this thread).
    The point is: if I reinstall everything connected to a NOT audio capable HDMI monitor, RetroPie works just fine, playable with perfect sound from analog jack. If I reinstall everything connected to an audio capable HDMI monitor (like my TV), RetroPie performs poorly with distorted and broken sound, does not matter if I try analog jack or HDMI from PulseAudio configurations.

    I've tried to configure audio from inside RetroPie.
    I've selected different audio cards and devices, but nothing seems to make any difference.

  • Global Moderator

    RetroPie doesn't modify any sound settings on the system during installation, so as long as you have sound working, it should work also on the programs (emulators) installed.
    Check in the RetroArch settings and see what Audio settings you have set - try switching from ALSA to PulseAudio if possible and see if you get proper sound.

  • @mitu : I've configured
    audio_driver = pulse
    in /opt/retropie/configs/all/retroarch.cfg.bak all/retroarch.cfg

    No effect.

    I've even selected (in the RetroPie GUI ) audio card NULL.
    Games do not have sound anymore, as I expected.
    However, the performance is still poor, as if emulators are still aware that the HDMI monitor is audio capable and emulators are trying to do "something".

  • Global Moderator

    Looks like the performance is pretty poor, even without sound. What emulators are you running and what resolution are you using ?
    Can you run with verbose logging enabled (switch it on in the Runcommand launch menu) and then post the log from /dev/shm/runcommand.log ?

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.