Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Getting a controller to work



  • Hi,

    I really need some help. I have invested 4hrs so far trying to get my dualshock 4 controller to work and I am getting fed up now.

    I have reinstalled retropie twice(I was paranoid I had tried to many things and messed up config files) and I have read through a lot of guides and now I am back to square one. I have gone through varioIus articles in the forum too.

    I installed the latest retropie image to an 8gb card, installed it on my Pi 3 and I connected a DS4 controoler by USB cable. I have loaded some roms onto a USB stick and they show fine, I can load them fine.

    I ran through the initial controller set up and it works fine in the menu. I have changed nothing else with the controller (fresh install of retropie). When I open the mastersystem to play Alex Kidd nothing works. Retroarch flashes the controller in the bottom left when the ROM loads. But there is no response from the controller.

    On my first install I followed this guide here (in German but the screenshots made sense with Chromes auto translate of German to English) This kind of worked in that the controller worked in Alex Kidd but pressing A punched and pressing B reset the emulator. I have tried pressing other buttons to see if it mapped incorrectly but they all do anything except but what button B would do). I went into the retroarch config file for the mastersystem via winscp and tried to manually map the buttons but there was so much information in there I didn't know where to start.

    I went into retroarch within the game and remapped the buttons again but it just kept doing the same thing, A (circle on DS4) would punch but B (x on DS4) would reset the emulator again.

    I have tried an Amiga and Atari 2600 ROM and I am just having a whole host of issues.

    I am close to tearing my hair out. Can someone help me please?


  • Global Moderator

    Looks like you've not defined a Hotkey when asked in EmulationStation input mapping - that's why B resets the current game.
    What version of RetroPie are you using ? Can you add more info about your setup, as detailed in https://retropie.org.uk/forum/topic/3/read-this-first ?



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.