Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Golden Tee Fore and CHD/Eagle BIOS issues....other CHDs have worked for me fine.



  • Hello everyone!

    Over the holidays I received an Arcade 1up machine which I have been customizing with a RasPi 4 and Retropie to play a bunch of games. I spent a good time learning and experimenting with the software before posting on here, but the only issue I still seem to hit is trying to run any of the newer Golden Tee games from Fore! onward and wanted to ask for any input.

    Ive learned about CHD games and how they work. Ive successfully gotten Killer Instinct and Blitz to work in Mame, both with their respective CHD files. Im placing the game rom zip file in my Arcade folder in Retropie, and each CHD in an empty folder with the same name as the zip rom file. (info learned from these forums thx) Those both are running semi slow, but actually load. Ive scoured almost every google search I can to try and see how to get Golden Tee Fore to work, but ive had no luck.

    After booting GTFore! I get to a black screen with a white box around the edge and then it flashes and goes back to the main menu. I am assuming that possibly this is due to the itEagle.zip file I have? or maybe the CHD? (but I have tried many CHD files) I have my eagle BIOS zip file in my Arcade folder just like the CHD folder, but it has kept its original name. (info once again learned in these forums, thx).

    Can anyone help me diagnose this issue? I have spent hours trying to just see if I can get this game to load (regardless of how it runs) because then I can decide if I want to upgrade my comp running retropie or not. For some reason Golden Tee Fore just wants to crash everytime I load it.

    Thanks! ;)


  • Global Moderator

    Please add more info about your system, as detailed in https://retropie.org.uk/forum/topic/3/read-this-first.
    What MAME/Arcade emulator are you using ? AFAIK, the GTFore games require a powerful system to emulate them, I don't think an ARM SBC will provide enough power for it to be runnable.



  • @mitu Ive been trying to emulate it in lr-mame2003/lr-mame2010/lr-mame2016 all seem to produce the same result. Basically I tried to install every mame emulator I could see in the Retropie Setup scripts.

    Even if it requires a more powerful computer to run perfectly without lag, it still should atleast boot/not crash back to the menu right? Thats whats making me think something is wrong with my BIOS file or placement of files and not the hardware....


  • Global Moderator

    According to the game's MAME history, support for it was added in 2015, so neither Mame2003 nor Mame2010 would run it. As for why mame2016 doesn't work, that's hard to say without a detailed log file - it's probably a missing or mis-named file.



  • @mitu Yeah I was pretty sure it would only run in 2016, but figured I would try all just anyway. That being said, Im pretty sure none of the files are named incorrectly.

    I have the gtfore06.zip and the iteagle.zip located in "/home/pi/RetroPie/roms/arcade".

    And in that same folder I have the CHD(unzipped) in its own folder named "gtfore06" (/home/pi/RetroPie/roms/arcade/gtfore06/CHD file)

    This according to the docs and wiki should be correct right?


  • Global Moderator

    @sssetz said in Golden Tee Fore and CHD/Eagle BIOS issues....other CHDs have worked for me fine.:

    This according to the docs and wiki should be correct right?

    Not necessarily - do you have the right ROMset for Mame2016 ? Was it validated ?



  • @sssetz Same EXACT problem for me too. I have a more powerful PC that can run it fine so it might be the RPI4 just isn't powerful enough, but my PC is also running a more updated version of MAME. If the latter is the case then the problem is probably the rom zip file because I think Mame2016 can run romsets up to 1.74 (or something close). It's possible that the rom zip file is too up-to-date for Mame2016 to run it properly.

    There's also someone on youtube (therexershow) who commented to me that he's going to try and make a video about making Golden Tee Fore run on the RPI4.

    I'm actually really tired right now so I hope what I wrote makes sense, lol.



  • @sovereign120 Hey sov, thanks for helping me confirm Im not the only one.

    Just as a sanity check, I'm pretty sure I have the correct roms and CHD for mame2016. I found them from the removed site (edit: links removed). Ive also found them MANY other places, but these ones seem like the most reliable, especially for 2016.

    I guess my eagle BIOS file could be bad, but not sure where to find a reliable one of those as most seem to be all the "same"?

    @sovereign120 if that video ever surfaces of GTFore on a RPI4 PLEASE LEMME KNOW :) :)


  • Global Moderator

    @sssetz Please remove the links to ROMs, as per the forum rules.

    EDIT: if you want to diagnose this further, please provide a log file from running the ROM (taken from /dev/shm/runcommand.log). Enable verbose logging from the Runcommand launch menu before launching the game.



  • This post is deleted!


  • @mitu Here is a picture of the errors I am getting from running GTFore06 (sorry not sure how to actually get the text log from the RPI to my comp?) IMG_1411.jpg


  • Global Moderator

    Looks like a generic ROM is not good error.



  • @mitu ok, and by that you mean just the generic gtfore06.zip file? or the iteagle? Cause isnt the iteagle technically the rom file for games like GTFore?

    I'll try to get a different gtfore06.zip file right now and report back, thanks again for the help!


  • Global Moderator

    I'm not sure if it's worth the hassle. In the log file you notice there's one message about a particular ROM that doesn't have a good dump (g4c-us-u.u53), hence the warning about 'The machine might not run correctly'. It could be that the gtfore06 ROMset was incomplete at the time and was promoted to working later on.



  • @mitu Ok, but im not really sure what that means? Can you clarify for me a bit more? Obviously some people have got this game to work....thanks for your input in this sitch, really appreciated.


  • Global Moderator

    @sssetz said in Golden Tee Fore and CHD/Eagle BIOS issues....other CHDs have worked for me fine.:

    Obviously some people have got this game to work.

    The other reply in this topic suggests otherwise.

    Let me explain my previous reply. Sometimes games/machines are added to MAME even if their emulation is imperfect or not working at all. Some of them are missing parts of the original (see the message about missing ROM in the log). In time, emulation improves and they're 'promoted' to working. You can see for instance the release notes for the latest version, which mentions which games are working/which are marked as non-working, etc.
    It is possible that this particular version of the game was not complete in the MAME version you have (2006) and it's not working or the emulation is not complete.



  • Awesome, thank you for this info. I definitely understand that issue, but still dont completely understand as I have seen people emulate this game successfully. But I'll keep looking into it as it doesnt seem like a clear error at this point.



  • @sssetz basically what @mitu is saying is as the emulator improves, it’s also discovered that the older rom dumps are not that good. MAME, as a project, will no longer support an older version of a dump. Unlike NES or SNES etc, if a dump is bad, the emulator will attempt to play regardless. Their may be no issue running a bad dump. It may not even effect the emulation at all. It’s just just a byte for byte dump of the rom. But MAME needs the correct rom version to run.



  • @lostless Appreciate the input from you and @mitu but I'm still not sure why it wont load in the end. I'll keep tweaking it and see what I can get but I'm getting to the end of my options....as I've scoured every forum for GTFore and cant seem to distinguish why I cant get it to run. Ive gotten other CHDs to run, and even though they are slow I can get them to atleast boot and run.

    Even if GTFore doesnt run great, I'd still love to diagnose why its not actually booting. You mentione "it will no longer support an old version of a dump. But SNES/NES does..." Does that mean its an emulator issue or a rom issue with a older version of a dump...



  • Check your error message it's saying this rom has not been found "ROM_LOAD( "g4c-us-u.u53", 0x0000, 0x0880, NO_DUMP )" it should be inside gtfore06.zip



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.