Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

  • Got it to work momentarily with an XBox controller (I use by default a saturn controller with adapter); I remapped it properly, and it worked... weirdly ( start is on R2 ); entered retroarch to try and select the saturn controller for player one but instead of the saturn controller only the name of the adapter was displayed... couldn't go back, tried to reboot... and couldn't (I can write the login but not the password...)
    Feel sort of cursed!

  • Global Moderator

    @soge73 The password is not echoed at the terminal - you don't see *** like on windows. You just need to write it and then press Enter to login.


  • OK, I could see it right before though...
    well it seems retroarch doesn't recognize my saturn controller anymore (detects the adapter), it worked just fine before I fiddled with the online updater menu...
    how can I revert what I did, should I delete or replace some files with SSH ?

    I could get the "options" content in the lr-vice retroarch menu though, which is why I wanted to update retroarch in the first place...

  • Global Moderator

    @soge73 Remove/rename any retroarch.cfg file you find under /opt/retropie/configs/ and sub-folders. There's a global retroarch.cfg and each system has it's own (short) retroarch.cfg.

    Then, re-install/update all packages.


  • Just tried (well, I removed the files in "all" and "snes", in which I've been doing the tests), updated, rebooted , redid the "configure input"... doesn't work.

  • Global Moderator

    @soge73 Can you enable Verbose Logging when you start your emulator from the Runcommand launch menu and post the contents of the /dev/shm/runcommand.log file on pastebin.com ? This should show how the inputs are detected and where are the input configuration files located.

    Did you modify any permissions on any of the configuration folders ?


  • Yes I think I tinkered with the permissions (followed a tutorial to get access to the root with Putty)

    Here is the log if I did everything right: https://pastebin.com/9FxhKxqV

  • Global Moderator

    Is this the complete log ? It looks truncated.

    I advise you to re-install and don't change any permissions after the installation. You don't need root to use RetroPie. If you need any info, ask in the forum, but take a look first in the Docs to see if your question hasn't been documented or explained before.


  • Don't know if I did the copy-paste correctly sorry...

    Anyway I reinstalled, updated all packages, and everything works smoothly (what a joy to be finally able to try the c64!)

    Many thanks for your help, I know now NOT TO MESS WITH PERMISSIONS!


  • @soge73

    Thanks for posting - this helped me with lr-vice as well!

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.