Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Odd Issue with SD Card Size



  • Hi everyone, I'm having a bizarre issue with my 128 SD Card. I was working on my set up and making coding changes when I realized that I had made some mistakes. So I decided to go back to my backups and start from my back up.

    I wipe the SD card & formated it; when I checked the SD card, it still says 128GB of 128GB of space available (Note it's more like 127... since there's a lil space taken up, as you know). Then I flash it with my back up (about 90GB with games). Once the flashing is done, when I look at the SD Card stats, it now says my SD card is only 59.6MB in size, and 48MB is available for work.

    It won't let me add any new code from GitHub or any games because it doesn't have space. Initially, I thought this might be a Mac OS issue since on one of the latest Mac OS updates when you formatted a drive, it would "Make" the drive appear as only MB, and the system would reject adding things to it. However, after I format, it's still 128GB; it only occurs after I flash it. I tried on my very old Mac (2004), and the same thing happened.

    Weirdly, all the games are on there, and the 90+GB that I flashed is there, it works and plays the games, I just can't add anything new to it or add anything new from Github because it thinks it's 59.6MB.

    Any ideas on what this could be or how to fix it?

    My System Info: Mac OS: El Capitan
    SD CARD: San Disk Ultra 128GB A1 (10)SDXC 1
    Raspberry Pi 2B


  • Global Moderator

    Are you sure you're not looking at the boot partition when checking the size ? macOS cannot read natively the Linux ext4 filesystem on the 2nd partition, so it cannot see how much is there.
    How are you 'adding things from Github' to your installation ?



  • Could this be that after you flash it, you need to boot it up in the pi to let it grow to the full size of the card?



  • @mitu I've tried adding things from github, through the retropie and even something around 100mb it rejects.



  • @HurricaneFan I'll try this tonight when I'm off work (working from home due to COVID - but can't get too deep into it) I'll let you know how it works.



  • @HurricaneFan Ya, that wasn't it ;-( I did this originally before I backed everything up.



  • @pie_droid
    The image that you made may have been shrunk, after restoring your backup there is an option the expand the filesystem manually. Find it in raspi-co fig. Hope that helps. And the filesystem that was showing ~50 mb was possibly normal for the boot partition and is separate from the rest of the data.



  • @pie_droid ahh gotcha.



  • @mitu I wanted to circle back, you were right. In the terminal, I typed df -h / this got me the info on the SD card. So, that resulted in 118gb Space, 113gb used, 0 Space available, 100% used up.

    I thought this was odd, my SD card should be close to 128gb. Anyways, I deleted a bunch of games, etc and ran the same command and got the following:

    118gb space, 103gb used, 10gb space avail., used 92%

    So like I said, you were right!

    Thanks!



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.