Please do not post a support request without first reading and following the advice in

  • Hi everyone,

    Just gone upstairs into my spare room and dug out a box of old cassettes that I kept long after my Sinclair Spectrum died. Found an old game that brought back so many memories as a young child and couldnt wait to play it. The game is called Jumping Jack by Imagine Software from 1983.

    As I went to download it from an online site I noticed there were 2 versions of it. One has a TZX extension and one has a TAP extension. After a bit of reading about spectrum emulation, I opted with the TZX image as its apparently a perfect tape image.

    When loading the game, I plugged my USB keyboard in as the game was keyboard only. The keyboard didnt work so removed the USB joypad as I thought it might have conflicted. Disconnected the keyboard and replugged the joypad in thinking that I could quit out. Nothing working on the joypad at all. Had to hard reset by pulling the plug. Next time I thought id not plug a joypad in, but just leave the keyboard plugged in. Switched it on, and RetroPie complained of no joypad and went to some command prompt screen. With no knowledge of Linux I didnt know what to type so pulled the plug a second time.

    When just the joypad is plugged in, the hotkey for quit (start and select) works. As soon as I plug the keyboard in, BOTH stop working. The only key that works is the SCROLL LOCK key on the keyboard when pressed says GAME FOCUS ON and OFF in the bottom left. This then needs a plug being pulled. Tried the TAP image too and this is the same.

    Anyone know how to play speccy games or any reason why the keyboard doesnt work. The keyboard is new and works perfectly when plugged into my laptop.

    Please help someone!!!!

  • Global Moderator

    Take a look at, since I assume you are using lr-fuse. Particularly, change the device type for your controls from retropad/joystick to Sinclair Keyboard.

  • Thanks mitu. My Pi has just gone spectacularly wrong. Will try when its working again (just posted about it in another thread).

    Thank you.

  • Will try to configure the Speccy again once I can get the wife off Galaxian haha

  • Thats great. I can play the keyboard games, but just cant get any joysticks to work. Tried all the options...Kempston, Fuller, Sinclair 1 and 2 etc and nothing is working? Ive followed the instructions but maybe I need to download something else?


  • @vasquez109

    This old thread may be useful -

    Remote into your pi and find retroarch.cfg for the zxspectrum - opt/retropie/configs/zxspectrum

    Find the following line: -input_libretro_device_p1 =

    and make sure it says

    input_libretro_device_p1 = "513".

    This will set your joystick to Kempston by default.

    Hope that helps

  • Thank you. Will try when I get home!

  • Just tried doing that and found that and my retroarch.cfg file is in RETROPIE/configs/zxspectrum and this is what is in it:

    Settings made here will only override settings in the global retroarch.cfg if placed above the #include line

    input_remapping_directory = "/opt/retropie/configs/zxspectrum/"
    input_libretro_device_p1 = "513"

    #include "/opt/retropie/configs/all/retroarch.cfg"

    Still no joy playing one of my favourite games. Just wondering if someone could try loading the game and see if they get the joystick to work. The game is called "Island of Dr. Destructo" or sometimes just "Destructo".

    Thanks for your time.

  • Global Moderator

    The game has to be configured to use the Kempston joystick for player 1 or player 2. So if you choose to change the device type of Port 1 to Kempston Joytick, you'll also need to enter the game configuration and choose that using the virtual keyboard.

    Easier to do is using the core Options, where you can assign the gamepad to the default keyboard bindings used by the game:

    Here's how it might look:


    After you assign keys to the gamepad actions, choose 'Create game-options file' in from the same Options menu (1st option) and the options will apply only to this game. After saving the game's options, clear out the actions - so other games will not get these set of options.

  • Thank you. Reliving the good old days finally! One last question, is there a way of resetting the machine and go back to sinclair basic or the boot up screen without it loading the tape image? Reset within retroarch reloads the tape image again. I just want to go and have a mess around with Sinclair BASIC.

    Thanks for your help.

  • Global Moderator

    Try creating an empty file (basic.tap) in the ROM folder and load it.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.