Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

powerblock 2.2 power issues.



  • i got a powerblock about 2 weeks ago, when i tried my power supplies none of them worked. kept causing brown outs and showing the rainbow voltage warning. i figured my phone charger wasnt enough juice so i went and ordered a 5.25v 3.5 amp usb c power supply. more than enough power i thought. still showing the low voltage, causing brown outs, ect. i have a hat on the pi as well. so i removed it and put the powerblock straight to the pi with no hat and still having the same power issues. its like the powerblock isnt allowing enough power to pass through it. is this a defect board? i installed the drivers and scripts but still, warnings. any help would be appreciated.
    i have a raspberry pi 3b+ and have removed the fan hat from the board so i wont need to worry about that.



  • update: ive tried the board on another pi and the same issues, ive tried 4 different usb c supplies and removed anything that could draw power and the powerblock is still giving me the low voltage warning


  • Global Moderator

    Hi! I am sorry to hear that! We tested the PowerBlock with quite a few extension boards and that should not happen at all.
    Please contact me via email or webform (https://www.petrockblock.com/contact/) so that we can arrange a replacement.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.