Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

mame2003-cheats setting ignored in core config



  • Cheats have stopped working with mame2003 (database not found) and I'm trying to fix it for my brother. I have the cheat.dat & mame2003.xml in /home/pi/RetroPie/BIOS/mame2003/.

    I set mame2003-cheats = "enabled" in /opt/retropie/configs/all/retroarch-core-options.cfg with no success, so I rebuilt mame2003 from source (commit hash below) to see if the latest version would help me.

    This new version saw the parameter names change from using - to _ so I also added mame2003_cheats = "enabled" to /opt/retropie/configs/all/retroarch-core-options.cfg because one of those should work, right?

    Then I found out that the core options in the above file are being ignored and are instead being read from /opt/retropie/configs/mame-libretro/retroarch-core-options.cfg; I was able to disable the nag warning by setting mame2003_skip_warnings = "enabled" in the mame-libretro core config even though it had already been set in the all core config.

    TL;DR, to have all the bases covered, I have mame2003-cheats = "enabled" and mame2003_cheats = "enabled" in both /opt/retropie/configs/all/retroarch-core-options.cfg and /opt/retropie/configs/mame-libretro/retroarch-core-options.cfg. But when I press R2 and select Cheat -> Enable/Disable a Cheat it always tells me the database is not found.

    Pi: 3B
    RetroPie version: 4.6.4 (commit 719d022)
    Emulator: lr-mame2003, built from source (commit 0e8554e)


  • Global Moderator

    I think the option name is changed and I'm not sure that core options influence the native MAME cheat engine.
    The enable/disable a Cheat is part of the native MAME menu, which looks for cheats.dat. The file is automatically installed with the mame2003 libretro core and its location is the BIOS/mame2003 folder.

    However, the core options are always read/written from the /opt/retropie/configs/all/retroarch-core-options.cfg, but if you have re-set your RetroArch's configuration, the location will be changed. The reset would also change where RetroArch - and the mame2003 core - looks for the cheats.dat file. That may be the cause of why your cheats are not working in the MAME menu.
    I'd advise you to use the default configuration - replace the /opt/retropie/configs/mame-libretro/retroarch.cfg with the standard RetroPie retroarch.cfg (see below) configuration file and re-try to see if Cheats are working:

    # Settings made here will only override settings in the global retroarch.cfg if placed above the #include line
    
    input_remapping_directory = "/opt/retropie/configs/mame-libretro/"
    
    #include "/opt/retropie/configs/all/retroarch.cfg"
    


  • @mitu /opt/retropie/configs/mame-libretro/retroarch.cfg is already in that state (and it's identical to retroarch.cfg.rp-dist)



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.