Please do not post a support request without first reading and following the advice in

  • Hello,

    I am using RetroPie version 4.6.6 running on an x86 system with elementary OS 5.1.7 Hera.

    I was previously running a similar setup, except on Kubuntu and it worked perfectly. I just switched to elementary OS and I would like a shortcut to launch RetroPie however I am running in to an issue.

    When I launch a game, or try to select any option in the config menu it jumps to the desktop a moment and goes right back to ES, won't launch the game, won't launch the menu option.

    First I tried just creating a desktop file and put this in it:

    Name= RetroPie
    Comment=RetroPie retro games front end.
    Type= Application
    Categories= Game

    This method has always worked but not this time, it launches but I get the issue above, so I tried to research the issue and found the suggestion to use a bash script and point the shortcut to that, so I tried that with this:

    sleep 2
    sudo pkill Xorg

    This worked, but had the exact same issue. I tried changing things around but no matter what, I get the same result.

    Lastly, I tried launching from the terminal directly. I still can't launch any config menu options but I can launch games however there is a considerable delay. It jumps to the desktop a few seconds, then a terminal window pops up, and after a few seconds the game launches.

    I did a screen recording because when it jumps to the desktop and back its quick I just see flashes, when I ran it in slow mo I could see the terminal menu pop up and request a password but then quickly close and jump back to ES.

    I would appreciate any insight anybody could share on this issue!


  • This is literally mine:

    [Desktop Entry]

    Change the icon path to yours.

    Also if you don't want to get asked how to run it you should do the following:

    Open file manager, go to your Desktop directory.

    Now, Edit, go to Preferences.


    Tick "Don't ask options on launch executable file"


    This will apply to every file on your desktop.

  • @k3001993 said in Games does not launch, goes back to ES menu.:

    [Desktop Entry]

    I tried to copy yours, get the same issue unfortunately.

    I also tried reinstalling RetroPie, and switched to KDE Neon just to experiment. Still same issue, and there apparently is no solution, so I guess I need to figure out another option unfortunately. The previous setup was an older version of RetroPIe so I can only assume something must have changed.

  • @k3001993

    One further thing, I found by changing Terminal=false to true, then a terminal window will popup asking for a password, enter the password and it works.

    So only conclusion I can draw is that it must be permissions related.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.