Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

Retropie on rpi3 not finding wifi



  • I just got my rpi3 last night. I flashed it first with 3.8.1 on a 128gb sd card. I booted it up and everything worked but my fake ps3 controller. I upgraded to the 4.0 release candidate using the built in upgrade feature and that didnt fix it. Since I tried a bunch of things I decided to flash my sd card again back to 3.8.1 to have a clean slate, and just return the fake controllers.

    Since I flashed I have not been able to get wifi working again. I go in to configure wifi and it says "0", and has an empty space beside it. The 2nd option is "hidden network". I tried both and neither will connect. The first time i did this it listed all the wifi's nearby. Now it doesn't list anything. I tried flashing it several times with both 3.8.1 and 4.0 rc1, and it does the same thing repeatedly.

    Please help,
    Thanks,
    Todd

    PS. Everything I did update and wifi wise was done via the retropie gui.


  • administrators

    What is the output of sudo iwlist wlan0 scan ? What channel is your wifi on ? If on a higher channel you might need to change the wifi country (via raspi-config / internationalization)



  • Thanks for your reply.

    "sudo iwlist wlan0 scan" outputs "wlan0 Interface doesn't support scanning."

    I tried putting NOOBS on to see if that was the same. When I click on the wireless icon (two computers) in the upper right it says "No wireless interfaces found" and the tooltip says "eth0: Link is down"

    Im still checking on the channel, but i dont think thats the issue since it did work at one time. I live in the USA.

    Ps. I got the canakit on amazon for 50, so I know the power supply is good

    Router settings:
    wireless channel: auto detect
    Security: wpa



  • If I do "iwconfig" it lists "lo" and "eth0", but no "wlan0" as it should on a pi3. Is mine broken?

    I don't know for certain, but I believe it broke when I updated "the underlying os kernel etc". Ive tried to install 3.8.1 and update everything again the way i did before to see if that kicks it back into gear. So far I have not been successful.



  • I also just got my rpi3 last night, put retropie 3.8.1 straight on, and no Bluetooth or wifi being recognized at all. tried updating and it screwed the whole OS, so will continue the fight after work today... Can anyone suggest where to go with it though? Haven't had time to try Raspian yet, or should I try older version of retropie?



  • In my research I've found three variations:

    1. Wifi and Bluetooth never worked - To me this seems like a defective board or image on your sd. Try retropie 4 and/or NOOBS (full image) to install rasparian. If that doesnt work its probably the hardware. From what I gather both wifi and bluetooth functions are on the same chip. For me, my bluetooth seems like its working, but I dont have any controllers worth testing. I got some fake ps3 controllers but I think its those that arent working and not the bluetooth. in rasparian the bluetooth icon was lit and said no bluetooth devices found.

    2. wlan0 is listed in 'iwconfig' - This seems to be the best scenario of the three. If its listed it seems like people have been 50/50 in getting it fixed. Some say that apt-get update /upgrade fixed it, or various other updates. Or reflashing the sd card. This doesnt seem to transcend os installations.

    3. wlan0 isnt listed in 'iwconfig' - This is the boat Im in. I know wifi worked at one point in time. Maybe it the chip fried, or maybe there is something wrong with the firmware or other bios/drivers stored directly on the pie. Updating the firmware didnt help, and no other command or config change works. This transcends all OS installations so in one way that limits the search and is good. But its mostly bad because the fix for the others may simply be to reflash your sd card.

    Good Luck, Im still messing with mine hooked up to ethernet, but in a week when Im satisfied with everything except wifi ill be returning it for one that is working. I know one other poster took this route. Anyway, decide what group your in and narrow your searches. If your in my group let me know, I have 4 different threads out there, unfortunately none have the answer. Mine seems to be the rarest and most unresolved, but maybe I just think Im special.


Log in to reply
 

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.