Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first
  • Global Moderator

    @aadi You can leave just hdmi_safe=1 and comment out your additions.


  • @mitu Leaving just 'hdmi_safe=1' and commented out above entries not making any difference. It seems like nothing is connected at all. No connection. Have also tried different HDMI ports on the TV but it is same. I am totally lost now, please help.

  • Global Moderator

    @aadi Post you entire config.txt on pastebin.com and provide the link.


  • @mitu Here you go config.txt

  • Global Moderator

    I'd advise to drop the overclock and try with a simpler config.txt:

    hdmi_safe=1
    dtparam=audio=on
    
    gpu_mem_2048=384
    [pi4]
    # Enable DRM VC4 V3D driver on top of the dispmanx display stack
    dtoverlay=vc4-fkms-v3d
    max_framebuffers=2
    

  • I am experiencing this exact issue with a Samsung UN55MU800D (55" as well). I have scoured the internet without success for a solution to get the Pi to work on the tv. I currently have it attached to a 32" Samsung smart tv, no issues at all. It also works on computer monitors.

    I too have tried the usual HDMI tweaks in config.txt. None of these have helped including HDMI safe mode. I have gone as far as to create other disks with 64-bit Raspberry Pi OS and Ubuntu, use different HDMI cables, and run the signal through a receiver, all with the same issue of no signal detected.

    I am by no means an expert, I'm a hobbyist who knows enough to be dangerous. I vaguely remember there being a service menu on Samsung TVs that gives controls well beyond that of the standard menu. I will try to remember the codes to get in there and see if there is anything of use.

  • Global Moderator

    @anorine if you're willing to experiment, can you dump the EDID of the TV and post it here ? You need to use SSH to connect to your Pi and run

    tvservice -d UN55MU800D.edid
    base64 UN55MU800D.edid
    # post the resulting text
    

  • I had a similar problem with a older SAMSUNG tv, here is what worked for me: https://retropie.org.uk/forum/topic/27529/solved-retropie-pi-4-will-not-display-on-old-model-tv?_=1599550253467


  • I used to have issues with my pi4 2GB getting to display 1080p on my 4k vizio tv.
    A firmware update might've fixed it. Updating retropie and answering yes to updating the kernel should do it. If not, run sudo rpi-eeprom-update manually.
    I have also tested on two different 4k samsung tv's. I don't remember the model numbers. The 40in is 3-4yrs old. The 65in is 1-2yrs old.
    I use:
    disable_overscan=1
    hdmi_force_hotplug=1
    hdmi_group=1
    hdmi_mode=16


  • @mitu Here's the text that came out after the commands:

    AP///////wBMLe4NAA4AAQEbAQOAeUR4CiOtpFRNmSYPR0q974BxT4HAgQCBgJUAqcCzAAEBBHQA
    MPJwWoCwWIoAUB10AAAeAjqAGHE4LUBYLEUAUB10AAAeAAAA/QAYSw9RHgAKICAgICAgAAAA/ABT
    QU1TVU5HCiAgICAgAToCA0/wU18QHwQTBRQgISJdXmJjZAcWAxIsCQcHFQdQPQTAVwcAgwEAAOIA
    D+MFAwFuAwwAQAC4PCAAgAECAwTjBg0B5Q5gYWVm5QGLhJABAR2A0HIcFiAQLCWAUB10AACeZiFW
    qlEAHjBGjzMAUB10AAAeAAAAAAAAAAAAAAAArQ==
    

    Additionally, after hours of messing with this, when I plugged it in today it was magically working. I had just rebuilt the box after an issue with SSD corruption. I'm still willing to pull data/test to help anyone else who has come across this issue. I also plan on rebooting a few times to see if this is a fluke.

Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.