Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

wolf4sdl black screen on launch, audio playing keyboard working



  • running the latest release of retropie on a rpi4 running stock clocks. I launch wolf4sdl from the ports menu in emulation station and I get a black screen with the audio playing in the background. keyboard works, I can press ESC and exit from the game just fine.

    the game launches correctly but I am not getting any video output. however if I navigate using the keyboard to exit the port jumps back to emulation station no problem. The log shows no errors.

    anyone have any ideas?


  • administrators

    @kaltertod please be more specific with details. Latest version isn't enough info.

    Please do not post a support request without first reading and following the advice in https://retropie.org.uk/forum/topic/3/read-this-first

    Also check dispmanx settings for wolf4sdl in RetroPie-Setup /
    -> configuration / tools)

    Should be enabled for RPI4



  • Dispmanx is enabled for wolf4sdl it is also kind of funny I cannot disable it either, runcommand.log shows no errors upon launch of the game... still have a black screen if you can point me to a log file that will give some information I will be happy to post it.



  • Pi = Rpi 4 4GB
    Retropie Version = 4.6
    Kernel Version = 5.4.51-v71+
    Controller = Xbox One S & Keyboard
    Usb Devices = Wireless Usb Keyboard Adapter (Logitech)
    Error Messages = None /dev/shm/runcommand.log Shows no Errors



  • I have uninstalled and removed all game files from the /roms/ports/wolf3d directory, removed the /roms/ports/wolf3d directory and done a full reinstall of the the port and will see if this makes a difference.


  • administrators

    @kaltertod the log shows no errors or is empty?The log may still be useful to reproduce the issue.

    If you still have the issue please post a log and also the contents of /boot/config.txt



  • Contents of the /boot/config.txt


    For more options and information see

    http://rpf.io/configtxt

    Some settings may impact device functionality. See link above for details

    uncomment if you get no picture on HDMI for a default "safe" mode

    #hdmi_safe=1

    uncomment this if your display has a black border of unused pixels visible

    and your display can output without overscan

    #disable_overscan=1

    uncomment the following to adjust overscan. Use positive numbers if console

    goes off screen, and negative if there is too much border

    overscan_left=-60
    overscan_right=-60
    overscan_top=-60
    overscan_bottom=-60

    uncomment to force a console size. By default it will be display's size minus

    overscan.

    #framebuffer_width=1280
    #framebuffer_height=720

    uncomment if hdmi display is not detected and composite is being output

    #hdmi_force_hotplug=1

    uncomment to force a specific HDMI mode (this will force VGA)

    #hdmi_group=1
    #hdmi_mode=1

    uncomment to force a HDMI mode rather than DVI. This can make audio work in

    DMT (computer monitor) modes

    #hdmi_drive=2

    uncomment to increase signal to HDMI, if you have interference, blanking, or

    no display

    config_hdmi_boost=4

    uncomment for composite PAL

    #sdtv_mode=2

    #uncomment to overclock the arm. 700 MHz is the default.
    #arm_freq=800

    Uncomment some or all of these to enable the optional hardware interfaces

    dtparam=i2c_arm=on
    #dtparam=i2s=on
    #dtparam=spi=on

    Uncomment this to enable infrared communication.

    #dtoverlay=gpio-ir,gpio_pin=17
    #dtoverlay=gpio-ir-tx,gpio_pin=18

    Additional overlays and parameters are documented /boot/overlays/README

    Enable audio (loads snd_bcm2835)

    dtparam=audio=on

    [pi4]

    Enable DRM VC4 V3D driver on top of the dispmanx display stack

    dtoverlay=vc4-kms-v3d-pi4,noaudio
    max_framebuffers=2

    [all]
    #dtoverlay=vc4-fkms-v3d
    overscan_scale=1
    enable_uart=1
    gpu_mem=512

    [Overclocking]
    over_voltage=6
    arm_freq=2100
    gpu_freq=750



  • Contents in dev/shm/runcommand.log

    _________________________________________-

    Parameters:
    Executing: SDL1_VIDEODRIVER=dispmanx SDL_DISPMANX_WIDTH=720 SDL_DISPMANX_HEIGHT=480 SDL_VIDEO_KMSDRM_CRTCID=65 SDL_VIDEO_KMSDRM_MODEID=48 /opt/retropie/ports/wolf4sdl/bin/wolf4sdl.sh "/home/pi/RetroPie/roms/ports/wolf3d/vswap.wl1"


  • Global Moderator

    @kaltertod You've disabled the Pi4 fkms overlay and you're using the KMS only GPU driver. This is not a standard RetroPie config and that's why the game doesn't work - dispmanx is not available for your system.



  • @kaltertod Did you try ecwolf instead?
    I made best experience with this mod therefore I wrote the script installer, sadly it wasn't accepted.
    Main Thread is here - but consider also that what @mitu told you. As long you are not using a standard version it's hard to help.



  • I will try and go back to fkms and see what happens oddly it worked before....... and I will give ecwolf a shot



  • Disabled full kms driver and went back to fkms still no dice.... however, I uninstalled wolf4sdl and installed ecwolf and it now works flawlessly. Thanks Ghost I will mark this solved for now.



Contributions to the project are always appreciated, so if you would like to support us with a donation you can do so here.

Hosting provided by Mythic-Beasts. See the Hosting Information page for more information.